LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2007, 11:58 PM   #1
xunilTCB
LQ Newbie
 
Registered: May 2007
Posts: 10

Rep: Reputation: 0
Problem to add a CD-ROM to the sources.list file and using it


How to configure my debian to read from cdrom? I try using "apt-cdrom add" to read from my cdrom, but it didn't work out.

And I also try to mount the cdrom using this command : "mount /dev/hdc"
but it result a message
"opscontrol:~# mount /dev/hdc"
"mount: No medium found"

Last edited by xunilTCB; 06-13-2007 at 01:10 AM.
 
Old 06-13-2007, 01:15 AM   #2
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 37
Code:
sudo apt-cdrom
From Raiden's Realm Kubuntu review
 
Old 06-13-2007, 01:38 AM   #3
xunilTCB
LQ Newbie
 
Registered: May 2007
Posts: 10

Original Poster
Rep: Reputation: 0
I'm login as a root user. I also have try to use this command "apt-cdrom -d=/dev/hdc add"
Code:
opscontrol:~# apt-cdrom -d=/dev/hdc add
Using CD-ROM mount point /dev/hdc/
Unmounting CD-ROM
Please insert a Disc in the drive and press enter
Mounting CD-ROM
E: Unable to stat the mount point /dev/hdc/ - stat (20 Not a directory)
E: Unable to stat the mount point /dev/hdc/ - stat (20 Not a directory)
E: Failed to mount the cdrom.
Code:
opscontrol:~# apt-cdrom -d=/media/cdrom0 add
Using CD-ROM mount point /media/cdrom0/
Unmounting CD-ROM
Please insert a Disc in the drive and press enter
Mounting CD-ROM
E: Failed to mount the cdrom.

My /etc/fstab file is like below:
Code:
<file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,auto  0       1
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
i really appreciate all the help.Thanks
 
Old 06-13-2007, 01:49 AM   #4
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Have you looked at section 2.4 of the apt how-to?
 
Old 06-13-2007, 02:38 AM   #5
xunilTCB
LQ Newbie
 
Registered: May 2007
Posts: 10

Original Poster
Rep: Reputation: 0
I have solve my problem, this is not related to any command i used but is the stupid mistake cause by me. I really apologize for disturb u all. Anyway, thanks for all the help, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Recommendation for Debian Etch sources.list ( /etc/apt/sources.list ) forgox Debian 6 05-05-2007 02:57 PM
Noob to debian - add repos to sources.list kdrlx Linux - Newbie 1 01-29-2007 01:32 AM
KDE 3.5 - add what to sources.list? PlainDave Debian 7 01-12-2007 05:09 AM
Add ExtraCD's to Sources list maury0324 MEPIS 4 03-04-2006 05:01 PM
HowTo add specific location into sources.list? Mathsniper Debian 1 08-28-2005 05:21 AM


All times are GMT -5. The time now is 04:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration