LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-06-2011, 05:20 AM   #1
mansoorsherazi
LQ Newbie
 
Registered: Mar 2011
Posts: 2

Rep: Reputation: 0
Unhappy Postfix not accepting parameters


hi

I am new to linux i am trying to set up a mail server for testing but I am stuck in beginning.

the problem is i am changing the parameters in main.cf file but postfix is not accepting them. its still inheriting my system's host name and domain

here is my configuration

my main.cf file

myhostname = mail.example.com
mydomain = example.com
myorigin = $domain
mydesitination = $mydomain, $myhostname, localhost.$mydomain, localhost
other all values are default.
my hosts file

127.0.0.1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6
192.168.1.3 m1 mail mail.example.com


And there is the problem

[root@m1 ~]# service postfix start
Starting postfix: [ OK ]
[root@m1 ~]# postconf -d myhostname
myhostname = m1
[root@m1 ~]# postconf -d mydomain
mydomain = m1
[root@m1 ~]# postconf -d myorigin
myorigin = $myhostname
[root@m1 ~]# postconf -d mydestination
mydestination = $myhostname, localhost.$mydomain, localhost


Nothing is accepted. I have test this on CentOS 5.5 and Fedora 14 both have the same result. Please Correct me that where i am wrong. Thanks
 
Old 03-07-2011, 01:39 AM   #2
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Rep: Reputation: 165Reputation: 165
"postfconf -d <whatever>" shows default settings. try "postconf <whatever>".

Last edited by Berhanie; 03-07-2011 at 01:41 AM. Reason: typo
 
1 members found this post helpful.
Old 03-07-2011, 01:48 AM   #3
sandy.bhadoriya
Member
 
Registered: Dec 2010
Posts: 31

Rep: Reputation: 3
just try running this command
ls -d cd /etc postfix-[0-9]* | cat | while read line; do /usr/sbin/postfix -c /etc/$line start; done
 
Old 03-08-2011, 10:56 AM   #4
mansoorsherazi
LQ Newbie
 
Registered: Mar 2011
Posts: 2

Original Poster
Rep: Reputation: 0
Thanx Berhanie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix server configured for TLS not accepting connections lxvor Linux - Software 2 08-19-2010 11:28 AM
Postfix - accepting mails for a concrete recipient tikit Linux - Networking 7 09-08-2009 10:04 AM
Postfix still accepting non FQDN PcPixel Linux - Server 3 11-21-2007 09:22 PM
postfix not accepting external emails samnjugu Linux - Server 14 03-18-2007 07:04 AM
Postfix smtp not accepting connections Spleenie Linux - Software 0 01-23-2005 06:04 AM


All times are GMT -5. The time now is 05:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration