LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-21-2004, 09:21 PM   #1
splashdream
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
please don't laugh...


how do you boot Fedora in Text mode? I have installed Fedora in a VMWare Virtual Machine and am trying to exit the GNome GUI to install the VMWare Tools which requires that "X" not be loaded.

sorry to ask what is probably a very basic question but I have just picked up Fedora as my introduction to Linux to hopefully break my reliance on Microsoft products at home.
 
Old 01-21-2004, 09:27 PM   #2
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
There might be an easier way but:
As root, edit /etc/inittab - change the line that says
Code:
id:5:initdefault:
to look like
Code:
id:3:initdefault:
.

If you restart the computer, it will come to a text login prompt, and you will need to type "startx" to get into gnome. You can change the /etc/inittab back when you are done.

I hope this helps
From Ian
 
Old 01-21-2004, 09:38 PM   #3
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
another way is to hit ctrl-alt-F1, then 'kill ####' your desktop manager, whether it's gdm (gnome) or kdm (kde). To find out which, you can run 'ps -A | less' (the pipe command is the one above your backslash, generally).

If you use Lilo as your bootloader, you can also use 'linux single' which is similar to MS Window's "safe" mode. 'linux 3' will boot you into init 3, which runs everything but the GUI, generally.

Hope these ideas help a little.
 
Old 01-21-2004, 11:29 PM   #4
t3___
Member
 
Registered: Sep 2003
Posts: 240

Rep: Reputation: 30
for a one time deal you can always enter the command "init 3" in a terminal window to "drop down" to command line only, then enter "init 5" (no quotes btw) to reload the window manager.
 
Old 01-21-2004, 11:39 PM   #5
psycho2004
LQ Newbie
 
Registered: Jan 2004
Location: Mexico
Distribution: Mandrake 9.2
Posts: 15

Rep: Reputation: 0
i think ctrl+alt+backspace works as well, it'll "kill" x server (just for that one time)
 
Old 01-21-2004, 11:41 PM   #6
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
to make sure it boots into the bash promt, just edit /etc/inittab

around after the runlevel definitions are made youll see a comomand like
1:123:respawnwhatecver program and stuff)
change it to read
1:123:respawn:bash --login

just be sure to comet out anything else with respawn in it and not to delet it cuse then ur stuck


er stupid sad face!!!! its a : ( with no space but it dame it a smilY!!!!!!! EERRRRR!
 
Old 01-22-2004, 01:35 AM   #7
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
>"i think ctrl+alt+backspace works as well, it'll "kill" x server (just for that one time)"

That works with startx, but gdm, kdm, and similar are annoyingly persistant. When you hit ctrl-alt-backspace, it kills the xserver, but they automatically try and reboot it.

It's still useful, especially when troubleshooting, but not like it used to be.
 
Old 01-22-2004, 04:04 AM   #8
psycho2004
LQ Newbie
 
Registered: Jan 2004
Location: Mexico
Distribution: Mandrake 9.2
Posts: 15

Rep: Reputation: 0
thanks for the heads up scott_R, I was beginning to wonder what was wrong when X kept coming up after i hit those keys over and over.
 
Old 01-22-2004, 11:44 AM   #9
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
In X, CTRL+ALT+F2. You'll be in command line.

su -
enter root password
init3

That should kill your X server. Now, follow the advice of IBall and you'll be booting into command line permanently (unless of course you change it back to the init5).
 
Old 01-22-2004, 05:31 PM   #10
splashdream
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for all the variations on how this task could be completed. WOW! The power of linux I like choices!

I ended up launching a console and entering init 3 then when completed init 5. Worked like a champ!

Now, how do I modify the bootloader so that I have a terminal mode option?
 
Old 01-22-2004, 05:51 PM   #11
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Quote:
Originally posted by splashdream
Thanks for all the variations on how this task could be completed. WOW! The power of linux I like choices!

I ended up launching a console and entering init 3 then when completed init 5. Worked like a champ!

Now, how do I modify the bootloader so that I have a terminal mode option?
Now when you say you want to modify the bootloader so you have a terminal mode option do you mean that you want to boot into command line or just have the option to choose command line OR GUI login?

As far as I know, you choose EITHER command line OR GUI permanently, but not a both. Nothing, is of course permanent as you can edit your /etc/inittab again. But, I find booting to command line first, then going into X is much easier on my stress levels.

Lots of times booting to X will be hell to get out of (as you found out). So, rather than going through all that, I just type:

startx

after I login to my terminal and go to X that way. It's 7 extra keystrokes that will keep you from stressing. And if something goes wrong with X, it will usually dump you back to command line with errors rather than putting you in a looping hell.
 
Old 01-22-2004, 10:39 PM   #12
splashdream
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Original Poster
Rep: Reputation: 0
thanks Texicle! I will take your advice and avoid the potential of the infinite loop.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I know I shouldn't laugh, but......... bigjohn General 2 08-06-2005 05:45 AM
I got a good laugh out of this Jmcatch742 General 19 07-25-2005 03:08 AM
Are you bored? Want to have some laugh? neo77777 General 9 12-08-2002 04:16 PM
/evil laugh u02gtt General 0 04-20-2002 10:15 AM
Don't laugh... gdc34 Programming 5 04-02-2002 06:58 AM


All times are GMT -5. The time now is 06:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration