LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-28-2013, 02:26 AM   #1
pavanchauhan
Member
 
Registered: Nov 2013
Posts: 36

Rep: Reputation: Disabled
phpmyadmin


hello sir
i'm using cenots 6.4 32 bit os
i have download phpMyAdmin-4.1.2-all-languages.tar
nd i have extract to /var/www/html
i have also change authentication cookie to http in php.inc.php.
when i open browser and type http://localhost/phpmyadmin
then
only php files appears on my browser but php GUI mode is not appear on my browse. and it does not ask me username and password.
however i have restart service succesfully httpd, mysqld
please help me what am i do. Please its so urgent

Last edited by pavanchauhan; 12-28-2013 at 02:27 AM.
 
Old 12-28-2013, 04:42 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,598

Rep: Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532
Quote:
when i open browser and type http://localhost/phpmyadmin then only php files appears on my browser but php GUI mode is not appear on my browse. and it does not ask me username and password
Make sure that in the apache config file ( /etc/httpd/conf/httpd.conf), you have added index.php among the other index files in the DirectoryIndex option, so looks like this
Code:
DirectoryIndex index.html index.htm index.php
Don't forget to restart apache afterwards

Regards
 
Old 12-28-2013, 05:03 AM   #3
pavanchauhan
Member
 
Registered: Nov 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
Sir Simply i have used this following steps but i can't access php.


[root@localhost download]# tar jxpvf phpMyAdmin-3.5.6-all-languages.tar.bz2

Step: 4 Move phpmyadmin folder to default document root of apache web server

[root@localhost download]# mv phpMyAdmin-3.5.6-all-languages /var/www/html/phpmyadmin

Step: 5 [root@localhost download]# cd /var/www/html/phpmyadmin/

Step: 6
[root@localhost phpmyadmin]# cp config.sample.inc.php config.inc.php

Step: 7 Now edit config.inc.php file , change Authentication type from cookie to http

[root@localhost phpmyadmin]# vi config.inc.php




save & exit

Step: 8 Now start the apache and mysql service

[root@localhost phpmyadmin]# service httpd restart

[root@localhost html]# /etc/init.d/mysqld restart

Note : 1. Also Make sure selinux is disabled or else write the selinux rule, so that apache can read phpmyadmin files
2. Set the mysql root password if not set use below command :

[root@localhost ~]# mysqladmin -u root password NEWPASSWORD

Step:9 Now Access phpmyadmin from your broswer

http://localhost/phpmyadmin or http://192.168.2.129/phpmyadmin

Last edited by pavanchauhan; 12-28-2013 at 05:05 AM.
 
Old 12-28-2013, 05:07 AM   #4
pavanchauhan
Member
 
Registered: Nov 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
but after restart my httpd, mysqld service thenafter i open browser and type http://localhost/phpmyadmin or 192.168.0.150/phpmyadmin thenafter only phpmyadmin files appear on my page, which i have put and extract in /var/www/html location.

Please help me
 
Old 12-28-2013, 05:12 AM   #5
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,598

Rep: Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532
Quote:
Originally Posted by pavanchauhan View Post
but after restart my httpd, mysqld service thenafter i open browser and type http://localhost/phpmyadmin or 192.168.0.150/phpmyadmin thenafter only phpmyadmin files appear on my page, which i have put and extract in /var/www/html location.

Please help me
If you click on index.php, I guess you'll see the phpMyadmin GUI.
As I've told you you need to add index.php in the apache DirectoryIndex directive
 
Old 12-28-2013, 05:14 AM   #6
pavanchauhan
Member
 
Registered: Nov 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
Unhappy

I'm Sending you a screenshot which appear on my browser.
Please check and i had told you all steps of my php configuration
and i have no any entry in "/etc/httpd/conf/httpd.conf" file.
Please tell me properly steps, what should i do.
Attached Thumbnails
Click image for larger version

Name:	php.jpg
Views:	11
Size:	110.9 KB
ID:	14356  
 
Old 12-28-2013, 05:20 AM   #7
pavanchauhan
Member
 
Registered: Nov 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
when i type "http://localhost/phpmyadmin/index.php"
then index.php page coding appear on my page.
Please help sir!
i'm using centos 6.4 final version, 32 bit
Attached Thumbnails
Click image for larger version

Name:	php2.jpg
Views:	4
Size:	80.8 KB
ID:	14357  
 
Old 12-28-2013, 08:25 AM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,598

Rep: Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532
For the 3rd time, I'm telling you that you need to open /etc/httpd/conf/httpd.conf and add index.php in DirectoryIndex directive, so it looks like:
Code:
DirectoryIndex index.html index.htm index.php
 
Old 12-28-2013, 08:55 AM   #9
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,598

Rep: Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532
Quote:
Originally Posted by pavanchauhan View Post
when i type "http://localhost/phpmyadmin/index.php"
then index.php page coding appear on my page.
Please help sir!
i'm using centos 6.4 final version, 32 bit
If you see the php code, then php is not installed in your system. To install it, run:
Code:
yum install php
To install the various php modules, have a look here
 
Old 12-28-2013, 12:58 PM   #10
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
For that matter, phpmyadmin should be available via yum. If installed that way, all of the correct dependencies (including PHP) should get installed automatically.
 
Old 12-29-2013, 11:53 PM   #11
pavanchauhan
Member
 
Registered: Nov 2013
Posts: 36

Original Poster
Rep: Reputation: Disabled
sir first I was try to install yum, and i had download latest epel rpm and i had install
but when i install by yum "yum install php phpmyadmin -y
then i get error,
package is not availabe, and erorr caused of epel
when i was searched to internet then mostly person have told, configure by phpmyadmin tar.gz
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] phpmyadmin leupi Linux - Server 3 09-15-2010 08:46 AM
phpMyAdmin error: client denied by server configuration: /usr/share/phpMyAdmin Kropotkin Linux - Server 2 05-15-2010 01:55 PM
phpmyadmin shows blank page; no "phpmyadmin" database in mysql qajaq Linux - Software 2 12-20-2009 01:23 PM
[SOLVED] phpmyadmin aihaike Slackware 3 07-24-2006 12:01 PM
phpmyadmin seanlinux Linux - Software 1 12-06-2003 05:17 PM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration