LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-12-2004, 01:19 PM   #1
spuppett
Member
 
Registered: Feb 2003
Posts: 47

Rep: Reputation: 15
permissions


I would like to access my /dev/hda from <user> rather than root. Everyone has read permissions, but only root can cd into the folder. Its mounted, so I don't think thats the problem. I su'd and tried to chmod about every combo I could think of, but the permissions don't change. Is there a special chmod for dirs? What am I doing wrong??

Thanks
 
Old 04-12-2004, 02:00 PM   #2
Mr.Bill.Gates
Member
 
Registered: Apr 2004
Location: Moscow, Russia
Distribution: Debian
Posts: 55

Rep: Reputation: 15
/dev/hda is the whole disk. You probably mount partitions like /dev/hda1 /dev/hda2 and so on. There's no special chmod for directories. But they are virtually useless without both read and execute permissions. So you should use something like this:

# chmod 755 /mnt/mydir

Then you might need to modify this file

/etc/fstab

but read the manual first:

# man fstab

There is an option that lets ordinary users mount partitions and other media.

P.S. I hope this helps although i'm a total newbie myself :-)
 
Old 04-12-2004, 02:04 PM   #3
spuppett
Member
 
Registered: Feb 2003
Posts: 47

Original Poster
Rep: Reputation: 15
I tried that stuff. I changed fstab to
Code:
/dev/hda1        /mnt/win         vfat        noauto,owner     1   0
but all that did was not mount at start up. When I went to /mnt everything looked like I could go there, i.e. drwx-xr-xr, but when I mounted it, things changed back to drwx--r--r.

I appreciate the reply and any other insights would be appreciated as well.
 
Old 04-12-2004, 02:15 PM   #4
Mr.Bill.Gates
Member
 
Registered: Apr 2004
Location: Moscow, Russia
Distribution: Debian
Posts: 55

Rep: Reputation: 15
noauto means do not mount when "mount -a" is given, e.g at boot time
you should probably remove that option

owner means that only the owner of /dev/hda1 file can mount it (it's probably root)
what you need is "user" not "owner"

so that line should look like this

/dev/hda1 /mnt/win vfat user 1 0
 
Old 04-12-2004, 02:32 PM   #5
nightjar
Member
 
Registered: May 2002
Location: Argentina
Distribution: Mandrake 9.2
Posts: 177

Rep: Reputation: 30
Try with

/dev/hda1 /mnt/win vfat iocharset=iso8859-1,umask=0,codepage=850 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
file permissions OK, but command permissions? stabu Linux - General 2 10-05-2005 01:00 PM
permission ... permissions .... permissions alaios Linux - General 1 05-31-2005 05:16 AM
Permissions jymmi Linux - Newbie 3 04-15-2005 12:43 AM
Permissions help reddog64 Linux - Newbie 1 04-22-2004 06:23 PM
getting a directory's permissions and creating a new one with the same permissions newbie1000101 Programming 1 04-10-2004 01:52 PM


All times are GMT -5. The time now is 10:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration