LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2004, 03:47 PM   #1
Linux24
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1
Posts: 204

Rep: Reputation: 30
Pause during boot at eth0


During my machine bootup for Linux, it reaches a point where it is detecting the network settings using DHCP for eth0, and it pauses for what seems like 10 seconds or so. How can I reduce this pause?

I have a combo router/DSL modem attached to the ethernet port on my NFORCE2 motherboard.

Everything works fine, just wondering how to speed up the boot time.
 
Old 09-10-2004, 04:00 PM   #2
ThirtySixBelow
Member
 
Registered: Sep 2004
Posts: 48

Rep: Reputation: 15
Mine does the same thing. I think its normal. It's just detecting the network.
 
Old 09-10-2004, 04:09 PM   #3
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
It may take that much time negotiate an IP address from your router which is acting as a DHCP server. It may speed things up if you configure your PC with a static IP address.
 
Old 09-11-2004, 12:58 AM   #4
Linux24
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1
Posts: 204

Original Poster
Rep: Reputation: 30
I took your advice.

Here's what I did.

I go onto the router by entering its IP into my browser address bar http://192.168.1.254

and accessed the control panel.

Then I turned off DHCP.

I then found IP passthrough, and I enabled "user configured pc"

I then went into the Mandrake control center and accessed networking, and I turned off DHCP there. I chose an IP address for my pc

192.168.1.##

I used this as subnet mask 255.255.255.0 (standard for most PC's I think)

and for a DNS server I used the modem address

192.168.1.254

And I rebooted.

eth0 detection took about 2 secs instead of fifteen seconds, and networking worked like a charm.

Strangely enough, I had a more difficult time configuring my Windows XP to operate using the fixed IP - the jargon in the M$ dialog windows is annoyingly inaccurate and so user friendly that someone with actual knowledge has trouble navigating. But I did it ok, restarted, and everyone can access the net and both operating systems boot more quickly.

Thanks!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
please...how to pause scrolling messages at boot lerningkurv Linux - Newbie 5 05-15-2005 08:24 PM
Strange pause during boot angelic3000 Linux - Hardware 0 10-28-2004 01:41 PM
How to pause during boot? fclifton Linux - Newbie 4 08-16-2004 03:45 PM
Long pause during boot up the theorist Fedora 7 06-05-2004 02:51 PM
Can I pause the boot up msgs? snatale1 Mandriva 2 01-03-2004 02:59 AM


All times are GMT -5. The time now is 02:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration