LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-21-2009, 06:09 PM   #1
muzzavitch
Member
 
Registered: Dec 2008
Location: Lismore, NSW Australia
Distribution: Ubuntu 9.10 Server 32Bit
Posts: 30

Rep: Reputation: 16
NVidia driver not starting at boot


Hello All,
Once again the Kernel update process has broken my NVidia drivers. I have "Synaptic" the Linux Headers and rebooted many times...

I have re-installed the NVidia-glx, ran "nvidia-xconfig" and rebooted.

Please remind me if I have forgotten any steps...

Thanks guys.
Muzza.
 
Old 06-21-2009, 07:28 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,103
Blog Entries: 3

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
sudo nvidia-xconfig then reboot. if it persist then make sure you always install your hardware driver from the system hardware link. Remember the link also enables the non-free driver.or uninstall all of it and build your own driver.

Last edited by Drakeo; 06-21-2009 at 07:29 PM.
 
Old 06-21-2009, 11:30 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,093

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
Quote:
Once again the Kernel update process has broken my NVidia drivers
Well seeing as EVERY kernel and X11, and xorg update WILL require the rebuilding of the kernel module from the nvidia.run driver/installer that is very normal .
 
Old 06-23-2009, 06:47 PM   #4
muzzavitch
Member
 
Registered: Dec 2008
Location: Lismore, NSW Australia
Distribution: Ubuntu 9.10 Server 32Bit
Posts: 30

Original Poster
Rep: Reputation: 16
Talking Wrong headers selected...

I just fixed the problem, I selected the wrong header files, had to select the FULL header files...it is now working fine...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver not starting muzzavitch Linux - Hardware 7 03-01-2009 06:38 PM
Fedora 8: Compiz not starting with nvidia driver Speed_Demon_X Linux - Desktop 7 06-11-2008 03:03 PM
Boot freezes after upgrading nVidia driver rabalder321 Linux - Hardware 1 10-26-2006 04:23 AM
I have to reinstall nvidia driver every boot in 10.1 community Belegdol Mandriva 5 11-19-2004 05:55 PM
starting into text mode after installing NVIDIA driver kaega2 Linux - Hardware 2 09-30-2003 02:51 PM


All times are GMT -5. The time now is 11:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration