LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-19-2003, 09:03 PM   #1
deepika
Member
 
Registered: Jul 2003
Distribution: Redhat
Posts: 88

Rep: Reputation: 15
Not able to install rpm-build package


Hi.

I want to use rpmbuild but I don't have one on my computer so I downloaded rpm-build-4.1.1-1.8x.i386.rpm package from one of the sites and tried to install it running below command. But I get following error.

---------------------------------------------------------------------------------
[root@localhost downloads]# rpm -i rpm-build-4.1.1-1.8x.i386.rpm
warning: rpm-build-4.1.1-1.8x.i386.rpm: V3 DSA signature: NOKEY, key ID 2039b291error: Failed dependencies:
rpm = 4.1.1 is needed by rpm-build-4.1.1-1.8x
[root@localhost downloads]#

---------------------------------------------------------------------------------

I don't understand why I am getting this error as I already have 'rpm' package installed on my m/c as seen below.

-------------------------------------------------------------------------------
[root@localhost downloads]# rpm -q rpm
rpm-4.1-1.06
[root@localhost downloads]#
-------------------------------------------------------------------------------

Does anyone have any idea what could be the problem here?

Thanks.
 
Old 07-19-2003, 09:20 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
just to see if it works, try installing it like this:
rpm -ivh --nodeps rpm-build-4.1.1-1.8x.i386.rpm
and if it works, then everythings great, if it doesn't work then uninstall rpm-build and then we'll go from there...
just respond back if that works out, and if not then we'll try something else.
 
Old 07-19-2003, 09:45 PM   #3
deepika
Member
 
Registered: Jul 2003
Distribution: Redhat
Posts: 88

Original Poster
Rep: Reputation: 15
I get following messages.

[root@localhost downloads]# rpm -ivh --nodeps rpm-build-4.1.1-1.8x.i386.rpm
warning: rpm-build-4.1.1-1.8x.i386.rpm: V3 DSA signature: NOKEY, key ID 2039b291Preparing... ########################################### [100%]
file /usr/lib/rpm/brp-strip from install of rpm-build-4.1.1-1.8x conflicts with file from package rpm-build-4.1-1.06
file /usr/lib/rpm/brp-strip-comment-note from install of rpm-build-4.1.1-1.8x conflicts with file from package rpm-build-4.1-1.06
file /usr/lib/rpm/brp-strip-shared from install of rpm-build-4.1.1-1.8x
conflicts with file from package rpm-build-4.1-1.06
file /usr/lib/rpm/find-debuginfo.sh from install of rpm-build-4.1.1-1.8x conflicts with file from package rpm-build-4.1-1.06
file /usr/lib/rpm/find-requires from install of rpm-build-4.1.1-1.8x conflicts with file from package rpm-build-4.1-1.06
file /usr/lib/rpm/javadeps from install of rpm-build-4.1.1-1.8x conflicts with file from package rpm-build-4.1-1.06
file /usr/lib/rpm/rpmb from install of rpm-build-4.1.1-1.8x conflicts with file from package rpm-build-4.1-1.06
file /usr/lib/rpm/trpm from install of rpm-build-4.1.1-1.8x conflicts with file from package rpm-build-4.1-1.06
file /usr/share/man/man8/rpmbuild.8.gz from install of rpm-build-4.1.1-1.8x conflicts with file from package rpm-build-4.1-1.06
[root@localhost downloads]#
--------------------------------------------------------------------------------

But this shows I already have rpm-build installed on my m/c. Wondering what did I do to check it before .

Thanks DrOzz for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install a RPM package mobyuk Linux - Newbie 3 12-11-2008 05:24 AM
no kernel module build environment" Error message during RPM install gotmonkey Linux - Hardware 7 12-07-2007 02:08 AM
how to install rpm package manager? :))) sawran Linux - Software 3 04-18-2005 07:04 AM
I can't install with RPM package. PICOspark Linux - Newbie 8 04-06-2005 06:40 AM
Install package with RPM nobyone Linux - Newbie 4 04-01-2004 10:50 AM


All times are GMT -5. The time now is 03:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration