LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-06-2009, 11:40 PM   #1
jcornwall3
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Rep: Reputation: 0
No Sound Ubuntu 8.1, already checked mixer


I am very new the Linux. I purchased a new computer and installed Ubuntu 8.1, I do not get any sound though. I have read a enough on-line that I have checked the mixer and used the command:

lspci |grep Audio

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

Any help would be be appreciated.
 
Old 03-07-2009, 08:50 AM   #2
cdnLilwolf
Member
 
Registered: Jan 2006
Location: Canada
Distribution: Kubuntu 11.10
Posts: 31

Rep: Reputation: 15
Pulse audio still has some apparent issues. Are all your settings rigged for ALSA?
 
Old 03-07-2009, 10:36 AM   #3
jman82s
Member
 
Registered: Jul 2007
Location: Central Coast, California
Distribution: "distro-hopper"
Posts: 66

Rep: Reputation: 15
One thing you might want to try is this:

Double click your speaker icon in the panel. You'll get a window pop up showing the audio device to control and different tracks with sliders. Click the 'preferences' button. This will give you the option to display even more tracks to adjust. I have seen certain intel audio chipsets that require you to adjust the 'surround' track. In my case, it was muted by default.

If that doesn't work, you may want to make all the sliders/tracks visible, and play with them while having an audio program playing something.
 
Old 03-07-2009, 05:22 PM   #4
jcornwall3
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by cdnLilwolf View Post
Pulse audio still has some apparent issues. Are all your settings rigged for ALSA?
What exactly does that mean? When I double click on my sound it says that the device is HDA Intel (Alsa mixer). How can I check if my settings are rigged for ALSA
 
Old 03-07-2009, 10:13 PM   #5
harsha101087
Member
 
Registered: Nov 2007
Distribution: Opensuse 11.0 , Fedora 9 , Ubuntu 8.04
Posts: 54

Rep: Reputation: 15
what's is the output for this :-

Code:
$ cat /proc/asound/card0/codec#* | grep -i codec
 
Old 03-08-2009, 12:26 AM   #6
jcornwall3
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by harsha101087 View Post
what's is the output for this :-

Code:
$ cat /proc/asound/card0/codec#* | grep -i codec
The output is:

Codec: Realtek ALC662 rev1
 
Old 03-08-2009, 05:02 AM   #7
harsha101087
Member
 
Registered: Nov 2007
Distribution: Opensuse 11.0 , Fedora 9 , Ubuntu 8.04
Posts: 54

Rep: Reputation: 15
In your /etc/modprobe.d/, edit the file alsa-base i.e append the following code

Code:
options snd-hda-intel index=0 model=

The options for the model r the following :-
3stack-dig	3-stack (2-channel) with SPDIF
  3stack-6ch	 3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  6stack-dig	 6-stack with SPDIF
  lenovo-101e	 Lenovo laptop
  eeepc-p701	ASUS Eeepc P701
  eeepc-ep20	ASUS Eeepc EP20
  ecs		ECS/Foxconn mobo
  m51va		ASUS M51VA
  g71v		ASUS G71V
  h13		ASUS H13
  g50v		ASUS G50V
  asus-mode1	ASUS
  asus-mode2	ASUS
  asus-mode3	ASUS
  asus-mode4	ASUS
  asus-mode5	ASUS
  asus-mode6	ASUS
  auto		auto-config reading BIOS (default)

example :- options snd-hda-intel index=0 model=lenovo-101e
 
Old 03-08-2009, 05:05 AM   #8
harsha101087
Member
 
Registered: Nov 2007
Distribution: Opensuse 11.0 , Fedora 9 , Ubuntu 8.04
Posts: 54

Rep: Reputation: 15
Then reboot your system..
and Please specify whether computer is laptop or desktop..
 
Old 03-08-2009, 08:29 PM   #9
jcornwall3
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by harsha101087 View Post
In your /etc/modprobe.d/, edit the file alsa-base i.e append the following code

Code:
options snd-hda-intel index=0 model=

The options for the model r the following :-
3stack-dig	3-stack (2-channel) with SPDIF
  3stack-6ch	 3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  6stack-dig	 6-stack with SPDIF
  lenovo-101e	 Lenovo laptop
  eeepc-p701	ASUS Eeepc P701
  eeepc-ep20	ASUS Eeepc EP20
  ecs		ECS/Foxconn mobo
  m51va		ASUS M51VA
  g71v		ASUS G71V
  h13		ASUS H13
  g50v		ASUS G50V
  asus-mode1	ASUS
  asus-mode2	ASUS
  asus-mode3	ASUS
  asus-mode4	ASUS
  asus-mode5	ASUS
  asus-mode6	ASUS
  auto		auto-config reading BIOS (default)

example :- options snd-hda-intel index=0 model=lenovo-101e
What code exactly do you want me to append to that file? I have a desktop computer Vostro 220.
 
Old 03-09-2009, 04:36 AM   #10
harsha101087
Member
 
Registered: Nov 2007
Distribution: Opensuse 11.0 , Fedora 9 , Ubuntu 8.04
Posts: 54

Rep: Reputation: 15
Add like this to your alsa-base file (at the end) :-

Code:
options snd-hda-intel index=0   model=lenovo-101e
The model depends what type of system u r using ..
u can try the following models inplace of lenovo-101e

Code:
  3stack-dig	
  3stack-6ch	 
  3stack-6ch-dig 
  6stack-dig	 
  lenovo-101e	 
  eeepc-p701	
  eeepc-ep20	
  ecs		
  m51va		
  g71v		
  h13		
  g50v		
  asus-mode1	
  asus-mode2	
  asus-mode3	
  asus-mode4	
  asus-mode5	
  asus-mode6	
  auto
I suppose u have built-in speakers..if that's case try connecting headphones or external speakers that might work !!
I m really sorry for not being clear !!
hope that the above helps u !!

Last edited by harsha101087; 03-09-2009 at 04:42 AM.
 
Old 03-11-2009, 10:29 PM   #11
jcornwall3
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
So I went through the list that harsha101087 supplied for me to try. I was unsuccessful at getting the sound to function, but I did look around on my computer and up until now I had been check if the sound was working by using the Internet. I have since found that I can test the sound through system>Preferences>Sound and there I receive an error when I test the sound.

audiotestsrc wave=sine freq=512 !
audioconvert ! audioresample ! gconfaudiosink:
Could not open audio device for playback.

I hope this sheds some light on my predicament. Thanks for your help.
 
Old 03-12-2009, 09:22 AM   #12
harsha101087
Member
 
Registered: Nov 2007
Distribution: Opensuse 11.0 , Fedora 9 , Ubuntu 8.04
Posts: 54

Rep: Reputation: 15
Hey jcornwall , i think it's a bug with pulseaudio wrt intrepid ( if i m wrong please do correct me , still a newbie ) !! Found out in ubuntu forums ..
And as far i know , this is the problem when some other apllication is using your sound device
one way is to change pulseaudio to alsa which can solve your problem , but i donno how to do in ubuntu
Then the other way round is to kill pulseaudio and people have got sound from there ..
Hopes this helps you

Cheers jcorn !!
 
Old 03-12-2009, 11:20 AM   #13
velomoose
LQ Newbie
 
Registered: May 2005
Location: Colorado, USA
Distribution: OpenSUSE 11.1, Centos 5.3, Ubuntu Studio 8.04, 9.10
Posts: 9

Rep: Reputation: 0
Try running:

sudo alsaconf

This should setup the alsa sound system for you. I have an Asus M70vnc1 running the Intel HDA audio controller as well, but the ICH9 version. I had audio successfully in 8.1 using alsa on the ICH9 series...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
linking sliders in ubuntu sound mixer zepphead5 Ubuntu 0 08-23-2006 11:23 AM
Couldn't open mixer device /dev/sound/mixer laurentwahl Linux - General 8 05-17-2005 09:15 PM
couldn't open mixer device /dev/sound/mixer pitts68 Linux - Newbie 4 11-15-2004 09:03 AM
Couldn't open mixer device /dev/sound/mixer arctic123 Linux - Newbie 4 09-22-2004 10:39 AM
Couldn't open mixer device /dev/sound/mixer Dabria Linux - Hardware 2 07-29-2003 12:50 PM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration