LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-07-2004, 03:27 PM   #1
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Rep: Reputation: 0
no option to boot new kernal


excuse me. very new -- just installed yesterday.
I use grub bootloader. Selecting the new kernal in systems settings under "bootloader" does not boot the new kernal. I use two hard-drives: hda = other os, hdb = Fedora. During the install I did not put grub on MBR since the option = hda ; so i chose the hdb option= first sector of /boot partition: but, Kickstart tells me that grub is installed on the MBR. Note that attempt to access the grub menu.lst or boot.conf = "access denied' under su. How do I get the options menu at bootup to choose which kernal I boot? Why is my access denied to the grub configuration? Why does Kickstart say grub is on the MBR, or am I misunderstanding kickstart's use? Also, the link used in up2date results in 404 error. I am guessing this is because I need to boot new kernal to continue my updates through the new, correct link. If this is not the reason, does anyone know why this happens? thanks up front for any assist.

sk

Last edited by scotko; 03-07-2004 at 03:36 PM.
 
Old 03-07-2004, 03:35 PM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
This is more a hardware issue than a grub issue. Depending on bios settings the system boots from the primary drive which is /dev/hda. Since you installed grub to /dev/hdb the system will not look there. The correct option should have been /dev/hda. You can get at the bootlaoder by telling the bios to boot from the secondary drive. I am not sure whether this drive is connected as a slave to the master /dev/hda or secondary master.
 
Old 03-07-2004, 05:29 PM   #3
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
thanks TigerOC.

That gives me some ideas. A couple more ?? though please. I have to boot from floppy to get Fedora up. Can I install grub to the hda mbr? Will this give me boot options for hda & hdb? Or, would you recommend just switching drives and booting Fedora first? I'll try some of these ideas in any case. thanks agian.

SK
 
Old 03-08-2004, 03:52 AM   #4
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
I would suggest using /dev/hda. If you are using windows then there is an example for booting windows in the menu.lst. If you know how to change the bios options then you could set the system to boot from the second drive. Do not physically switch the drives around because the /etc/fstab is configured for the current setup.
 
Old 03-08-2004, 05:45 PM   #5
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
I switched the bios settings to boot hdb. I got:

GRUB

that is all. No options, and any keystrokes I tried did not input -- as if it were stuck. any ideas please?
 
Old 03-08-2004, 06:43 PM   #6
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
for anyone who reads this thread, please:

continuation of the above:

Should I check drive hdb to see if it is set up as a master too? I am obviously getting to GRUB on the disk; but nothing happens other than what I said in post #5. Anyone who can help with these problems listed in this thread please feel free to input info. thanks up front.

SK
 
Old 03-09-2004, 03:41 PM   #7
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Have a look in /boot//grub/menu.lst. If there is nothing there then it wasn't configured. I am not sure how Fedora handles this. Debian is grub-update if I remember correctly. Should tell you in menu.lst.
 
Old 03-11-2004, 06:11 PM   #8
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
I have resolved the issue well enough. First, thanks TigerOC. You gave me many ideas.

The install options in Fedora put Grub by default on hda if you are using two drives. This does no good since when one drive is up, the other is off -- a dead drive that can't be booted. Now, you can opt to put Grub on the first sector of the LINUX boot partition on hdb (if the second drive, hdb, represents where linux is being installed to ofcourse). This is also not the way to go. In this instance you will only get "GRUB_" when you atempt to boot the disk, and it will hang. The first sector is close; but not close enough. So, you have to opt to change the drive order and custom configure the bootdrive installation. Change the order, and install GRUB to the master boot record of the hdb drive. Now you can simply switch your BIOS settings to boot this disk, and GRUB comes up as it should, with any Kernal options you want to see. GRUB also lists the DOS drive, if you have windows on hda; but see below:

This resolves the problem 90% of the way. The only last question I want to know from above is:
GRUB shows DOS on hda, and if I select it, Grub attempts to boot it; but the disk is off so it can't boot. Other than installing a hard-wired switch (which I have seen much of with two hard drives), how can I keep this a software issue and force drive hda to boot from GRUB? It sees the drive, and offers the option, but the drive won't boot. An answer here completely resolves any questions I have about all of this.

Thanks much for everything so far.
sk
 
Old 03-12-2004, 02:59 AM   #9
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
I think you are getting a bit confused as to how hardware handles drives during the POST sequence. During the POST sequence the BIOS checks the drives and determines whether there is a valid OS on them. Next it checks to see if the drive is bootable which is really what you are looking for. You probably have not made the drive bootable when using cfdisk or fdisk. i.e. there is no boot sector on the drive. The system should be able to boot off any hard drive with a boot sector i.e. the drive has been made bootable.
 
Old 03-14-2004, 02:28 PM   #10
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
I am not sure how you mean for me to use this info -- I am sorry. What I have learned is that Grub will not boot the drive it is on unless it is installed on the MBR of that drive. And since what I did worked, I am obviously not entirely wrong. I had to switch the drive order in the selection menu diring the install. Also, when Grub is on the MBR of the drive currently booting, it will offer a "DOS" selection in its menu, (or a selection for whatever is on the other drive); but it will not boot that DOS /OTHER selection from another, different drive, from its current location. Also, from talking to others who run Linux, they actually had to install a physical hardware switch (a simple toggle switch) to "turn on" the other drive if they wanted to boot it when operating from the second drive. So, HDB will not boot from Grub when it is on the MBR of HDA unless iHDB is also on. When BIOS is set to boot HDA, for example, HDB is off. Whether HDB is checked, reckognized, offered as a boot selection, or no, seems to be irrelevent; it just won't boot from the other drive. It can "see" HDB, it can offer the selection to boot HDB, but it won't boot; because even though it will attempt to do so, the drive is off -- two drives don't run at once, according to the info I have gotten; only the drive sleected in BIOS as the one to boot first. This is all I know, and according to my continued trials and errors and final working system -- this seems to be true. If you have any further info I would greatly appreciate it. I really don't like others to "tell" me what to do -- this is a learning exp[erience; but please feel free to offer something more specific if you have time. Other wise, it seems that trial, error, and a good book or two seem to work better when trying to figure this all out. Thanks for all your input.

SK
 
Old 03-14-2004, 02:56 PM   #11
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
I think I may have not been clear -- this is the problem. Specifically. I have two bootable (made bootable) disks. HDA, and HDB. HDA has windows, HDB has Linux. I wanted to install Grub bootloader to offer me the option, from HDB where Linux is, to boot either windows or Linux. It does that; but when I select to boot DOS, it simply hangs and does not boot HDA. HDB boots fine, and I no longer need a floppy.

So, I know that both disks need to be bootable -- ok. I know that Grub is a bootloader. I know that grub must be installed on the MBR of the disk to be booted first -- which is whatever you want to select in BIOS. It is only installed on the first secotr of the boot partition when you are running Linux and Windows from the same disk and you have Windows NT -- otherwise, you still want Grub in the MBR. I know that if I am in the bootloader menu, located on drive HDB, that tthere is a selection to boot HDA, and it is labeled DOS - but it won't boot it. So, talking to others, I have learned/heard that this is because the other drive is physically offf. So, when in HDB, that is, when in Grub's menu located on HDB, or , just whenever one hard-disk is on -- the other hard-disk is off. This is why we have all of these web sites that show how to rig a switch for people like me who have two seperate hard drives. However, I have "heard" of a way to bypass all of this switch-stuff and actually be able to boot-up any drive you want. This is what I am asking. I am aware of bootable disks, and the fact that I would not even need grub if all I wanted was to make drive HDB bootable. But I want more than that -- I want to be avble to select any drive and boot it from Grub. thanks

SK

Scott
 
Old 03-14-2004, 03:10 PM   #12
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Ok i didn't bother to read your last 2 posts (hehe)
but if bios is set to boot from hdb and GRUB is installed in its MBR, open up /boot/grub/grub.conf with a text editor, find the stanza for DOS, it should say something like this:
Code:
title DOS
rootnoverify (hd1,0)
chainloader +1
change it to
Code:
title Windows
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1
see if it helps
 
Old 03-14-2004, 03:16 PM   #13
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Under /boot/grub you will find device.map which lists the partitions. To get grub to boot a dos or windows partition you need to add a line (sample is in menu.lst) to tell grub where the boot sector is. On my system grub is on /dev/hda and I have a Windows partition on /dev/hda1(hd0,0 ; grub starts at 0 i.e. disk 1=0 and partition 1=0) and linux on /dev/hdd1(hd2,0 disk=3 partition=1) and my entry for Windows is;

title Windows 95/98/NT/2000
root (hd0,0)
makeactive
chainloader +1

Entry for Linux;

title Debian GNU/Linux, kernel 2.4.24-amdk7
root (hd2,0)
kernel /boot/vmlinuz-2.4.24-amdk7 root=/dev/hdd1 ro hdb=ide-scsi apm=on
initrd /boot/initrd.img-2.4.24-amdk7
savedefault

Do not mix up hardware with software. If a device has a valid os format on it and the bios recognises it during the post sequence then the os can be mounted in linux terminology. Hope this gives you some further insight.
 
Old 03-14-2004, 03:37 PM   #14
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks much. I think this is what I am looking for -- I have seen something similar; but without explanation. I will work through it and post back. thanks again.

sk
 
Old 03-15-2004, 05:05 AM   #15
scotko
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
well, got a question. I can't access grub.conf. -- "permission denied." I tried in a terminal as su and still the same. But, I can access menu.lst. This makes no sense to me.
Any ideas as to why I am denied access? I have noticed that this access denial seems to happen frequently. What does this mean, and how do I access grub.conf? Any advice greatly appreciated. thanks much.

sk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernal 2.6.x won't boot darkpulsaromega Linux - Newbie 5 08-14-2005 07:19 PM
Dual Boot : Making Windows First Option in boot menu Maxwell Rain Linux - Software 3 11-27-2004 04:00 PM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-19-2004 12:10 AM
Help! Configuring Kernal failed, GRUB can't boot new kernal, help! sabaka Linux - Newbie 4 09-16-2003 10:12 PM
How to boot Mandrake Linux faster (skip boot option) lava Linux - General 7 02-28-2003 03:39 PM


All times are GMT -5. The time now is 05:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration