LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-22-2010, 02:55 PM   #1
Quinlan
LQ Newbie
 
Registered: Jul 2010
Location: Kalamazoo, MI
Distribution: Ubuntu 10.04 / CentOS 5.5
Posts: 24

Rep: Reputation: 1
No internet connection upon startup


When I boot up my machine (running CentOS 5.5), I have no internet connection.

ifconig doesn't show that eth0 is present. Going into my Network Gui from the administration tools, it says that eth0 is not active. I can't activate it from the GUI.

But...
If I sudo dhclient -d eth0, the process runs for a little bit, and all of the sudden my internet connection is there.

There must be some sort setting that I need to change to avoid doing this everytime I start the machine. Its odd, because I have an identical machine right next to it that doesn't have this problem.

Any advice?
Any more info required?
 
Old 09-22-2010, 03:14 PM   #2
suprstar
Member
 
Registered: Aug 2010
Location: Atlanta
Distribution: ubuntu, debian
Posts: 142
Blog Entries: 2

Rep: Reputation: 22
System / Administration / Network

Double click on eth0 (or whatever your NIC is)

Make sure 'Activate device when computer starts' is checked

'Automatically obtain IP address settings with:' is selected,

and 'dhcp' is in the pulldown, ie not bootp or anything else.

There isn't really anything else to it..
 
Old 09-22-2010, 04:07 PM   #3
Quinlan
LQ Newbie
 
Registered: Jul 2010
Location: Kalamazoo, MI
Distribution: Ubuntu 10.04 / CentOS 5.5
Posts: 24

Original Poster
Rep: Reputation: 1
Hmm. All of those things check out, and it's still not working.
 
Old 09-22-2010, 05:16 PM   #4
whk
Member
 
Registered: Jun 2005
Posts: 202

Rep: Reputation: 35
eth0

Try this:

sudo ifup eth0

reboot
If it does not take then add the command in
/etc/rc.local
or similar file
hth
 
Old 09-22-2010, 06:21 PM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,758
Blog Entries: 27

Rep: Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079
Hi,

From a terminal do 'ifconfig -a'. What does it show?
 
Old 09-23-2010, 12:18 AM   #6
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,145
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
You said ifconfig doesn't show eth0;

Please tell us what's the output of :

Code:
sudo mii-tool
and

Code:
sudo ifconfig eth0
Please paste the output here.

Disable iptables and selinux

Also let us know if your network has DHCP
 
Old 09-23-2010, 03:50 AM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,107

Rep: Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478
just how are you connecting ?
a cable hook up through the ether port ?
or the usb ( if usb there is a bug someplace ) i am tiring to figure that one out [ cable to usb ]


usb wireless
eth to a wireless hub ?

what
 
Old 09-23-2010, 04:28 AM   #8
leejohnli
Member
 
Registered: Sep 2010
Posts: 66

Rep: Reputation: 2
Quote:
Originally Posted by whk View Post
Try this:

sudo ifup eth0

reboot
If it does not take then add the command in
/etc/rc.local
or similar file
hth
I go for this one to ease burden of troubleshooting.It should be on /etc/rc.d/rc.local
 
Old 09-23-2010, 06:21 AM   #9
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7/10
Posts: 879

Rep: Reputation: 113Reputation: 113
does
/etc/sysconfig/network-scripts/ifcfg0

the option onboot is it set to yes like this
onboot=yes

if so then check your boot log in

/var/log/

Last edited by jmc1987; 09-23-2010 at 06:22 AM.
 
Old 09-23-2010, 10:05 AM   #10
Quinlan
LQ Newbie
 
Registered: Jul 2010
Location: Kalamazoo, MI
Distribution: Ubuntu 10.04 / CentOS 5.5
Posts: 24

Original Poster
Rep: Reputation: 1
I am using a cable through an ethernet port.

The output of ifconfig -a is:

Code:
eth0      Link encap:Ethernet  HWaddr 00:13:72:14:01:E9  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:177 Memory:fbef0000-fbf00000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1603 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1603 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2681508 (2.5 MiB)  TX bytes:2681508 (2.5 MiB)

sit0      Link encap:IPv6-in-IPv4  
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

ifup eth0 gives this output:

Code:
Determining IP information for eth0... failed; no link present.  Check cable?
Clearly it's not a cable problem, since I'm online right now without having to mess with the cable at all.

mii-tool gives me:

Code:
SIOCGMIIPHY on 'eth0' failed: Resource temporarily unavailable
no MII interfaces found
In the ifcfg-eth0 file, ONBOOT = yes.
/var/log/boot.log has a couple entries similar to this:

Code:
Sep 22 17:04:31 localhost NET[3539]: /sbin/dhclient-script : updated /etc/resolv.conf
 
Old 09-23-2010, 10:11 AM   #11
Quinlan
LQ Newbie
 
Registered: Jul 2010
Location: Kalamazoo, MI
Distribution: Ubuntu 10.04 / CentOS 5.5
Posts: 24

Original Poster
Rep: Reputation: 1
One thing I noticed, is that once I have the internet working, running ifconfig eth0 gives me this:

Code:
eth0      Link encap:Ethernet  HWaddr 00:13:72:14:01:E9  
          inet addr:141.218.146.170  Bcast:141.218.146.255  Mask:255.255.255.0
          inet6 addr: fe80::213:72ff:fe14:1e9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1283 errors:0 dropped:0 overruns:0 frame:0
          TX packets:125 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:130866 (127.7 KiB)  TX bytes:19784 (19.3 KiB)
          Interrupt:177 Memory:fbef0000-fbf00000
Inside my resolv.conf file:

Code:
generated by /sbin/dhclient-script
search wmich.edu
nameserver 141.218.140.6
nameserver 141.218.1.100
We recently had our lab's computers assigned static IP's, but were having problems. There ended up being some sort of problem with LAN vs VLAN (or something like that) which was in the hands of the IT guys. I may have changed some files while trying to fix that problem, which is now causing this connection problem.

Do you see any problem with my IP being 141.218.146.170 and the name server being 141.218.140.6?
 
Old 12-28-2010, 10:47 PM   #12
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7/10
Posts: 879

Rep: Reputation: 113Reputation: 113
Sorry for the supper late reply but the nameserver ip is just for dns resolution so you can type linuxquestions.org into your browser or whatever webaddress you may use. you ip ending in 170 is your personal ip. Just wanted to confirm that for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
internet connection to newly installed linux, i have a dual up connection babu.knl Linux - Newbie 1 05-22-2008 10:36 PM
multiple NIC causes no internet connection on startup pljvaldez Debian 5 04-10-2007 10:12 AM
Internet Connection not present at startup Suburban Linux - Newbie 2 05-02-2004 12:58 AM
startup internet connection on log-in pld Linux - Software 7 10-06-2003 05:51 PM
Starting Internet Connection at Startup OutlawStar Linux - Newbie 1 06-09-2003 09:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration