LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-15-2010, 11:30 AM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,520

Rep: Reputation: 51
No GUI app can produce sound.


Kernel 2.6.21.5, Slackware 12.0
Xfce 4.4

Hi:
That's what I wanna do. For example I've just issued 'mplayer foo.flac' and I do not want an error made by me while in the GUI to issue a loud sound notifying me the error and putting in risk my speakers. Any hint will be welcome.

Last edited by stf92; 12-16-2010 at 01:18 PM.
 
Old 12-16-2010, 05:58 PM   #2
soppy
Member
 
Registered: Mar 2008
Location: In your head!
Distribution: Arch Linux
Posts: 165
Blog Entries: 1

Rep: Reputation: 28
Load up the terminal and log in as Root. Then type
Code:
alsaconf
This will detect and set up your sound card. Once done, load your mixer program and you can adjust your volume.
 
Old 12-16-2010, 08:30 PM   #3
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 291Reputation: 291Reputation: 291
I have found that MPlayer in Slackware will sometimes use OSS by default instead of alsa when run from the terminal. To make sure that MPlayer uses alsa open the: ~/.mplayer/config file and put this in it:
Code:
# use alsa
ao=alsa
Then restart MPlayer. It will then always use alsa when you play your music.
 
Old 12-16-2010, 08:35 PM   #4
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04
Posts: 1,260

Rep: Reputation: 147Reputation: 147
Quote:
Originally Posted by stf92 View Post
I do not want an error made by me while in the GUI to issue a loud sound notifying me the error and putting in risk my speakers. Any hint will be welcome.
A loud sound can be a feedback issue. Are you also set up to do recording of some sort?
 
Old 12-17-2010, 01:47 AM   #5
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,520

Original Poster
Rep: Reputation: 51
In no way. There are all sorts of sounds output by GUI apps to signal some kink of event. Put it another way: there are all kinds of events that produce audible notifications. Examples: email notification, the KDE desktop environment crashed, some program finished his job, and so on and so on.

I have just looked into ~/.mplayer/config and saw it is empty. OK. I'll proceed to put 'ao=alsa' in it. But before I do this, I would very much wish to know what was mplayer using up to now, ALSA or OSS. How could I know?

The system-wide configuration file /etc/mplayer/mplayer.conf has all of its lines commented out. One of these lines is this:
Code:
#Specify default audio driver
#ao=oss
I think it indicates the default is presently oss, notwithstanding the fact that they are commente out. In the man page, what mplayer does when he encounters no -ao option in either the config files or the command line is a mistery. Not a word.

Last edited by stf92; 12-17-2010 at 06:57 AM.
 
Old 12-17-2010, 03:30 AM   #6
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Set the volume of your amplifier to a low level and then adjust if the audio is too low. Always start at low level. If you are controlling the sound from alsamixer or GUI tool, then you will have to load those programs up all the time, so you may want to setup a dual screen to have easy access to the mixer controls. Just find an option in XFce that disables system sound events. You can do the same in other desktop or window environments.
 
Old 12-17-2010, 03:32 AM   #7
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Quote:
Originally Posted by stf92 View Post
In no way. There are all sorts of sounds output by GUI apps to signal some kink of event. Put it another way: there are all kinds of events that produce audible notifications. Examples: email notification, the KDE desktop environment crashed, some program finished his job, and so on and so on.

I have just looked into ~/.mplayer/config and saw it is empty. OK. I'll proceed to put 'ao=alsa' in it. But before I do this, I would very much wish to know what was mplayer using up to now, ALSA or OSS. How could I know?

The system-wide configuration file /etc/mplayer/mplayer.conf has all of its lines commented out but this
Code:
#Specify default audio driver
#ao=oss
seems to indicate the default is presently oss. In the man page, what mplayer does when he encounters no -ao option in either the config files or the command line is a mistery. Not a word.
You should first be running mplayer in command line, the output will clearly tell you which AO driver is being used. I've seem similar quirks when I had jackd installed on my system. My experience with it has been quite negative, to tell the truth.
 
1 members found this post helpful.
Old 12-17-2010, 05:00 AM   #8
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,520

Original Poster
Rep: Reputation: 51
Thanks for your kind reply, i92guboj. Running mplayer one of the lines is
Code:
CPLAYER: AO: [oss] 44100 etcetera.
So, it is OSS.
Regards.

Last edited by stf92; 12-17-2010 at 06:51 AM.
 
Old 12-17-2010, 07:53 AM   #9
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,520

Original Poster
Rep: Reputation: 51
Thanks Electro for replying. If Xfce, or for that matter any other DE should have such an option, it would be a great thing indeed. Up to now, I've seen that main Xfce apps (but he can run some KDE apps too) have the option. Perhaps I could go deeper and ask directly X to disable O.S. sound events. Any ways, I'll try to enter the Xfce forum, if there is one. Thanks again.

***************************

Sorry for the double post but I had missed Electro's answer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
disabling cd sources in apt/sources.list revod_neb Linux - Newbie 4 05-25-2013 01:03 PM
XMMS is not playing file, saying 'couldn't open audio' creviceru Linux - Newbie 1 06-09-2009 01:59 AM
playing GSM audio file format Murdock1979 Linux - Software 3 12-17-2008 10:06 AM
How to save part of an audio file? WilliamS Slackware 3 04-03-2007 02:38 AM
Playing an Audio file from the shell? GreaperXtreme Linux - Newbie 14 04-16-2004 07:43 PM


All times are GMT -5. The time now is 11:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration