LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2004, 03:13 AM   #1
go_sooner
Member
 
Registered: Feb 2004
Location: Norman, OK, USA.
Distribution: Mandrake 10.0
Posts: 33

Rep: Reputation: 15
newbie: Internet connection: Debian


Hi

I am using debian woody 3.0r2 and installation included the kernel 2.2. Then I was able to connect to internet and browse. Also I had the option of configuring the net using netcon command, I suppose so.

I am connected to T1 (broadband, university supplied network) and ipconfig /all in windows 2k gives me Realtek RTL8139 fast ethernet.

I recently upgraded the kernel from 2.2 to 2.4.24. But now I couldnt connect to internet, it says, "could not connect to (website URI)".

But I could ping my localhost and it was fine.

ifconfig gives me no IP addresses or nothing on the eth0 device.

I couldnt issue netcon command, it says command not found.

I tried editing /etc/network/interfaces and issued /etc/init.d/networking restart. no success.

I could see some folders dhcp-client2 and files like dhcp-client.conf, should I try editing these files. I didnt see whats inside it.

Please also let me know what are the files that need correction after a kernel update, becoz first I installed kernel in the /usr/src folder and after reviewing some web sources, it was recommended to do it in /home folder. So deleted the /usr/src/kernel-source-2.4.24 folder and then installed the same in /home folder.

Will the old kernel be deleted automatically?, I mean kernel version 2.2.

more details: I used apt-get update, from sources.list edited to include backports.org, (that time i had internet connection, i.e., when old kernel in use), then used bzip2 and tar to unpack, then make menuconfig, then make dep, make clean, make bzImage, make bzlilo, then make modules, make modules_install. Do I have to do the bzlilo last? anyway I didnt chose any modules when I entered the menuconfig.

Thanks.

Vgn
 
Old 02-06-2004, 03:19 AM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Have you compiled Realtek support in the kernel? Check your /boot/config-2.4.24 file. Sounds like there is no support for the card and therefore it is not being seen at boot time.
 
Old 02-09-2004, 10:24 AM   #3
go_sooner
Member
 
Registered: Feb 2004
Location: Norman, OK, USA.
Distribution: Mandrake 10.0
Posts: 33

Original Poster
Rep: Reputation: 15
Hi Tiger
Sorry for late reply. But no such file in /boot, I mean the new version config-2.4.24 is missing. I can see the old version config-2.2.x in there.

Please help me solve this problem. I am dying to connect to internet.

I saw most of the formats of questions and the replies they received, and had been elaborate in setting my questions.

suspect thats why I didnt receive any replies from others.

So I really thank you for being patient in reading my stuffs.

Thanks.

Vgn
 
Old 02-09-2004, 04:03 PM   #4
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Sounds strange but then I only compile the Debian way. Go into the source directory and look at the config file. Check whether you have compiled direct support (y) or compiled it as a module (m) if its (n) then you'll have to recompile. If it's a module then install it by doing modconf and selecting the driver.
 
Old 02-10-2004, 10:01 AM   #5
go_sooner
Member
 
Registered: Feb 2004
Location: Norman, OK, USA.
Distribution: Mandrake 10.0
Posts: 33

Original Poster
Rep: Reputation: 15
fixed: internet connection OK.

Hi Tiger

I got it finally. I was going through all the recent network questions and was hinted by the steps given by wapcaplet in the Networking section. 3 steps to connect to internet.

But I dont know how to keep it permanent. Becoz I knew for sure after rebooting I will loose the connection since my "route -n" gave me single line before following his steps like,

Destination Gateway GenMask Flags Metric Ref Use Iface
129.15.208.0 0.0.0.0 255.255.252.0 U 0 0 0 eth0

But Now it contains two devices but same name eth0

Destination Gateway GenMask Flags Metric Ref Use Iface
129.15.208.0 0.0.0.0 255.255.252.0 U 0 0 0 eth0
0.0.0.0 129.15.208.1 255.255.252.0 U 0 0 0 eth0

As for as I knew, from windows ipconfig option, secondone is right, I mean my gateway is 129.15.208.1 and I dont know why and how 129.15.208.0 shows up in the first line, becoz neither that number is IP address nor that number is associated with anything like gateway becoz of that zero in the last place.

Do you know why?

Thanks for the inputs.

Vgn
 
Old 02-10-2004, 03:28 PM   #6
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
To make a permanent setup here's my setup in /etc/network/interfaces;

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

# The first network card - this entry was created during the Debian installation
# (network, broadcast and gateway are optional)
auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
network 192.168.0.1
broadcast 192.168.0.255
 
Old 02-15-2004, 03:58 PM   #7
go_sooner
Member
 
Registered: Feb 2004
Location: Norman, OK, USA.
Distribution: Mandrake 10.0
Posts: 33

Original Poster
Rep: Reputation: 15
Hi Tiger

I read your mail the other day itself. But I got my chance to work on these stuffs yesterday only. I am yet to fix it. My /etc/network/interfaces also reads similar with the exception that the numbers are different.

But I found a major flaw in my compilation style. I told you that the config file in my /boot is config-2.2.20 or something older and not config-2.4.24 which is the version that I installed recently. I forgot to include apt-get installing the default configuration file that was available on the backports.org.

However that didnt make any difference to the problem at hand. I still doing the /sbin/route add default gw *(my gateway number) everytime I login or so. Becoz I reinstalled the kernel again and this time with the default configuration files included, it adds some thing else tap0 also.

Destination Gateway GenMask Flags Metric Ref Use Iface
129.15.208.0 0.0.0.0 255.255.252.0 U 0 0 0 eth0
0.0.0.0 129.15.208.1 255.255.252.0 U 0 0 0 eth0
*** *** *** * * * * tap0

I am on windows rightnow so I am using * in place of some numbers.

I think I will have to use route to connect to net every time till I become familiar with the linux file structure and commands.

Take Care.

Thanks for the support.

Vgn
 
Old 02-16-2004, 04:59 AM   #8
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
What is in your /etc/network/ifstate? This is what brings up your network during boot.
 
Old 02-16-2004, 10:07 AM   #9
go_sooner
Member
 
Registered: Feb 2004
Location: Norman, OK, USA.
Distribution: Mandrake 10.0
Posts: 33

Original Poster
Rep: Reputation: 15
Hi Tiger

I saw only two lines in the ifstate which is:
lo=lo
eth0=eth0

I will post my ifconfig and route soon.

Vgn
 
Old 02-16-2004, 12:10 PM   #10
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
That is the same as mine. Do you have dhcp ? It may be that you are using static and dhcp which is causing the problem. Also an address of 129.xxx.xxx.xxx I am sure is not allowed for private networks. The addresses for private networks are 10, 172.16-172.31 and 192.168.0-192.168.255. Have a look at this article.
 
Old 02-16-2004, 01:01 PM   #11
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Rep: Reputation: 15
Quote:
Originally posted by TigerOC
To make a permanent setup here's my setup in /etc/network/interfaces;

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

# The first network card - this entry was created during the Debian installation
# (network, broadcast and gateway are optional)
auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
network 192.168.0.1
broadcast 192.168.0.255

well instead of this you could write the following. this will detect the setting if there is a dhcp router within your network. (you have to install the package dhcpclient (not the server) in order to use it).
Code:
auto lo eth0
iface lo inet loopback

iface eth0 inet dhcp
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie needs help on his Internet connection! Fatch_R Linux - Newbie 7 02-14-2005 02:08 PM
[NEWBIE]no internet connection after boot gaco Linux - Networking 4 06-23-2004 04:14 AM
Internet Connection - Newbie! l22arg Linux - Newbie 2 05-17-2004 11:10 AM
Newbie internet connection question Surfmonkey Linux - Newbie 46 11-25-2003 01:35 AM
Debian Internet Connection Allen614 Linux - Software 1 12-24-2002 12:40 PM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration