LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2010, 05:27 PM   #1
gribbsy
Member
 
Registered: Jun 2009
Posts: 32

Rep: Reputation: 15
Unhappy newbie dual boot grub menu failure


Hello. I'm running a dual-boot with linux mint and Windows. I have an E-machines desktop with :
760 GB Hard Drive
6GB RAM
NVidia GeForce Graphics card 6150se Integrated
AMD Athalon II X2 235e dual-core processor

My problem is getting my grub to boot into Linux Mint, and the problem may lie with my graphics card. Whenever I install the linux mint for the first time, I am prompted to activate my proprietary NVidia graphics driver, which I do. Then I am asked to reboot. Upon reboot, the system gets to the grub menu, accepts my selection to boot linux mint, then the "progress dots" appear on the screen. After about 8 seconds, the screen switches into command prompt mode. I never get to the graphical sign-on screen. All I get is the console sign-on prompts. From there my only option seems to be to reboot. (sudu reboot). After which, of course, I am forced to go into Windows vs. Linux to avoid the problem. Once Windows has loaded up, I do a restart and go back into Linux Mint . Finally, I get to the Linux sign-on graphical screen.

To summarize, i cannot restart linux mint without getting stuck staring at a console screen. I can get back into linux mint if i use the command 'sudo reboot', and, from the grub menu, choosing to go into Windows. From Windows, I then do a restart and end up back at the grub screen again, but this time when I select linux mint, things work and I am given the sign-on gui.

If I choose to not install the graphics driver (and put up with the annoying reminder to activate one), the system dual boots without a problem.
 
Old 05-24-2010, 07:19 PM   #2
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Rep: Reputation: 31
edit your grub menu (press e when grub comes up) add xdriver=nouveau

see if that driver works for you.
 
Old 05-24-2010, 11:53 PM   #3
gribbsy
Member
 
Registered: Jun 2009
Posts: 32

Original Poster
Rep: Reputation: 15
How do I edit my grub menu so the changes are permanent

Hello. Thanks for the help.

OK, I pressed 'e' at the grub menu and at the bottom of the list I entered 'xdriver=nouveau'

How do I make this change permanent. I'm guessing I need to press CTRL+S or CTRL+X or something. I tried CTRL+x but the next time I checked, the command I typed in was nowhere to be found.
 
Old 05-25-2010, 12:39 AM   #4
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
If you want to make it permanent add 'xdriver=nouveau' to /boot/grub/menu.lst file.
 
Old 05-25-2010, 03:56 AM   #5
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by gribbsy View Post
Hello. Thanks for the help.

OK, I pressed 'e' at the grub menu and at the bottom of the list I entered 'xdriver=nouveau'

How do I make this change permanent. I'm guessing I need to press CTRL+S or CTRL+X or something. I tried CTRL+x but the next time I checked, the command I typed in was nowhere to be found.
In terminal sudo su nano /boot/grub/menu.lst
Instead of nano you use may pico kwrite or any other real linux text editor
And add the line you wise to add
 
Old 05-25-2010, 08:25 PM   #6
gribbsy
Member
 
Registered: Jun 2009
Posts: 32

Original Poster
Rep: Reputation: 15
Ok, thanks for the help. Here's where I'm at:

I was able to create the file /boot/grub/menu.lst with gedit and inserted the command
xdriver=nouveau
But there was no change -- I still upon a hard reboot get kicked out to the terminal screen. I did find out, however, that I can run the command "sudo gdm" which allows me to log in and get to the desktop. I sure would like to know if there's a way around having to do this every time I boot up.

take care
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed Fedora as dual boot but Grub boot menu is not showing up nilocjin Linux - Newbie 4 06-03-2009 02:09 PM
Lost my dual boot grub menu narcispy Linux - Software 1 07-28-2007 08:41 PM
Help w/ GRUB, menu.lst, dual boot Windows XP ryanryan Linux - Newbie 11 04-05-2007 08:26 PM
No Grub menu displaying on dual-boot (2 hdd's) JoeLinux117 Linux - Newbie 10 03-19-2007 01:23 PM
no grub menu after startup in dual boot FC3 and XP Remko Fedora - Installation 6 01-19-2005 04:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration