LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-22-2008, 12:24 AM   #1
booberandpuzz
Member
 
Registered: Apr 2008
Location: South Florida, USA
Distribution: Ubuntu 8.04
Posts: 32

Rep: Reputation: 15
New install Debian 4.0R3 can't mount CDROM


I'm completely new to Linux and this is my first attempt at installation. I've run the Debian 40r3-i386-netinst. I'm trying to install an NVidea driver so I can get X11 to work, but I can't get the CD to work, the same CD that installed the O/S. I don't get that.

I have an entry in my FSTAB:

/dev/hda /media/cdrom0 auto rw,user,noauto 0 0


but

sudo mount -t iso9660 /dev/hda /media/cdrom0

results in

special device /dev/hda does not exist

looking in /dev I see many objects including

sda sda1 sda2 sda5 sdb1 fd fd0 but no hda

This "learning" system I built has just one SATA hard drive and on install I used the option "all files in one partition." Nevertheless, udevinfo reports sda1, sda2, & sda5 are all partitions on the SATA HDD. It has one CDROM as master on the lone IDE port with no slave device. There is no floppy.

I tried entering "noapic aspi=off" at the end of the kernal boot line in menu.lst No help.

So if all the stuff I've been reading about how recent distros are much easier to install and configure ... OMG, what was it like before?
 
Old 04-22-2008, 01:01 AM   #2
pAn1k
Member
 
Registered: Jun 2004
Location: Cala city
Distribution: Suse 10.0; Debian 5.0 (Lenny) Fluxbox
Posts: 240

Rep: Reputation: 30
try using su then 'mount /dev/cdrom/'

hda is a hard drive

the sd* are usb

fd* are floppy

good luck
 
Old 04-22-2008, 11:54 AM   #3
booberandpuzz
Member
 
Registered: Apr 2008
Location: South Florida, USA
Distribution: Ubuntu 8.04
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pAn1k View Post
try using su then 'mount /dev/cdrom/'

hda is a hard drive

the sd* are usb

fd* are floppy

good luck
Thanks for the suggestion. And the answer is:

mount: can't find /dev/cdrom in /etc/fstab or /etc/mtab

I had read somewhere that the CD would show up as hda because it is on the IDE port, in this case the only device. Also the installer wrote the fstab that way, linking the device /dev/hda to /media/cdrom0.

Whether the device is there or not, working properly or not, I don't understand the mount command continually telling me it's not in the simple text file fstab when you can see it plain as day.
 
Old 04-22-2008, 12:46 PM   #4
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Your definition in fstab is incorrect; defined as /media/cdrom.

I suggest the following definition;

/dev/hda /cdrom iso9990 defaults,ro,noauto,users 0 0

It cannot write to media in the conventional sense so it is "ro"

Reboot the system and it should work correctly.
 
Old 04-22-2008, 02:37 PM   #5
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
booberandpuzz - it's ok. Modern kernels usually access ATA devices through SCSI emulation. Than /dev/sdb1 is your cdrom.
 
Old 04-22-2008, 05:09 PM   #6
booberandpuzz
Member
 
Registered: Apr 2008
Location: South Florida, USA
Distribution: Ubuntu 8.04
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by TigerOC View Post
Your definition in fstab is incorrect; defined as /media/cdrom.

I suggest the following definition;

/dev/hda /cdrom iso9990 defaults,ro,noauto,users 0 0

It cannot write to media in the conventional sense so it is "ro"

Reboot the system and it should work correctly.

I made the suggested changes to fstab. I now get
mount: can't find /dev/cdrom in /etc/fstab or /etc/mtab
Did you mean iso9990 or iso9660? I also tried mount /dev/cdrom0.

The edited line in fstab reads:
/dev/hda /media/cdrom iso9660 defaults,ro,noauto,users 0 0
I should also point out that there is no hda in /dev. I have not been able to find a node with which I can pull info from udevinfo either. Am I being obtuse, or can I assume the hardware is working properly since I installed this O/S from it yesterday? Not that the O/S is being very cooperative. Is there a utility to query the IDE port and see what's there?

I did some searching and found some interesting things:
cat /proc/filesystems does not list iso9660
I entered ln -s /dev/hda /dev/cdrom and now on mount /cdrom I get the message:
mount: can't find /media/cdrom0 in /etc/fstab or /etc/mtab
I guess it's pretty obvious that I'm fumbling around, but this is how I've always learned. I just didn't realize I'd signed up to learn so much.
 
Old 04-22-2008, 05:25 PM   #7
booberandpuzz
Member
 
Registered: Apr 2008
Location: South Florida, USA
Distribution: Ubuntu 8.04
Posts: 32

Original Poster
Rep: Reputation: 15
I changed the fstab line to
/dev/hda /media/cdrom0 iso9660 defaults,ro,noauto,users 0 0

and now I get:
mount: special device /dev/hda does not exist

I also opened the case just to confirm the CD has the Master jumper set. It does and BIOS sees the device just fine.

Last edited by booberandpuzz; 04-22-2008 at 05:29 PM.
 
Old 04-22-2008, 05:35 PM   #8
booberandpuzz
Member
 
Registered: Apr 2008
Location: South Florida, USA
Distribution: Ubuntu 8.04
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Samotnik View Post
booberandpuzz - it's ok. Modern kernels usually access ATA devices through SCSI emulation. Than /dev/sdb1 is your cdrom.
Actually, if I plug in my USB drive it shows up as sdb1 ... not that I've figured out how to ls or see any of the files on it yet. I've tried and none of the files show up. I tried getting the NVidia driver on the machine that way. I'm kinda 0'fer solving anything on this system yet. I can log in pretty consistently.

Last edited by booberandpuzz; 04-23-2008 at 01:56 AM. Reason: sp
 
Old 04-23-2008, 01:54 AM   #9
booberandpuzz
Member
 
Registered: Apr 2008
Location: South Florida, USA
Distribution: Ubuntu 8.04
Posts: 32

Original Poster
Rep: Reputation: 15
Another update

Update:

Now I'm suspicious of the hardware. I tried booting from the PCLinuxOS2007 LiveCD and looking at the progress of the kernal configuration I see:

--- MKLIVECD LINUXRC -------------------
...
<snipped several lines indicating success>
...
Probing USB devices:...........[LOADED]
No ide channels found .........[ OK ]
Searching for the loop image:../dev/sda1
.............................../dev/sda2
.............................../dev/sda5
...............................[DONE]
ERROR: Unable to mount the livecd

Dropping you to a limited shell


The /dev/sdaN are the partitions Debian installed on the lone SATA HDD. This system is a new MB/CPU MSI K9NGM4-F V.2 and AMD Athlon 64 LE-1600 I purchased strictly for this Linux project which, I'm sorry to say, isn't going so well thus far. I had successfully booted from Knoppix 5.1.1 before attempting the Debian install.
 
Old 04-23-2008, 02:32 AM   #10
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Quote:
Originally Posted by booberandpuzz View Post
...
<snipped several lines indicating success>
...
Probing USB devices:...........[LOADED]
No ide channels found .........[ OK ]
Searching for the loop image:../dev/sda1
.............................../dev/sda2
.............................../dev/sda5
...............................[DONE]
ERROR: Unable to mount the livecd

Dropping you to a limited shell


The /dev/sdaN are the partitions Debian installed on the lone SATA HDD. This system is a new MB/CPU MSI K9NGM4-F V.2 and AMD Athlon 64 LE-1600 I purchased strictly for this Linux project which, I'm sorry to say, isn't going so well thus far. I had successfully booted from Knoppix 5.1.1 before attempting the Debian install.
The key here is that the ide device is not being seen. If Knoppix located the device and the bios is seeing it correctly then you need to confirm that this definitely the problem. The fstab line should be;

/dev/hda /cdrom .......

If you are in a gui interface open up a root file browser and go look at /var/log/dmesg and look for lines related to ide. If you cannot figure them out let us know as this is where the problem is located.
 
Old 04-23-2008, 11:33 AM   #11
booberandpuzz
Member
 
Registered: Apr 2008
Location: South Florida, USA
Distribution: Ubuntu 8.04
Posts: 32

Original Poster
Rep: Reputation: 15
Well I haven't yet been able to get to a GUI anything, so I did

cat dmesg |less

Here are the lines that look suspicious to me:
Code:
PnPBIOS caused a fatal error (it goes on to recommend booting with pnpbios=off)

PCI:<snip>pcie_portdrv_probe ->Dev[0563:10de] has invalid IRQ. Check vendor BIOS

ide: Assuming 33MHz system bus speeds for PIOmodes; override with idebus=xx
I'm going to see if MSI has an updated BIOS, but I'm not sure yet how I'll get that installed either since I can't seem to see files on the CD or USB.

Update: They have a slightly newer BIOS (3.3) but it doesn't appear in the notes that they changed anything pertinent to my issue. I'll try it anyway. How likely is it that my issue is simply that my MB and chipset (nVidia 7025) are relatively new?

I also just ordered a SATA CD/DVD drive ... we'll see if going around the IDE problem helps.

Last edited by booberandpuzz; 04-23-2008 at 06:49 PM. Reason: u
 
Old 04-24-2008, 02:14 AM   #12
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Are there no other lines relating to the ide? If it cannot locate the ide channel it should show an error. If it recognises the ide channel it should also pick up the device.

You may need to install the kernel for the nvidia chipset. I have a standard (non-nvidia) motherboard in the same range and it worked from the get-go.

Do an apt-cache search and have a look for the nvidia kernel.

Last edited by TigerOC; 04-24-2008 at 02:16 AM.
 
Old 04-25-2008, 11:40 AM   #13
booberandpuzz
Member
 
Registered: Apr 2008
Location: South Florida, USA
Distribution: Ubuntu 8.04
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by TigerOC View Post
Do an apt-cache search and have a look for the nvidia kernel.
Doing this search turned up nothing so I think you're right. I was looking for documentation on using either apt-get or aptitude to obtain the kernel and I came across another thread for the 7025 chipset. At their suggestion I changed the video driver from "nvidia" to "vesa" in my xorg.conf. I now have a GUI!

I'm currently using synaptic to search for nvidia kernal. Is this the logical next step?

OK, I did get sidetracked a bit. Used now functional USB to bring nvidia x86 driver over and dropped to console to run it. It reports the following:

Code:
No precompiled kernel interface was found to match your kernel.
The nVidia website has some pretty detailed information on driver installation so I'll continue this part of my issue there. But I still can't mount the CD and that seems related to having an nVidia chipset-specific kernel installed. I'm not sure how to even begin this process. Came up empty on the MSI website: only Windows drivers.

After reading quite a bit on the nVidia website I:

1. Regret building a new nVidia system for Linux.
2. Installed make, linux-headers, libc, gcc, pkg-config, xserver-xorg-dev
3. Made sure nvidia-glx /etc/init.d/nvidia-glx and /etc/init.d/nvidia-kernel are not on system.

But all this pertains to the video driver I think. I'm really unclear on the exact relationship between the Linux Kernel, chipset kernel and the hardware and, while I can easily locate, if not correctly install, the display drivers, I can't even locate a file for the nVidia chipset "kernel."

Remember this is where I belong, the n00b section!

Reading yet more posts, I've found that my kernel (2.6.18-6-486) will not support CD/DVD on SATA anyway. For that I'd need 2.6.22 or higher. Am I wasting my time on this? Should I be installing a different, newer distro like Ubuntu 8.04?

Last edited by booberandpuzz; 04-25-2008 at 12:22 PM.
 
Old 04-26-2008, 03:00 AM   #14
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
booberandpuzz you are getting side tracked with other issues not related to this problem. Let's stay focussed on the issue which relates to the ide device problem.

You have not given detail that I asked for of the lines in the log file relating to the ide device that are being picked up during the boot phase. The messages that are logged will give us an idea of what the problem is. We need to know what the kernel is seeing and how it is handling the ide channel. Address any other problems related to other devices in another thread.
 
Old 04-26-2008, 07:47 AM   #15
mrrangerman
Member
 
Registered: Oct 2007
Location: MI
Distribution: Debian Slackware
Posts: 528

Rep: Reputation: 50
Quote:
This "learning" system I built has just one SATA hard drive and on install I used the option "all files in one partition." Nevertheless, udevinfo reports sda1, sda2, & sda5 are all partitions on the SATA HDD. It has one CDROM as master on the lone IDE port with no slave device. There is no floppy.
First thing, if the IDE cable you used has MASTER and SLAVE written on it, make sure the jumper on the cd-rom is set to Cable Select. If the IDE cable has nothing written on it then the jumper should be fine.

Quote:
PnPBIOS caused a fatal error (it goes on to recommend booting with pnpbios=off)

PCI:<snip>pcie_portdrv_probe ->Dev[0563:10de] has invalid IRQ. Check vendor BIOS

ide: Assuming 33MHz system bus speeds for PIOmodes; override with idebus=xx
You may need to go into the bios and disable PnP.

Also post the output of the command dmesg if you can, wrap it in code tags.
 
  


Reply

Tags
cd, debian, mount, nvidia drivers


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian 4.0r3 on Lenovo z61m: looking for wireless drivers; wired only semi-working surfbass Linux - Laptop and Netbook 1 03-13-2008 09:25 PM
CDROM won't mount w/ Debian Sarge hpladd Linux - Newbie 1 12-08-2005 09:56 AM
newbie on debian trying to mount cdrom javier_ccs Linux - Hardware 18 09-08-2005 05:02 PM
Changed CDROM to CDRW, Debian can't mount it bcalder01 Linux - Laptop and Netbook 9 09-12-2004 04:33 PM
I just discovered that I cannot mount my CDROM on debian! ganninu Debian 9 11-08-2003 02:59 PM


All times are GMT -5. The time now is 11:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration