LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-11-2003, 12:10 PM   #1
randomwhiteman
LQ Newbie
 
Registered: Aug 2003
Distribution: Slackware 9.0
Posts: 1

Rep: Reputation: 0
Question Network Setup Problems in Slack 9.0


I ran into some problems setting up my network cards under Slackware 9.0 (2.4.20 kernel). I've got two cards in my machine right now. One is a SiS 900 Fast Ethernet Adaptor built on the motherboard, the other is a Linksys, not sure on the exact model, but is should use the tulip.o module. netconfig detected the card using tulip, but won't detect the other. I tryed both cards and tryed changing the comments in the rc.inet1 file, but nothing has seemed to work. I'm connecting to a cable modem, and really just need one of the cards to work. Still have problems with the Linksys card removed and using only the motherboard card. Here's some output.

ifconfig -a
output
eth0 Link encap:Ethernet HWaddr 00:04:5A:56:E2:8F
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:125 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:7500 (7.3 Kb) TX bytes:1180 (1.1 Kb)
Interrupt:11 Base address:0xd000

eth1 Link encap:Ethernet HWaddr 00:07:95:DC:69:A6
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0xd400

dmesg
output
...
Adding Swap: 979956k swap-space (priority -1)
Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
PCI: Found IRQ 11 for device 00:0d.0
PCI: Sharing IRQ 11 with 00:02.7
eth0: ADMtek Comet rev 17 at 0xd000, 00:04:5A:56:E2:8F, IRQ 11.
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Intel PCIC probe: not found.
Databook TCIC-2 PCMCIA probe: not found.
ds: no socket drivers loaded!
sis900.c: v1.08.06 9/24/2002
PCI: Assigned IRQ 11 for device 00:03.0
eth1: Realtek RTL8201 PHY transceiver found at address 1.
eth1: Using transceiver found at address 1 as default
eth1: SiS 900 PCI Fast Ethernet at 0xd400, IRQ 11, 00:07:95:dc:69:a6.
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
PCI: Found IRQ 11 for device 00:02.7
PCI: Sharing IRQ 11 with 00:0d.0
i810: SiS 7012 found at IO 0xd800 and 0xdc00, IRQ 11
i810_audio: Audio Controller supports 2 channels.
ac97_codec: AC97 codec, id: 0x434d:0x4941 (Unknown)
i810_audio: only 48Khz playback available.
i810_audio: AC'97 codec 0 Unable to map surround DAC's (or DAC's not present), total channels =

lspci -v
output
00:03.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 90)
Subsystem: Elitegroup Computer Systems: Unknown device 0a14
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at d400 [size=256]
Memory at cffdd000 (32-bit, non-prefetchable) [size=4K]
Expansion ROM at cffa0000 [disabled] [size=128K]
Capabilities: [40] Power Management version 2

00:0d.0 Ethernet controller: Linksys Network Everywhere Fast Ethernet 10/100 model NC100 (rev 11)
Subsystem: Linksys: Unknown device 0574
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at d000 [size=256]
Memory at cfffdc00 (32-bit, non-prefetchable) [size=1K]
Expansion ROM at cff80000 [disabled] [size=128K]
Capabilities: [c0] Power Management version 2

rc.inet1
#! /bin/sh
# /etc/rc.d/rc.inet1
# This script starts up the base networking system.
#
# Version:
# @(#)/etc/rc.d/rc.inet1 8.1 Tue May 28 15:27:39 PDT 2002 (pjv)

# Edit these values to set up your first Ethernet card (eth0):
IPADDR="127.0.0.1" # REPLACE with YOUR IP address!
NETMASK="255.255.255.0" # REPLACE with YOUR netmask!
# Or, uncomment the following lines to set up eth0 using DHCP:
USE_DHCP=yes
# If your provider requires a DHCP hostname, uncomment and edit below:
#DHCP_HOSTNAME="CCHOSTNUM-A"

# Edit these values to set up your second Ethernet card (eth1),
# if you have one. Otherwise leave it configured to 127.0.0.1,
# or comment it out, and it will be ignored at boot.
#IPADDR2="127.0.0.1" # REPLACE with YOUR IP address!
#NETMASK2="255.255.255.0" # REPLACE with YOUR netmask!
# Or, uncomment the following lines to set up eth1 using DHCP:
#USE_DHCP2=yes
# If your provider requires a DHCP hostname, uncomment and edit below:
#DHCP_HOSTNAME2="CCHOSTNUM-A"

# Edit the next line to point to your gateway:
GATEWAY="" # REPLACE with YOUR gateway!

Thanks
 
Old 08-26-2003, 10:01 AM   #2
JoeDuncan
Member
 
Registered: Aug 2003
Location: Ottawa
Distribution: Redhat 5.2, 6.0, 6.1, Mandrake 7.2, 8.0, 9.1, 9.2, 10.0, Gentoo, Debian 3.1r0
Posts: 224

Rep: Reputation: 30
Hrm... it looks like both your NICs and your sound card are all using the same IRQ number...

...
PCI: Found IRQ 11 for device 00:0d.0
PCI: Sharing IRQ 11 with 00:02.7
eth0: ADMtek Comet rev 17 at 0xd000, 00:04:5A:56:E2:8F, IRQ 11.
...
PCI: Assigned IRQ 11 for device 00:03.0
eth1: Realtek RTL8201 PHY transceiver found at address 1.
eth1: Using transceiver found at address 1 as default
eth1: SiS 900 PCI Fast Ethernet at 0xd400, IRQ 11, 00:07:95:dc:69:a6.
...
PCI: Found IRQ 11 for device 00:02.7
PCI: Sharing IRQ 11 with 00:0d.0
i810: SiS 7012 found at IO 0xd800 and 0xdc00, IRQ 11

However, where as your Tulip and soundcard are trying to share the IRQ, it seems that your built in NIC is trying to hog it. Check the manuals for your Tulip and sound card and see if there's any way (usually some jumper pins) to change the IRQ they're using.

You may also want to look at your motherboard manual and see if there's a way to change the IRQ of the builtin NIC, though they are usually hardwired. Your nest net is to put the soundcard and NIC on a different IRQ. BTW, does your sound card work?

Also, take a look at "modprobe" (read the man page) and "modules.conf" as these might be able to change the IRQs in sfotware.

IIRC correctly you need to add an "options" line to modules.conf for your driver and specify what IRQ to use... should be in the man page...
 
Old 08-26-2003, 12:09 PM   #3
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Re: Network Setup Problems in Slack 9.0

Quote:
Originally posted by randomwhiteman
rc.inet1
#! /bin/sh
# /etc/rc.d/rc.inet1
# This script starts up the base networking system.
#
# Version:
# @(#)/etc/rc.d/rc.inet1 8.1 Tue May 28 15:27:39 PDT 2002 (pjv)

# Edit these values to set up your first Ethernet card (eth0):
IPADDR="127.0.0.1" # REPLACE with YOUR IP address!
NETMASK="255.255.255.0" # REPLACE with YOUR netmask!
# Or, uncomment the following lines to set up eth0 using DHCP:
USE_DHCP=yes
# If your provider requires a DHCP hostname, uncomment and edit below:
#DHCP_HOSTNAME="CCHOSTNUM-A"

# Edit these values to set up your second Ethernet card (eth1),
# if you have one. Otherwise leave it configured to 127.0.0.1,
# or comment it out, and it will be ignored at boot.
#IPADDR2="127.0.0.1" # REPLACE with YOUR IP address!
#NETMASK2="255.255.255.0" # REPLACE with YOUR netmask!
# Or, uncomment the following lines to set up eth1 using DHCP:
#USE_DHCP2=yes
# If your provider requires a DHCP hostname, uncomment and edit below:
#DHCP_HOSTNAME2="CCHOSTNUM-A"

# Edit the next line to point to your gateway:
GATEWAY="" # REPLACE with YOUR gateway!

Thanks
A few things here:

Gateway=""
If you are going to have that blank, feel free to comment it out as well.

If you are going to use DHCP, comment out the:
IPADDR="127.0.0.1" # REPLACE with YOUR IP address!
NETMASK="255.255.255.0" # REPLACE with YOUR netmask!

Lines as well. DHCP configures ALL of this for you. If you AREN'T using DHCP, comment out that line, replace the IPADDR with your actual IP, NETMASK="" with your actual netmask, and GATEWAY="" with your actual gw.



Then, as root, rerun the networking script:
/etc/rc.d/rc.inet1

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack 10 network problems Sherlok Slackware 12 11-17-2005 09:28 PM
network config w/ DHCP during slack setup miyagi Linux - Networking 4 09-02-2004 03:33 PM
Problems with network installation of Slack 9.1 wojtas Slackware - Installation 1 04-03-2004 01:32 PM
Want to setup a network gateway usigng Slack 9.1 GeneralmP Linux - Networking 13 10-12-2003 04:10 PM
network printer setup problems! yenonn Linux - Newbie 3 03-12-2003 11:53 PM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration