LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-18-2010, 02:32 AM   #1
khushwant
LQ Newbie
 
Registered: Aug 2010
Distribution: Ubuntu 10.04
Posts: 4

Rep: Reputation: 0
Network Problem on Ubuntu 10.04 LTS


Hi,

I am facing problem with ubuntu 10.04 LTS to process network. I have 2 HDD separate for windows 80GB and 250 GB for Ubuntu with 2 GB RAM and Pentium D process. Now the problem is I am able connect to world when I am on windows while not the case with Ubuntu 10.04 LTS. I have checked some settings such as,

$ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:1a:4d:0f:29:6d
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:720 (720.0 B) TX bytes:720 (720.0 B)

$ lspci

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)

$ /etc/init.d/interfaces

auto lo
iface lo inet loopback

I am new to Ubuntu, and wants to fix the problem, any help would be appreciable.

Thank you
 
Old 08-18-2010, 05:26 AM   #2
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
Hi,

You have to properly edit /etc/network/interfaces file in Ubuntu to connect to external world

Here are few links which may help you
https://help.ubuntu.com/8.04/serverg...iguration.html
http://www.cyberciti.biz/faq/setting...terfaces-file/
 
Old 08-18-2010, 05:31 AM   #3
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 113Reputation: 113
It seems you haven't configure network interface. Configure your network and interface.


Code:
$ sudo vi /etc/network/interfaces

iface eth0 inet static
address 192.168.10.10
netmask 255.255.255.0
gateway 192.168.10.1

$ sudo vi /etc/resolv.conf
nameserver ip-of-dns-server

$ sudo /etc/init.d/networking restart
or you can configure network through graphical tool.

Hope this help
 
Old 08-18-2010, 05:37 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Network does not seem to be configured. Either you can directly edit the files, or you can assign valid network information like ip address through network manager. You can find the network manager icon in the system tray. You can right and edit the connections and assign the address and other information.
 
Old 08-27-2010, 01:36 AM   #5
khushwant
LQ Newbie
 
Registered: Aug 2010
Distribution: Ubuntu 10.04
Posts: 4

Original Poster
Rep: Reputation: 0
Dear all,

Thanks to u all but still I am not able to fix the problem, I have edited accordingly and sending you the results of my file.

$ sudo gedit /etc/network/interfaces/

#auto lo
#iface lo inet loopback
auto etho0
iface eth0 inet static
address 172.16.8.98
netmask 255.255.254.0
gateway 172.16.8.1
broadcast 172.16.8.255

I have commented loopback files....

$ sudo gedit /etc/resolv.conf
#Generated by NetworkManager
nameserver 202.41.10.31
nameserver 202.41.10.32

$ sudo /etc/init.d/networking restart
Reconfiguring network interfaces... [OK]

Help me gurus...

Thank you
Khushwant
 
Old 08-27-2010, 02:24 AM   #6
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 113Reputation: 113
after editing file what is the output of ifconfig command

Code:
sudo ifconfig
did you stop network manager service?
stop network-manager and try to connect.

Code:
/etc/init.d/network-manager stop
/etc/init.d/networking restart
 
Old 08-28-2010, 12:44 AM   #7
khushwant
LQ Newbie
 
Registered: Aug 2010
Distribution: Ubuntu 10.04
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for your help, here are the output ...which I am getting

$ sudo ifconfig

eth0 Link encap:Ethernet HWaddr 00:1a:4d:0f:29:6d
inet addr:172.16.8.98 Bcast:172.16.8.255 Mask:255.255.254.0
inet6 addr: fe80::21a:4dff:fe0f:296d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:249 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:19358 (19.3 KB)
Interrupt:23 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:94 errors:0 dropped:0 overruns:0 frame:0
TX packets:94 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7820 (7.8 KB) TX bytes:7820 (7.8 KB)

$ /etc/init.d/network-manager stop

Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service network-manager stop

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the stop(8) utility, e.g. stop network-manager


$ /etc/init.d/networking restart

* Reconfiguring network interfaces... [OK]

Thank you
Khushwant
 
Old 08-28-2010, 01:18 AM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You have got the IP address for your network interface. Have you set it up manually or is it through DHCP? And how do you connect to internet using windows?
And you seem to be on internet using Ubuntu already. Is this the same machine you were facing issues?
 
Old 08-29-2010, 11:36 PM   #9
khushwant
LQ Newbie
 
Registered: Aug 2010
Distribution: Ubuntu 10.04
Posts: 4

Original Poster
Rep: Reputation: 0
Hi Chatainya,

I am connected through LAN in windows and ubuntu too. Earlier I have fedoracore 12 and network was fine but one day unfortunately my machine get turned off due to empty powerbackup. So afterward the network gone on FC12 and I installed Ubuntu 10.04 LTS. It was observed then the network is not working with Ubuntu 10.04 also. The machine is same.

I have got it manually instead of DHCP. But now i did not c network manager sign at panel near sound and chat, which was there earlier when I set IPv4 settings manually.

help to sort the problem. I have installed Realtek semiconductor device again but the problem is still there.

Thank you
Khushwant
 
Old 08-29-2010, 11:56 PM   #10
basheer
Member
 
Registered: Mar 2009
Location: Bangalore, India
Distribution: CentOS6.5, CentOS7, Ubuntu14.04
Posts: 182

Rep: Reputation: 29
Right Click on the top panel and add Notification Area.
See if the Network Icon is getting displayed there.
You can right click on that icon and check for the settings Else you acn add the connection.
Ubuntu 10.04 should be able to automatically detect your connection.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No enough space error when trying upgrade ubuntu from 8.04 lts to 10.04 lts flik shen Ubuntu 5 06-15-2010 12:44 PM
Ubuntu 10.04 LTS desktop problem The PIT Ubuntu 11 05-14-2010 11:08 AM
Wireless Problem with Ubuntu 8.04 LTS groogruxking40 Linux - Wireless Networking 15 01-07-2010 09:05 AM
LXer: I update Ubuntu 6.06 LTS and 8.04 LTS ... one has SSH issues, one does not LXer Syndicated Linux News 0 05-20-2008 07:30 AM
Problem before installing Ubuntu 6.06 LTS habiblove Ubuntu 6 06-08-2006 06:28 PM


All times are GMT -5. The time now is 04:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration