LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-30-2002, 07:38 PM   #1
BarkingRetard
LQ Newbie
 
Registered: Jun 2002
Posts: 12

Rep: Reputation: 0
Talking Need Help, again....


Ok installing mandrake went great but theres problems. First, my parents are bitchen at me cuase there old and cant get to the keyboard in time. Lilo automaticly boots to linux and they get pissed.... how do i change it to windows default?

2nd, According to windows I have a S3 ProSavage installed. In Linux its set to a S3 Savage4 and the ProSavage isnt listed. The ProSavage4 setting makes these little vertical lines accross the screen when it loades something. Its very annoying.... Now my question is what setting do I use for my ProSavage and how do I change it?

Thx for any help you give and remember. Dont flame me
 
Old 06-30-2002, 08:02 PM   #2
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 58
1) Just a matter of changing the /etc/lilo.conf file and then re-running lilo. The top of it should have something like:

append="hdd=ide-scsi"
boot = /dev/hda
message = /boot/boot_message.txt
default = Linux
prompt
timeout = 1200

Changing default to the exact phrase that is at the end after the word label = whatever, it'll probably be labelled Windows, capitalization matters.

timeout is measured in tenths of seconds, so mine up there is 2 minutes, 1200 tenths=120 seconds, 2 minutes.

When you're done editting lilo.conf, re-run lilo as root from a command line with:

/sbin/lilo

That one was from slackware, so yours may look a little different, but it will work the same, you will almost definately be adding the default = line entirely.

2) Those vertical lines mean that there is a bit of a probe problem from that pre-gen'd XF86Config file. You may want to save your current /etc/X11/XF86Config file somewhere else, like /home/whoever, and then try messing about with the utility: /usr/X11/bin/xf86config.

Luck,

Finegan
 
Old 07-01-2002, 07:15 AM   #3
burk
LQ Newbie
 
Registered: Aug 2001
Posts: 23

Rep: Reputation: 15
Mandrake also has a GUI config. tool in their Control Center that you can use to change the settings in Lilo.
 
Old 07-01-2002, 11:25 PM   #4
BarkingRetard
LQ Newbie
 
Registered: Jun 2002
Posts: 12

Original Poster
Rep: Reputation: 0
Angry Ummm shit

Ok problem with both of the solutions. It wont let me edit
lilo.conf saying access denied. I know what this means but
when linux starts up it only flashes a simple text login screen
and just signs me in as jesse. My simple idea waz to type really
fast while the screens up but when im under root my mouse wont
work for some reason...

I dont know what your talking about with the other solution but i
did it anyways. When i click on xf86config it dosnt do anything.
Sooo anyways my problem with the monitor seems to be getting
worse somehow and any help would be appreciated. Remember
that im completly new to the linux OS though....


 
Old 07-01-2002, 11:44 PM   #5
tunedLow
Member
 
Registered: Sep 2001
Location: Salt Lake City
Distribution: Slackware 8.1
Posts: 133

Rep: Reputation: 15
You have to be root to edit lilo.conf, as well as xf86config. You can use the su tool from the command prompt to edit lilo, and you need to run xf86config from the console.

Don't know what to tell you about the mouse not working as root.

Last edited by tunedLow; 07-01-2002 at 11:46 PM.
 
Old 07-01-2002, 11:46 PM   #6
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 58
In order to modify lilo, you have to be root. Use "su" from a terminal to become root and do it from there.



Now... X-windows.



Hit CTRL+ALT+F1, that'll take you out of X and to a tty, a terminal. Log in as root.



cp /etc/X11/XF86Config-4 /home/someuser (this will make a backup of your configuration file)

cd /usr/X11/bin

./xf86config (follow the steps)



Hit CTRL+ALT+F7, that'll get you back to your X session. Log out and let X restart (no need to restart the whole machine), and the changes will have taken effect. If you don't like it, or it crashes, or goes kazoo, just hit CTRL+ALT+F1 and copy the old XF86Config file back into /etc/X11 with:



cp /home/someuser/XF86Config /etc/X11/



Or of course you can try to configure it again and again a couple of times before you go back to the old one.



Luck,



Finegan

Blerghh... P.S. Before you start to mess with X you're going to have to know:

the exact RAM amount of your video card and its precise name.
The Vertical and Horizontal refresh rates of your monitor.
Both of these can almost definately be found at the manufacturers website, and when in doubt you can get the monitor's serial number info off of the back.

Last edited by finegan; 07-01-2002 at 11:50 PM.
 
Old 07-03-2002, 11:01 PM   #7
BarkingRetard
LQ Newbie
 
Registered: Jun 2002
Posts: 12

Original Poster
Rep: Reputation: 0
Umm shit my mosue isnt working now..... before it was just when I was logged in as root but i changed the settings from a autologin to a box that popes up asking you who u want to login as. When linux starts theres just a pointer in the middle of the screen.... what did I do and how can i fix it..... this post is really old and i mihgt have to start a new one to get anyones attention....
 
Old 07-05-2002, 02:31 AM   #8
tincat2
Member
 
Registered: Feb 2002
Location: hills of WV
Distribution: slackware
Posts: 223

Rep: Reputation: 30
i think mandrake has a thing for this(monitor setings) in the control center, possibly under harddrake-monitor. with no mouse you will have to navigate by keyboard-i never got that down and haven't seen it anywhere outlined but the tab key, up and down arrows, enter and space seemed important,if i remember. you may get your mouse back by going in as root (ctrl+alt+f2 after your graphical comes up and log in as root) and doing a xf86config-mouse configuration is the first item on that agenda. get the mouse back first,you can do it logged in on f2 text-do the simplest option for your mouse(ps2,serial,2button or exact model) and let xf86config write that using your existing video entries(same ones you already put in) then reboot and see if you've got a mouse(you can do the mouse too from the control center i believe, but again,keyboard navigation). then work on the monitor.
 
Old 07-05-2002, 04:23 AM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I am completely lost with the mouse thing...

I think you are talking about after lilo, not during right? If so, I am now assuming you are talking about kdm (the window where you would click to select which user) am I right? Hope so...

Now, just as Fin said, type CTRL+ALT+F1

Then follow his directions:
Quote:
Originally Posted by Finegan

Hit CTRL+ALT+F1, that'll take you out of X and to a tty, a terminal. Log in as root.



cp /etc/X11/XF86Config-4 /home/someuser (this will make a backup of your configuration file)

cd /usr/X11/bin

./xf86config (follow the steps)



Hit CTRL+ALT+F7, that'll get you back to your X session. Log out and let X restart (no need to restart the whole machine), and the changes will have taken effect. If you don't like it, or it crashes, or goes kazoo, just hit CTRL+ALT+F1 and copy the old XF86Config file back into /etc/X11 with:



cp /home/someuser/XF86Config /etc/X11/



Or of course you can try to configure it again and again a couple of times before you go back to the old one.



Luck,



Finegan

Blerghh... P.S. Before you start to mess with X you're going to have to know:

the exact RAM amount of your video card and its precise name.
The Vertical and Horizontal refresh rates of your monitor.
Both of these can almost definately be found at the manufacturers website, and when in doubt you can get the monitor's serial number info off of the back.
To login as root as he said, type ROOT and your ROOT PASSWORD

Then type exactly as Fin said.

You do not need your mouse in a Console, so don't worry about it not working. You will probably fix it in the part where Fin said to run ./XF86Config

Your mouse should be up and working when you restart X at the end of Fin's great explanation.

Tincat has a good idea too, but you will definitely need to get into Console to do anything first.

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration