LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2005, 04:48 PM   #1
paul1892
LQ Newbie
 
Registered: Jan 2005
Distribution: Trying to use Redhat
Posts: 25

Rep: Reputation: 15
Question Multibooting - NEWBIE!


I run WinXP as standard and want to dual boot to a hard drive install of Knoppix 3.7. I also boot to RH9 which is via GRUB and works great! I have 2 problems ...

1/Knoppix is only bootable via a LILO floppy, can the RH grub be used to boot Knoppuix? What/where/how do I change this please?

2/Knoppix defaults to 1024 when I want 1280 resolution, manually I cannot choose 1280 as 1024 is the max displayed - the monitor can run 1280 in Windows. What/where/how do I change this please?

I'm a 5+ yr Windows user so please bear with me (I may need some assistance).

Thanks in advance,
Paul.
 
Old 01-03-2005, 05:44 PM   #2
sls
Member
 
Registered: May 2004
Location: North Wales UK
Distribution: Debian Woody Sarge/Sid
Posts: 77

Rep: Reputation: 15
As su in a terminal use the following to configure your monitor settings

dpkg-reconfigure xserver-xfree86

Follow the steps it will write a file.

It will change to the new settings when xserver restarts.

Sls
 
Old 01-03-2005, 05:53 PM   #3
sls
Member
 
Registered: May 2004
Location: North Wales UK
Distribution: Debian Woody Sarge/Sid
Posts: 77

Rep: Reputation: 15
To add knoppix to grub you will need to edit in Red Hat /boot/grub/menu.lst
You will need to add a similar example as below
The kernel entry needs to point to the kernel installed in /boot on knoppix and root to the device it is installed on and the same with the initrd entry



title Debian GNU/Linux, kernel 2.6.8-1-686
root (hd0,0)
kernel /boot/vmlinuz-2.6.8-1-686 root=/dev/hda1 ro
initrd /boot/initrd.img-2.6.8-1-686
savedefault
boot


Sls
 
Old 01-03-2005, 07:03 PM   #4
paul1892
LQ Newbie
 
Registered: Jan 2005
Distribution: Trying to use Redhat
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by sls
As su in a terminal use the following to configure your monitor settings

dpkg-reconfigure xserver-xfree86

Follow the steps it will write a file.

It will change to the new settings when xserver restarts.

Sls
Thanks - worked a treat, 1280 once again
 
Old 01-03-2005, 08:08 PM   #5
paul1892
LQ Newbie
 
Registered: Jan 2005
Distribution: Trying to use Redhat
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by sls
To add knoppix to grub you will need to edit in Red Hat /boot/grub/menu.lst
You will need to add a similar example as below
The kernel entry needs to point to the kernel installed in /boot on knoppix and root to the device it is installed on and the same with the initrd entry



title Debian GNU/Linux, kernel 2.6.8-1-686
root (hd0,0)
kernel /boot/vmlinuz-2.6.8-1-686 root=/dev/hda1 ro
initrd /boot/initrd.img-2.6.8-1-686
savedefault
boot


Sls
That also works fine, a few changes for my partition but other than that great
Now I have a new problem, since loading to Hard Drive, Knoppix has lost the sound? I have run soundcard configuration but to no evail.
 
Old 01-03-2005, 08:39 PM   #6
paul1892
LQ Newbie
 
Registered: Jan 2005
Distribution: Trying to use Redhat
Posts: 25

Original Poster
Rep: Reputation: 15
Angry

...oh and it seems to have reverted to German language?
 
Old 01-04-2005, 11:23 AM   #7
sls
Member
 
Registered: May 2004
Location: North Wales UK
Distribution: Debian Woody Sarge/Sid
Posts: 77

Rep: Reputation: 15
Hi

Which kernel are you using with Knoppix?

To change the default language if I remember right, there is a flag on the bottom panel if you click it you can select US.
If not you will need to start the control centre and select regional settings and change it there.

Sls
 
Old 01-04-2005, 05:30 PM   #8
paul1892
LQ Newbie
 
Registered: Jan 2005
Distribution: Trying to use Redhat
Posts: 25

Original Poster
Rep: Reputation: 15
Hi - It's 3.7 Knoppix with 2.6.9, I tried the flag but when I attempt to use office it's in German?

It's quite good fun playing with Linux thus far
 
Old 01-05-2005, 01:35 PM   #9
sls
Member
 
Registered: May 2004
Location: North Wales UK
Distribution: Debian Woody Sarge/Sid
Posts: 77

Rep: Reputation: 15
Hi

Have a look at this link for sound on the 2.6.8 kernel may help

http://www.linuxquestions.org/questi...hreadid=272496

Not sure about openoffice in German though.

Sls
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
multibooting simcox1 Mandriva 4 07-13-2005 10:36 AM
Multibooting How-To RodimusProblem LinuxQuestions.org Member Success Stories 3 02-22-2005 05:06 AM
MultiBooting various Distros WarpFactor Red Hat 1 10-02-2004 11:04 PM
Multibooting *Nix's krazykow Linux - Software 2 08-26-2004 02:38 PM
Multibooting with SuSe 7.2 william8 Linux - General 2 11-08-2002 11:44 AM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration