LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2007, 07:44 AM   #1
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Rep: Reputation: 30
Question mplayer


Hi again, thought I'd take a look at mplayer which I downloaded form linux packages. There were quite a lot of dependencies, which I also downloaded from linux packages.
I installed all the relevant packages without problem, but (there is always a but isn't there?) I tried to run the program without success. I run the program from the "run command" choosing a terminal for ease of classifying the problem. This is the info that came up:

Quote:
mplayer: error while loading shared libraries: liba52.so.0: cannot open shared object file: No such file or directory
Is there anyone that can shed some light on the matter? I guess it is a case of some symbolic links or something like that.

As always, appreciate any help that you can give.

bookie
 
Old 06-12-2007, 08:51 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
Quote:
liba52.so.0: cannot open shared object file: No such file or directory
I guess you missed a dependency, which is liba52If you cannot find a precompiled package for Slack, then d/l it from the link I gave you and install it like this:
Code:
./configure --prefix=/usr --enable-shared
make
su 
make install
ldconfig
Regards
 
Old 06-12-2007, 01:40 PM   #3
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Thanks bathory

Thanks for your prompt reply. I find it strange that the slack required list didn't include liba52? I went ahead and installed it - following your instructions. Unfortunately, it didn't help. I am getting the same problem. The other thing that is strange is that I can't find liba52 listed by the Kpackage. I usually install most packages as root - which I did with mplayer. When I returned to user - I couldn't find mplayer listed in the media list?
Have you any more suggestions as to how I can solve my problems?

bookie
 
Old 06-13-2007, 03:03 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
Does this liba52.so.0 created under /usr/lib? What is the output of:
Code:
ls -l /usr/lib/liba52.so*
Take a look in /etc/ld.so.conf to see if the path "/usr/lib" exists (it should exist). If not, add it and run ldconfig again.
Since I don't know how the mplayer package you installed was compiled, run:
Code:
ldd mplayer
to find out where it expects to find that library. If it's in different directory than the above create a symlink to that directory.
 
Old 06-13-2007, 03:40 AM   #5
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi bathory, i ran the following command


Quote:
ls -l /usr/lib/liba52.so*
the result was "no such file or directory." I had a look in ls /etc/ld.so.conf - and this was the result:

Quote:
/usr/local/lib
/usr/X11R6/lib
/usr/i486-slackware-linux/lib
/opt/kde/lib
/usr/lib/qt/lib

I tried to run lld mplayer "command not found"

Have you any more suggestions?

bookie
 
Old 06-13-2007, 03:49 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by bookie
I tried to run lld mplayer "command not found"
It's "ldd".
 
Old 06-13-2007, 04:35 AM   #7
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
Since there is no liba52.so* in /usr/lib you didn't install it correctly, or it's installed in a different directory. Run as root:
Code:
updatedb
locate liba52.so
to find where the library is installed. Then add the directory containing liba52.so in /etc/ld.so.conf and run ldconfig.
Also as Nylex noted it's ldd mplayer.
 
Old 06-13-2007, 04:53 AM   #8
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Sorry Nylex

Sorry about the typing error.

Quote:
Originally Posted by Nylex
It's "ldd".

bookie
 
Old 06-13-2007, 05:12 AM   #9
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi again,
Well after udatedb I did the search as you said but couldn't find any thing at all!

bookie
 
Old 06-13-2007, 05:20 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
Quote:
Well after udatedb I did the search as you said but couldn't find any thing at all!
Are you running it as root? Because it should at least find liba52.so in the directory you compiled the sources (the one created after extracting a52dec-0.7.4.tar.gz)!!!
 
Old 06-13-2007, 05:31 AM   #11
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi bathory

Sorry, read next message

Last edited by bookie; 06-13-2007 at 05:48 AM.
 
Old 06-13-2007, 05:33 AM   #12
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Well, I have been doing a little fishing. I thought that I would do a new install - from user mode. I cd to the folder and ran the first part of your code - the configure
/configure --prefix=/usr --enable-shared

but I didn't get anywhere at all "permission denied". Surely I don't need to be root to configure?

bookie

Last edited by bookie; 06-13-2007 at 05:36 AM.
 
Old 06-13-2007, 05:50 AM   #13
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
If you have ran "/configure --prefix=/usr --enable-shared" as root at a first place, then permission denied is normal. You can do it as root if you like, but in general it's good practice to run ./configure and make as normal user and run "make install" as root. Anyway, as root, run:
Code:
make distclean
to remove the previous compiled sources and and start over.
 
Old 06-13-2007, 07:21 AM   #14
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi bathory

Well, as I have said before to another linux member, you're not just a pretty face are you? I followed your instructions and then re-installed as user/root. I then checked to see if I had a read out for liba52.so - and I had. Now I have a new problem, which is probably on the same lines as the last one. When I downloaded all the packages from linux packages - I installed them as root instead of user/root. When I run mplayer I get a new problem as follows:

Quote:
mplayer: error while loading shared libraries: libfaad.so.0: cannot open shared object file: No such file or directory
I haven't installed such a file? The following is a list of the packages needed according to the slack required file submitted by mplayer:
Quote:
alsa-lib >= 1.0.11
arts >= 1.5
audiofile >= 0.2.6
cdparanoia >= IIIalpha9.8
faac >= 1.25
ffmpeg >= 20070419
gtk+2 >= 2.8.20
jack >= 0.101.1
lame >= 3.97
libdv >= 1.0
libjpeg >= 6b
libmad >= 0.15.1b
libmpcdec >= 1.2.5
libogg >= 1.1.3
libpng >= 1.2.12
libtheora >= 1.0
libungif >= 4.1.4
libvorbis >= 1.1.2
samba >= 3.0.23
sdl >= 1.2.11
slang >= 2.0.6
speex >= 1.2
svgalib >= 1.4.3
twolame >= 0.3.9
x264 >= 20070418
xmms >= 1.2.10
xvidcore >= 1.1.0

You will of course take comfort in that I am learning the hard way concerning working as root and user.

Have you any suggestions to the above problem?

bookie
 
Old 06-13-2007, 07:53 AM   #15
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
First of all run
Code:
ldd mplayer
to find out all the needed libraries and those you're still missing. According to the Mplayer software requirements you don't need all this stuff!!! As for libfaad you can get if from here and compile it as you did with liba52.so.
Another one thing you can try is to d/l the Mplayer source and compile it yourself. It should be easy if you meet the dependencies above and have already installed the various codecs.

***EDIT***
I've tried to compile faad and it needs id3lib!!!. So you have to install id3lib as usual and then for faad follow the instructions in README.linux. Note that before running "autoreconf -vif" this you must create by hand a directory named bmp under the directory plugins or else ./configure fails!! Then use:
Code:
./configure --with-mp4v2 --with-bmp
to compile

***EDIT 2***
libfaad compile fails for various reasons, so you best bet is to compile mplayer yourself.

Last edited by bathory; 06-13-2007 at 09:28 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer build: configure finds ALSA, but mplayer doesn't galle Linux - Software 5 10-13-2007 07:14 PM
Mplayer codecs - running 32bit mplayer on 64bit OS sleepyrob Linux - Software 2 08-12-2006 06:08 AM
In Kubuntu I have compiled MPlayer and it works fine, MPlayer Plug-in is not working kickass331 Linux - Newbie 10 08-11-2006 10:12 PM
No sound in mplayer or mplayer firefox plugin case1984 Linux - Newbie 1 01-21-2005 01:58 AM
mplayer is cool ... mplayer plug-in is even cooler..! linuxlah Linux - General 4 07-16-2003 11:55 PM


All times are GMT -5. The time now is 12:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration