LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-27-2005, 11:40 PM   #1
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
mx700 logitech mouse: not working properly


just put slack 10.1 on.. chose the same mouse as i did when i had (for the short time) slack 10, a usb mouse which worked.

i have a wireless usb logitech keyboard, and my mouse is a logitech mx700 wireless optical connected with the same usb port as the keyboard.

i tried running mouseconfig as root and when i choose usb mouse the mouse is recognized but only moves up and down, and acts weird, ie: right mouse jumps the cursor to far right of screen, the left side button of mouse (not 'left click') cliking will move the cursor to the far left of screen... the top mouse button (sorry, theres like 9 buttons on it) moves the cursor 1px to the left, etc etc.
i didnt find one that acted as a 'click' however.

how can i switch all the buttons around so that it moves properly X & Y? and get my left/right main buttons working appropriately?

i thought iv seen before that gpm was the mouse setup program for X (sorry i dont exactly know what im talking about ) but i found out that it is just the program to allow for cut/paste in virtual consoles.

i havent ran xf86config, i believe its called.. would this be the appropriate thing to do, and is it pretty straight forward?

thanks


edit: bah! i cant wait... imma go try and break i mean fix it now

Last edited by nadroj; 04-29-2005 at 12:52 AM.
 
Old 04-28-2005, 12:03 AM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Original Poster
Rep: Reputation: 59
ok, i couldnt even find the xf86config command.

any tips?
 
Old 04-28-2005, 01:32 AM   #3
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
Here is the website that really helped me when i installed 10.0.Shilo is a Geek

Your are looking for the xf86config.

I think it is here: /etc/X11/XF86Config

if not use slocate or whereis to find it.

Read This

Good Luck.

For mouse Auto has always worked for me.

Good Luck. Slackware is a great distro. I learned a lot using it.

Regards.
 
Old 04-28-2005, 02:03 AM   #4
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Original Poster
Rep: Reputation: 59
ya i was checking out the xorg.conf file and changed what it was to Auto and restarted computer but it didnt seem to do anything.. hopefully the first link will work for 10.*1* also.
thanks, ill check those things out now
 
Old 04-28-2005, 02:12 AM   #5
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Original Poster
Rep: Reputation: 59
i couldnt find much about the mouse on the first site, that was very helpful that i didnt know..
but the 2nd site, the very last line on the page, i believe it is, says that slackware [10?] doesnt use xf86free anymore? it uses X.org? so i need to run xorgconfig not xf86config.
ill go try that one, although i had previously edited the file manually and it didnt help.. and i would think this program is just an easier way of manually editing the file, oh well ill give it a shot
 
Old 04-28-2005, 08:09 AM   #6
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
I'm still on 10.0.
I thought 10.1 was still using xfree.
 
Old 04-28-2005, 01:56 PM   #7
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
Quote:
Originally posted by DeadPenguin
I'm still on 10.0.
I thought 10.1 was still using xfree.
xfree is included in the unsupported directory..........but
xorg is the default......
 
Old 04-28-2005, 11:05 PM   #8
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Original Poster
Rep: Reputation: 59
ok, cant get my wireless USB Logitech mx700 to work properly. i have ran mouseconfig, xorgconfig, and manually edited the /etc/X11/xorg.conf file and set the mouse to Auto and usb, but its not working.

any help?
 
Old 04-29-2005, 12:59 AM   #9
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Original Poster
Rep: Reputation: 59
ok heres my /etc/X11/xorg.conf input[mouse] section:

Section "InputDevice"
Option "CorePointer"
Option "Device" "/dev/mouse"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "false"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
EndSection

and i have ran this command 'xmodmap -e ponter = 1 2 3 6 7 4 5' but get an error.. something like ' cannot open display for '' ' or something similar.. sorry i cant remmeber it right now, in M$.

i thought there was a .xmodmap file i was supposed to edit (iv been searching LQ for other threads regarding this problem) but couldnt find one.. maybe i was just mistaken and you dont edit that file, or create it.

the mouse is recognized.. but say, moving up mouse the curosr down, and vice versa... right clicking mouse cursor far left, etc etc... its all screwy.

anyone any suggestions?
thanks..
 
Old 04-29-2005, 10:45 PM   #10
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
Change
Option "CorePointer"
to
Option "AlwaysCore"

also, you might want to change
Protocol "Explorer/PS2"
to
Protocol "imps/2"
I'm not sure that will help, but I've had better luck with imps/2 protocol than explorer mouse.

That said, I've had similar issues with my usb mouse in slack, and I got them fixed. (Unfortunately I can't remember how for the life of me).

You might want to try something like
ZAxisMapping "*insert two numbers here*"
and I think there's something similar in xorg for XAxis and YAxis. (X/Y are motion, Z is scrolling), and I'm sure there are options used to enable all your other copious buttons

anyhow, good luck, hope something I said was at least a *little* help

Last edited by pokemaster; 04-29-2005 at 10:47 PM.
 
Old 04-30-2005, 12:33 AM   #11
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Original Poster
Rep: Reputation: 59

indeed was, poke. thank you.

about the protocol.. ya iv been going through afew, iv just seen more who had this problem using ExplorerPS2 to solve it, oh well ill try your way too; cant hurt.

the alwaysCore option i never heard of, ill change that.

the x,y axismapping options you mention i also didnt see in my searches.. although makes logical sense!

thats my main problem.. my mouse IS recognized.. but only mouse up/down.. and its odd, as i said earlier.. my right click moves the cursor left, etc etc..
maybe i can add that xaxismapping and that might help for the X-coordinate problem.. still none of the clickys will work though

thanks though, ill try it.
 
Old 05-05-2005, 09:18 AM   #12
ramke
LQ Newbie
 
Registered: Apr 2005
Location: sa
Distribution: Slack
Posts: 15

Rep: Reputation: 0
I had that problem too
i have to type

modprobe -r usbmouse
modprobe hid

every time i reboot my system.


options


Section "InputDevice"
Option "CorePointer"
Option "Device" "/dev/mouse"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "false"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
EndSection

just won't work for me,
 
Old 05-05-2005, 12:02 PM   #13
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
Quick little question... is the mouse you're having trouble with the only mouse on your system?

i.e. I work on a laptop, when my mouse did those things it was my usb mouse goin screwy, but my touchpad still worked beautifully. Turned out all I had to do was to create a second mouse section in my xorg.conf file to accomodate the usb mouse. Here's my xorg.conf stuff, maybe it'll help:

Code:
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        ### here's the server declaration of my two mice,
        ### note that only one mouse can be "CorePointer",
        ### the rest must be "AlwaysCore"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Mouse1" "AlwaysCore"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection

Section "Module"
. 
. unimportant...
. 
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"        ### This is my touchpad, and has lots of touchpad-specific options (ones with ***)
        Identifier  "Mouse0"
        ***Driver      "synaptics"
        ***Option      "Protocol" "auto-dev"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        ***Option      "SHMConfig" "yes"
        ***Option      "MaxSpeed" "1"
        ***Option      "AccelFactor" "1"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Input Device"        ### This is my usb mouse section, note I don't have the "AlwaysCore" in here,
        Identifier  "Mouse1"  ### Because that's in the ServerLayout section.
        Driver      "mouse"
        Option      "Protocol" "imps/2"
        Option      "Device" "/dev/mice"
        Option      "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
. 
. unimportant....
. 
EndSection

Section "Device"
. 
. vid card....
. 
EndSection

Section "Screen"
. 
. also unimportant...
. 
EndSection

Section "DRI"        ### lol, no idea what this is, but probably something for my vid display...
        Group        0
        Mode         0666
EndSection

As always, hope that helps...


[edit] something I noticed just after I posted... try changing /dev/mouse to /dev/mice, b/c /dev/mice seems to work better with usb mice for some reason... [/edit]

Last edited by pokemaster; 05-05-2005 at 12:05 PM.
 
Old 05-05-2005, 05:40 PM   #14
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Original Poster
Rep: Reputation: 59
alright.. thanks alot poke, appreciated.

what mouse do you have/how many buttons on it? (the usb one)

yes.. i only have one mouse (logitech mx700 optical wireless usb) on my desktop.
the reply before this one that i made, referring to your response, i did try and it didnt seem to solve it.

i tried the both (one or the other) corepointer/alwayscore options with no success it seems.

for the protocol, isnt there just one for 'usb' or something? i dont understand why i should set it to *ps/2.. oh well, it seems thats what everyone uses anyway.

also.. 2 nights ago i deleted the slack partition, cause i was gonna try gentoo.. and that is a nitemare! i didnt even get to install it cause i was lost after booting to the install cd! but i also downloaded and burned knoppix live cd... i checked the xorg.conf file there and under device it said '/dev/input/mice' i believe.. i can double check... but if this is the case, should editing the default line that it had for me in my slackware install's xorg.conf (id be happy to reinstall it if it might work) to the one that it shows for the knoppix system?

the mouse still works and is recognized with how it was layed out in the xorg file for my slack install, just not working properly... would changing that /dev/... line really matter?

thanks again.

and ya, is helpful.
 
Old 05-05-2005, 06:05 PM   #15
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
Yea, the /dev line is gonna be different depending on the system. Often, /dev/mouse is a symlink for the psaux (ps2 mouse) and /dev/mice links to the usb. Try reinstalling slack, and put your knoppix xorg mouse options in the place of the slack ones -- it should fix your problems!

Last edited by pokemaster; 05-05-2005 at 09:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
refresh rate horizontal/vertical sync TV cjae Linux - Hardware 1 04-15-2005 11:41 PM
vertical and horizontal refresh rate of presario 2568 AI melinda_sayang Linux - Laptop and Netbook 0 10-13-2004 09:40 AM
Horizontal and vertical refresh sharpie General 5 01-24-2004 08:17 PM
Horizontal and vertical refresh rate johannes Linux - Laptop and Netbook 3 10-31-2003 06:44 AM
negative horizontal and vertical refreseh rates sanjeevan Linux - Newbie 1 06-28-2003 01:46 PM


All times are GMT -5. The time now is 03:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration