LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-21-2004, 04:45 PM   #1
kosh42
LQ Newbie
 
Registered: May 2004
Location: Hampshire, UK
Distribution: Fedora
Posts: 13

Rep: Reputation: 0
Question Mounting Problems - Permissions


OK, I have the following in my fstab:
Code:
/dev/sda1               /mnt/cardreader         auto    sync,noauto,user,exec,rw 0 0 #HOTPLUG B3Fu.Ua$
/dev/hda1               /mnt/win95              auto    auto,user,exec,ro 0 0
/dev/hda5               /mnt/winfiles           auto    auto,user,exec,ro 0 0
This allows me to right click on my desktop and mount any of these three... For some reason, the win95 and winfiles mounts are only readable if I am logged in as root. I have changed the permissions, but everytime I issue the mount command, it changes the properties to read and execute only for root. Any ideas why?

Also, the card reader will mount and I can read and delete files. However, it will only let me write a meg of data on the card before it says its full... And its a 128Mb card Any ideas on this also?

Many thanks,

Tim The Noob...
 
Old 05-21-2004, 05:05 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Try changing auto into vfat and all that follows into default:

/dev/hda5 /mnt/winfiles vfat( or ntfs or whatever) default 0 0

This will give you read and execute privilege to all and write privilege only to root, so your win partition won't get screwed up.

Peace!
 
Old 05-21-2004, 05:09 PM   #3
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
You have to set the access rights for your windows partitions with umask.
This is not done by simply changing the access rights of the mountpoint.

So add umask=0000 to the lines with the mount options for the windows partitions
in order to allow ANYONE to read and write from/to the windows partitions.

OK, since you are mounting read only, umask=0222 is the right option.

Better:
I suggest you group all valid users in a group. Usually they are grouped per default into a group called "users".
Find the group id of users by loging in as a non-root user and typing
id

let's say this gid=100

then add following to the mount options in fstab

gid=100, umask 0007

This will allow only the members of the "users" group to read/write and execute
from/to your windows partition.

In your case, since you mount read-only it could be, e.g.:

/dev/hda1 /mnt/win95 auto auto,gid=100, umask 0227,user,exec,ro 0 0
 
Old 05-22-2004, 03:12 AM   #4
kosh42
LQ Newbie
 
Registered: May 2004
Location: Hampshire, UK
Distribution: Fedora
Posts: 13

Original Poster
Rep: Reputation: 0
Arrow Cardreader problem...

Right... I found the problem with the card reader was that I was deleting files and they were going to the .Trash-user directory on the card, thus leaving no space. Is there a way to stop this hapening? I don't want to su in every time I delete files to the delete the trash...

Still playing with the Windows partitions

Cheers,

Tim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WOW mounting problems with permissions betomurcia Linux - Newbie 3 10-23-2005 10:07 PM
Mounting Permissions canuck_barlow Linux - Newbie 11 03-16-2005 10:33 PM
Having problems mounting a drive (with appropriate permissions...) Robhogg Linux - Hardware 3 11-01-2004 03:14 PM
Mounting Permissions ewto Linux - Newbie 2 09-30-2003 05:22 AM
Mounting permissions loganwva Linux - Networking 2 04-25-2002 05:14 PM


All times are GMT -5. The time now is 03:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration