LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-15-2003, 09:51 AM   #1
fredws
Member
 
Registered: Mar 2003
Posts: 35

Rep: Reputation: 15
Mounting NTFS read-write


Can you mount a NTFS read-write?
I changed the fstab from ro to rw, but doesn't seem to make any difference. Do I have to reboot?

TIA,
Fred
 
Old 08-15-2003, 09:59 AM   #2
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Exclamation Danger Will Robinson, Danger

You are taking a big risk ...

NTFS support is Read-Only.
Do NOT write to NTFS from Linux.
It may corrupt your NTFS filesystem.
 
Old 08-15-2003, 10:02 AM   #3
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
Check out this:

http://linux-ntfs.sourceforge.net/info/ntfs.html

You have to enable write support in the kernel I think. But it is listed as DANGEROUS when you run menuconfig for kernel configuration. I guess write support still doesn't work well. I haven't tried it myself. I have a Fat32 partition for sharing files between windows and linux.
 
Old 08-15-2003, 10:29 AM   #4
Strike
Member
 
Registered: Jun 2001
Location: Houston, TX, USA
Distribution: Debian
Posts: 569

Rep: Reputation: 31
Re: Danger Will Robinson, Danger

Quote:
Originally posted by Mathieu
You are taking a big risk ...

NTFS support is Read-Only.
Do NOT write to NTFS from Linux.
It may corrupt your NTFS filesystem.
In fact, I believe that you actually definitely WILL corrupt the filesystem if you do write to it. I remember reading somewhere that the NTFS write capability always (intentionally) corrupts the filesystem, but it tries to do so in a way that's easy to repair by the NTFS repair utility.

But yeah, in short, don't mount NTFS r/w.
 
Old 08-15-2003, 11:16 AM   #5
fredws
Member
 
Registered: Mar 2003
Posts: 35

Original Poster
Rep: Reputation: 15
OK, sounds like it would not be a good idea then.
The reason I was wanting to was because everything that I copy from the windows side is "read-only" and I have to do a chmod on the files each time. Is there an automatic way to do this?
Thanks!
 
Old 08-15-2003, 11:45 AM   #6
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
If you are copying a directory, you can change the permissions of the directory and all of the files and sub-directories in it with the following syntax:
Code:
chmod -R 664 myDirectory
Or
you can always create a script which does a cp and then a chmod.
 
Old 08-15-2003, 11:59 AM   #7
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
I believe changing the umask might do the trick for you. Try setting it to 027 by typing "umask 027" at the console.
 
Old 08-15-2003, 12:03 PM   #8
fredws
Member
 
Registered: Mar 2003
Posts: 35

Original Poster
Rep: Reputation: 15
so in the fstab, would that be umask= 0 2 7 ?
 
Old 08-15-2003, 12:06 PM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
No spaces though:
umask=027

I don't know whether this'll stick across the filesystems when copied though. And the 0 in that umask will not enable the write bit even though it'll essentially be creating a chmod of 7 (because of the above mentioned kernel compile requirement).

COol
 
Old 08-15-2003, 12:12 PM   #10
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
Yeah, I didn't mean that it would enable write access to the NTFS volume, I meant it would make it so he doesn't have to change permissions when he copies files from the NTFS volume over to his Linux partition(s). I've never really used umask, was I correct about it?
 
Old 08-15-2003, 12:16 PM   #11
fredws
Member
 
Registered: Mar 2003
Posts: 35

Original Poster
Rep: Reputation: 15
Well, I changed it in the fstab to:
/dev/hdb1 /mnt/windows ntfs iocharset=iso8859-1,ro,umask=027

but the file is still read-only when I copy it to my home directory, do I need to do something to make the new fstab active?
 
Old 08-15-2003, 12:18 PM   #12
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
Ummm you may need to reboot. I am sure there is a command to do what you are asking, but I don't know what it is, I only know a reboot would do it

And yes, that normally is the Windows way of doing things, but when you don't know the command to reinitialize something, why not just let the system do it for you?
 
Old 08-15-2003, 12:26 PM   #13
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Nah, just ask

mount -a -o remount
OR
umount /mnt/windoze
mount /mnt/windoze
To issue the remount command in 2 commands rather than one.



And I don't know if it'll work either, but according to the umask, that is correct, but copying FROM windoze TO linux is a ball park I'm not all that familiar with.

OT:
SLC and WA eh? I'm in WA, and moving back to SLC I was originally from there. What part you from? Me, Glendale originally, moved to West Valley, went to Kennedy Junior High and Hunter High, graduated from Granite. Feel free to email me so we don't clog this guys thread (sorry for the temporary heist ).

Cool
 
Old 08-15-2003, 12:31 PM   #14
fredws
Member
 
Registered: Mar 2003
Posts: 35

Original Poster
Rep: Reputation: 15
OK, now I get "permission denied" when trying to move to /mnt/windows as a regular user. it has:
dr-xr-x--- 1 root root 12288 Aug 13 18:01 windows/

any ideas?
 
Old 08-15-2003, 12:33 PM   #15
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Ah yeah, shoulda caught that, my bad.

It has been established (yet for unknown reasons) that you need a umask=000 for NTFS to work for simple read-only for users. The script idea sounds like the best solution at this point. That or an alias (alias might be better actually).

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Read/write to ntfs from knoppix dosnlinux Linux - Newbie 6 06-10-2005 03:35 PM
Mounting NTFS Filesystems with Read-Write privs' apocolipse Slackware 2 12-20-2003 03:29 PM
NTFS Read Write Snabber Linux - Newbie 1 12-23-2002 07:42 PM
mounting ntfs with read/write xofire Linux - General 4 07-11-2002 08:33 AM
Mounting NTFS in read / write mode escrotto General 5 12-04-2001 05:26 AM


All times are GMT -5. The time now is 12:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration