LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-17-2006, 09:38 PM   #1
JamesNewbie
LQ Newbie
 
Registered: Jan 2006
Location: Sarasota, FL
Distribution: Fedora
Posts: 27

Rep: Reputation: 15
Mounting FAT32


Hi, new to Linux (obviously) and just installed Fedora last week. I have 4 partitions spread through 2 hard drives. Suprisingly I can boot to just fine to linux or winxp without a problem. Now that I am in Fedora I would like to be able to access a FAT32 partition a a way to share files between the two OS (music, drivers I download to get my network card working under Fedora, etc). If it is possible, how do I do it? Thanks.
 
Old 01-17-2006, 10:05 PM   #2
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
First, you need to figure out which partitions are FAT32. You would use the mount command to mount partitions. In Linux, you can only access contents of a partition if you mount that particular partition.

You would know which FAT32 partitions to use by:

Code:
fdisk -l
You can search this forum for help with mount command. There are zillion posts on mounting FAT32 partitions. You can also use, man pages that come with linux

Code:
man mount
To get help on man command

Code:
man man
There are two ways to mount a partition:
1. To mount a partition manually;
2. To mount a partition automatically at boot.

To mount manually, you have to use the mount command. To mount automatically, you need to make specific entry in /etc/fstab file.

Here's my typical entry from /etc/fstab

Code:
/dev/sda3 /mnt/winshare vfat auto,users,rw,umask=000 0 0
The same thing with a manual mount command
Code:
mount -t vfat -o rw /dev/sda3 /mnt/winshare
Tux

Last edited by tuxrules; 01-17-2006 at 10:09 PM.
 
Old 01-17-2006, 10:07 PM   #3
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,477

Rep: Reputation: 191Reputation: 191
It's easy to setup but we need a little more info. Post your /etc/fstab file and the output of:

$ su
<enter root password>
# /sbin/fdisk -l

fstab controls what partitions are mounted at boot and fdisk -l lists all partitions by device file that your system recognizes, whether mounted or not.
 
Old 01-19-2006, 01:04 PM   #4
danjah
LQ Newbie
 
Registered: Jan 2006
Distribution: Fedora core 4
Posts: 7

Rep: Reputation: 0
Hello, I'm new to linux too, I am also using FC4.
I have jumped from forum to forum, topic to topic and landed here.
here is some info..


Disk /dev/hda: 61.4 GB, 61492838400 bytes
16 heads, 63 sectors/track, 119150 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System

Disk /dev/hdb: 80.0 GB, 80060424192 bytes
255 heads, 63 sectors/track, 9733 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 1023 8217243 54 OnTrackDM6

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 104391 83 Linux
/dev/sda2 14 19457 156183930 8e Linux LVM

Disk /dev/sdb: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 2 12748 102390277+ f W95 Ext'd (LBA)
/dev/sdb2 * 12749 16572 30716280 c W95 FAT32 (LBA)
/dev/sdb3 16573 19929 26965102+ c W95 FAT32 (LBA)
/dev/sdb5 3826 12748 71673966 e W95 FAT16 (LBA)
_______________________________________________________________________
The setup as you see above is 2x160gb Maxtor SATA's NO RAID!!!
sda1=linux boot
sdb2=windoze boot
all but linux are fat32 partitions, unknown to me the 2xIDE's appear to have no partitons in linux! Why? (visible in XP)

Basicly, I would like very much to know how to be able to see the fat partitons in Linux.
I have read lots of forums, man, and HOWTO's but none so far have done anything but add folders here and there which don't link to the drives!

Sorry for the lengthy comment, please help!
Danjah
 
Old 01-19-2006, 01:09 PM   #5
danjah
LQ Newbie
 
Registered: Jan 2006
Distribution: Fedora core 4
Posts: 7

Rep: Reputation: 0
Also, this is what happens as i try the above suggestions...

mount: mount point /mnt/winshare does not exist
[root@localhost ~]# mount -t vfat -o rw /dev/sdb1 /mnt/windrive
mount: mount point /mnt/windrive does not exist
[root@localhost ~]# mount -t vfat -o rw /dev/sdb1 /mnt/WinDrive
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or other error
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)
In some cases useful info is found in syslog - try
dmesg | tail or so
 
Old 01-19-2006, 01:22 PM   #6
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 2,117

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
You have to create the mountpoint before you can mount to it. You did not create "/mnt/winshare".

To fix (at least the missing mountpoint part):
Code:
$ su -
# cd /mnt
# mkdir winshare
[edit]
p.s. - When you "mkdir /mnt/winshare" (an alternate way of doing the same as above) you will only be creating an empty directory. Known as a "mountpoint". Then you need to run the "mount" command to actually mount the FAT32 partition to the newly created mountpoint. Then, and only then, will you be able to see the contents of the FAT32 partition.
[/edit]

Last edited by haertig; 01-19-2006 at 01:40 PM.
 
Old 01-19-2006, 01:37 PM   #7
danjah
LQ Newbie
 
Registered: Jan 2006
Distribution: Fedora core 4
Posts: 7

Rep: Reputation: 0
RE: p.s -
I've tryed mounting it! - This is what I get...

[root@localhost ~]# mount -t vfat -o rw /dev/sdb1 /mnt/WinDrive
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or other error
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)
In some cases useful info is found in syslog - try
dmesg | tail or so

Last edited by danjah; 01-19-2006 at 01:45 PM.
 
Old 01-19-2006, 01:45 PM   #8
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 2,117

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Quote:
Originally Posted by danjah
Ahh yes, if you look a little closer, I was reading/typing the example, I corrected it later to WinDrive...

Any suggestions?
Well, since the error you are receiving is very specific:
Code:
[root@localhost ~]# mount -t vfat -o rw /dev/sdb1 /mnt/windrive
mount: mount point /mnt/windrive does not exist
"mount point /mnt/windrive does not exist"

...then you would need to run "mkdir /mnt/windrive" rather than "mkdir /mnt/winshare".

;-)
 
Old 01-19-2006, 01:46 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,961

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
danjah
sdb1 is an extended partition and can not be mounted. Your data partitions are sdb2,3,and 5
 
Old 01-19-2006, 01:48 PM   #10
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 2,117

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
OK, now I see that you re-edited your post above and it's now saying something totally different. Stop doing that! Make a new post and say "I mistyped above, this is what I really meant to say..."

Otherwise, we get terribly confused here because we'll type a post, like mine above, that referes to some text quote that no longer exists (because you edited it out). Very confusing.

Please make a new post stating exactly what is happening NOW. ;-)
 
Old 01-19-2006, 01:55 PM   #11
danjah
LQ Newbie
 
Registered: Jan 2006
Distribution: Fedora core 4
Posts: 7

Rep: Reputation: 0

Appologise for the messy forum
_____________________________________
From the top.
1: mkdir /mnt/WinDrive
mount /dev/sdb2 /mnt/WinDrive (thanks michaelk)
(please tell me which switches to use) -rw etc...
 
Old 01-19-2006, 02:02 PM   #12
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 2,117

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Editing previous posts is not always bad. Just don't change the entire nature of the post. Add information, don't change something that's already there (minor spelling/grammer corrections are exempt). It's also nice to add an [edit][/edit] section similar to what I did above so that people know something has changed or been added since the original post.

"mount point /mnt/windrive does not exist" is TOTALLY different than "mount: wrong fs type, bad option, bad superblock on /dev/sdb1,"

Just some tips to help you get better help in the future!

Try:
Code:
mount -t vfat -o rw /dev/sdb2 /mnt/windrive
This should mount your FIRST FAT32 partition. Looks like you have two FAT32's and one FAT16 you could choose from.
 
Old 01-19-2006, 02:03 PM   #13
danjah
LQ Newbie
 
Registered: Jan 2006
Distribution: Fedora core 4
Posts: 7

Rep: Reputation: 0
It actually worked!!!
____________________
[root@localhost ~]# mount /dev/sdb2 /mnt/WinDrive

Thank you everyone

Last edited by danjah; 01-19-2006 at 02:09 PM.
 
Old 01-19-2006, 02:11 PM   #14
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 2,117

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
OK, I'm NOT going to edit my post above! I'll add a new one.

It looks like over time /mnt/windrive has changed to /mnt/WinDrive on your system. Character case is significant! Modify whatever suggestions you get to account for the slippery naming convention of this mountpoint.

;-)
 
Old 01-19-2006, 02:12 PM   #15
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 2,117

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Our posts evidently crossed in the ethernet. Guess you figured out the character case thing already. Glad it worked.

[edit]spelling corrections[/edit]
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting fat32 gachejad Fedora 2 09-30-2005 11:33 AM
Mounting FAT32 Proxy Hoar Linux - Newbie 7 11-22-2004 08:38 PM
mounting fat32 wellblue88 Linux - Hardware 3 05-28-2004 01:05 PM
mounting fat32 jedavies123 Linux - General 1 11-03-2003 09:25 PM
mounting FAT32? FaLLeNSouL Linux - Newbie 2 03-28-2003 05:20 AM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration