LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2004, 10:43 PM   #1
rhraz
Member
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 80

Rep: Reputation: 16
Mounting a floppy drive


When I look at my /mnt directory I only see my cdrom. How would I go about mounting my floppy drive?
 
Old 02-10-2004, 10:55 PM   #2
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
First, we'll get root able to mount it, then we'll worry about users...

As root, create a directory to mount it to...
# mkdir /mnt/floppy

Put a floppy in, and try mounting it...
# mount -t vfat /dev/fd0 /mnt/floppy

If it doesn't give you an error, try listing what's on the floppy...
# ls /mnt/floppy

If it lists, you are golden. You can then unmount it with...
#umount /mnt/floppy
...Note the spelling, it's not uNmount, it's umount. I don't know why, it just is.

If that works, reply, and we'll work on setting up you /etc/fstab to allow any user to mount/unmount the floppy.
 
Old 02-11-2004, 12:18 PM   #3
rhraz
Member
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 80

Original Poster
Rep: Reputation: 16
Hrmm. I tried what you said. Here is exactly what I did...

[jared@localhost jared]$ su -
[root@localhost root]# mkdir /mnt/floppy
[root@localhost root]# mount -t vfat /dev/fd0 /mnt/floppy
mount: /dev/fd0 is not a valid block device
[root@localhost root]#

It gave me that "mount: /dev/fd0 is not a valid block device". I know the floppy is working because I recently used it to flash my bios.
 
Old 02-11-2004, 12:22 PM   #4
rhraz
Member
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 80

Original Poster
Rep: Reputation: 16
Ack, nevermind, that worked. I'm a retard. I didn't have a disk in . Now we can try to make it so that every one can do that. Also, how can I get it to mount automatically on startup?
 
Old 02-11-2004, 01:08 PM   #5
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Add a line to the /etc/fstab file. For how to do so: look at the file, it's almost self-explanatory; read 'man fstab'; search here, it's asked all the time. For automatic mounting put 'auto' in the options field.

Last edited by aaa; 02-11-2004 at 01:10 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting floppy drive foliva SUSE / openSUSE 2 09-21-2005 03:24 PM
mounting floppy drive Dogman2 Mandriva 6 03-28-2005 02:36 PM
mounting floppy drive??? SillyLinuxNewb Linux - Laptop and Netbook 1 12-29-2004 05:59 AM
mounting floppy drive Nigel Linux - Hardware 5 12-05-2003 05:44 AM
Need help mounting floppy drive everythingand2 Slackware 16 10-11-2003 07:06 PM


All times are GMT -5. The time now is 12:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration