LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2012, 01:46 AM   #1
sumeet inani
Member
 
Registered: Oct 2008
Posts: 895
Blog Entries: 26

Rep: Reputation: 48
missing dependency on rhel


Hi I have RHEL 5.2 . I did
#yum update
Code:
Loading "security" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
rpmfusion-nonfree-updates 100% |=========================| 2.8 kB    00:00     
epel                      100% |=========================| 3.4 kB    00:00     
cb3143d33c80b0986df2c1116 100% |=========================| 3.1 MB    00:06     
rpmfusion-free-updates-te 100% |=========================| 2.8 kB    00:00     
livna                     100% |=========================| 2.4 kB    00:00     
rpmfusion-nonfree-updates 100% |=========================| 2.8 kB    00:00     
rpmfusion-free-updates    100% |=========================| 2.8 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package libmodplug.i386 1:0.8.7-3.el5 set to be updated
---> Package libsndfile.i386 0:1.0.17-5.el5 set to be updated
---> Package libcdio.i386 0:0.78.2-6.el5 set to be updated
---> Package libmad.i386 0:0.15.1b-8.el5 set to be updated
---> Package fribidi.i386 0:0.19.2-2.el5 set to be updated
---> Package agg.i386 0:2.5-9.el5 set to be updated
---> Package libdca.i386 0:0.0.5-3.el5 set to be updated
---> Package mpeg2dec.i386 0:0.5.1-3.el5 set to be updated
--> Processing Dependency: libmpeg2 = 0.5.1-3.el5 for package: mpeg2dec
---> Package a52dec.i386 0:0.7.4-13.el5 set to be updated
---> Package libcaca.i386 0:0.99-0.5.beta16.el5 set to be updated
---> Package libkate.i386 0:0.3.8-1.el5 set to be updated
---> Package libid3tag.i386 0:0.15.1b-5.el5 set to be updated
---> Package x264-libs.i386 0:0.0.0-0.15.20080613.el5 set to be updated
---> Package cppunit.i386 0:1.12.0-4.el5.1 set to be updated
---> Package opencv.i386 0:1.0.0-3.el5 set to be updated
--> Processing Dependency: libx264.so.107 for package: ffmpeg
---> Package zvbi.i386 0:0.2.33-5.el5.1 set to be updated
---> Package taglib.i386 0:1.6.1-1.el5.3 set to be updated
---> Package portaudio.i386 0:19-8.el5 set to be updated
--> Processing Dependency: libjack.so.0 for package: portaudio
---> Package svgalib.i386 0:1.9.25-3.el5 set to be updated
---> Package flash-plugin.i386 0:11.2.202.233-release set to be updated
---> Package faac.i386 0:1.28-1.el5 set to be updated
--> Processing Dependency: libmp4v2.so.0 for package: faac
--> Running transaction check
---> Package jack-audio-connection-kit.i386 0:0.103.0-4.el5 set to be updated
--> Processing Dependency: libx264.so.107 for package: ffmpeg
---> Package libmp4v2.i386 0:1.5.0.1-6.el5 set to be updated
---> Package libmpeg2.i386 0:0.5.1-3.el5 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: libx264.so.107 is needed by package ffmpeg
Though my system has file

$ locate -i libx264.so
/usr/lib/libx264.so.107

Also rpm found on http://rpm.pbone.net/index.php3 , namely x264-0.0.0-0.4.20101111.el5.rf.i386.rpm is already installed.
# rpm -ivh Desktop/x264-0.0.0-0.4.20101111.el5.rf.i386.rpm
Code:
Preparing...                ########################################### [100%]
        package x264-0.0.0-0.4.20101111.el5.rf is already installed
 
Old 05-31-2012, 02:43 AM   #2
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 -Current
Posts: 889

Rep: Reputation: 182Reputation: 182
Try first -
# yum clean all

Then -
# yum update


Regards.
 
Old 06-01-2012, 07:45 AM   #3
sumeet inani
Member
 
Registered: Oct 2008
Posts: 895
Blog Entries: 26

Original Poster
Rep: Reputation: 48
Did not work

Quote:
# yum clean all
Loading "security" plugin
Loading "rhnplugin" plugin
Cleaning up Everything
# yum update
Loading "security" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
rpmfusion-nonfree-updates 100% |=========================| 2.8 kB 00:00
f4dd3526d2980e52051926a8f 100% |=========================| 17 kB 00:01
epel 100% |=========================| 3.4 kB 00:00
cb3143d33c80b0986df2c1116 100% |=========================| 3.1 MB 03:36
rpmfusion-free-updates-te 100% |=========================| 2.8 kB 00:00
12fc70b3db630a7fe06569974 100% |=========================| 61 kB 00:04
livna 100% |=========================| 2.4 kB 00:00
primary.sqlite.bz2 100% |=========================| 2.7 kB 00:00
rpmfusion-nonfree-updates 100% |=========================| 2.8 kB 00:00
d8d43dfb6a8a783b6dd214286 100% |=========================| 1.1 kB 00:00
rpmfusion-free-updates 100% |=========================| 2.8 kB 00:00
763a1aa69ace5e0d4f454974f 100% |=========================| 3.0 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
primary.xml.gz 100% |=========================| 11 kB 00:00
adobe-linu: ################################################## 17/17
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package libmodplug.i386 1:0.8.7-3.el5 set to be updated
---> Package libsndfile.i386 0:1.0.17-5.el5 set to be updated
---> Package libcdio.i386 0:0.78.2-6.el5 set to be updated
---> Package libmad.i386 0:0.15.1b-8.el5 set to be updated
---> Package fribidi.i386 0:0.19.2-2.el5 set to be updated
---> Package agg.i386 0:2.5-9.el5 set to be updated
---> Package libdca.i386 0:0.0.5-3.el5 set to be updated
---> Package mpeg2dec.i386 0:0.5.1-3.el5 set to be updated
--> Processing Dependency: libmpeg2 = 0.5.1-3.el5 for package: mpeg2dec
---> Package a52dec.i386 0:0.7.4-13.el5 set to be updated
---> Package libcaca.i386 0:0.99-0.5.beta16.el5 set to be updated
---> Package libkate.i386 0:0.3.8-1.el5 set to be updated
---> Package libid3tag.i386 0:0.15.1b-5.el5 set to be updated
---> Package x264-libs.i386 0:0.0.0-0.15.20080613.el5 set to be updated
---> Package cppunit.i386 0:1.12.0-4.el5.1 set to be updated
---> Package opencv.i386 0:1.0.0-3.el5 set to be updated
--> Processing Dependency: libx264.so.107 for package: ffmpeg
---> Package zvbi.i386 0:0.2.33-5.el5.1 set to be updated
---> Package taglib.i386 0:1.6.1-1.el5.3 set to be updated
---> Package portaudio.i386 0:19-8.el5 set to be updated
--> Processing Dependency: libjack.so.0 for package: portaudio
---> Package svgalib.i386 0:1.9.25-3.el5 set to be updated
---> Package flash-plugin.i386 0:11.2.202.233-release set to be updated
---> Package faac.i386 0:1.28-1.el5 set to be updated
--> Processing Dependency: libmp4v2.so.0 for package: faac
--> Running transaction check
---> Package jack-audio-connection-kit.i386 0:0.103.0-4.el5 set to be updated
--> Processing Dependency: libx264.so.107 for package: ffmpeg
---> Package libmp4v2.i386 0:1.5.0.1-6.el5 set to be updated
---> Package libmpeg2.i386 0:0.5.1-3.el5 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: libx264.so.107 is needed by package ffmpeg
# locate -i libx264.so
/usr/lib/libx264.so.107
#ls -l /usr/lib/libx264.so.107
-rwxr-xr-x 1 root root 2031799 Dec 4 2010 /usr/lib/libx264.so.107

Last edited by sumeet inani; 06-01-2012 at 07:47 AM.
 
Old 06-01-2012, 08:29 AM   #4
sumeet inani
Member
 
Registered: Oct 2008
Posts: 895
Blog Entries: 26

Original Poster
Rep: Reputation: 48
I saw that " x264-libs-0.0.0-0.15.20080613.el5.i386.rpm obsoleted the installed rpm " in GUI details . So I installed it . Other packages got installed smoothly then .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Dependency ImpossibleS Red Hat 22 12-20-2010 05:15 PM
Missing Dependency saurabhvasa Linux - Software 2 08-27-2008 11:24 AM
Missing Dependency - yum hectorDUQUE Fedora 6 06-29-2008 09:33 PM
Tovid missing dependency ionmich SUSE / openSUSE 6 07-12-2007 05:23 AM
yum missing dependencY puppet Linux - Software 6 10-26-2005 11:20 AM


All times are GMT -5. The time now is 09:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration