LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-17-2003, 11:36 AM   #1
odat
LQ Newbie
 
Registered: May 2001
Posts: 29

Rep: Reputation: 15
Minicom on (OK, ancient) Mandrake - permissions


Hi, first of all, I admit I'm using Mandrake 6.0
Yes, I'm thinking of changing/updating, but maybe
not on this machine. I've tried everything I can
find to get the minicom program to run for a user,
not as root. (Running as root isn't a good idea, no?)
I've checked the permissions on the modem, /dev/ttyS1
I've set the modem in the minicom setup to be /dev/ttyS1
and not /dev/modem (which has different permissions)
/dev/ttyS1 has root for owner tty as group
my user (say its dauser) has tty in his/her groups

Still, when dauser tries to run minicom, it gets
this permission denied message.

There's supposed to be a file in /etc/minicom.users
(There is a dosemu.users file there) I put one there,
following the sample in the minicom man pages
with the line dauser dfl or dauser dfl ttyS1
It still doesn't work. I've looked in other places
wher this minicom.users might be, and its not there. (i.e.
running minicom -s (for setup) doesn't generate it.
This is embarassing and also I can't think of anything else
to do. I may be back asking this same question later for
another version (less antique) or another distro. I'd still
like to solve this one. Any archaeologists around?
 
Old 12-06-2003, 12:46 AM   #2
tiger3
Member
 
Registered: Nov 2003
Location: Land of the Rising Sun!
Distribution: Fedors Core 3, Red Hat 9, Mandrake 8.1
Posts: 52

Rep: Reputation: 15
I assume minicom works for you just fine as root. You are correct in setting the serial port, but have you checked the permissions on the minicom file itself? I used minicom yesterday and here are my permissions
-rwxr-xr-x 1 root uucp /usr/bin/minicom
c-rwxrwxrwx 1 root uucp /dev/ttyS0

As a regular user I can use the command minicom -s
My minicom ver 2.00.0 (came with RedHat 9)
Hope this helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ancient Linux resources dinolinux General 4 06-25-2005 09:45 AM
Best LiveCD for ancient laptops netcrusher88 Linux - Distributions 4 02-13-2005 03:02 AM
Ancient Klingon programming says dushkinup General 5 03-24-2004 06:04 AM
Distros for ancient laptops jburford Linux - Laptop and Netbook 1 08-16-2003 12:14 PM
Browser first-aid, ancient Mandrake box odat Linux - Software 1 06-19-2003 04:55 PM


All times are GMT -5. The time now is 06:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration