LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2004, 06:52 PM   #1
rhraz
Member
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 80

Rep: Reputation: 16
Logging in as root in Mandrake 10 Community


I just installed Mandrake 10 Community. With Mandrake 9.2 i could choose "Log in as a different user" and type root and my root password. With 10 however it has a graphical user selection where you click on the user you want to log in as. It only shows one user and not root. How can I log in as root like this? Seems like some poor planing on Mandrakes part, or maybe I'm just missing something...
 
Old 03-30-2004, 07:46 PM   #2
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
I think they feel its more secure. Logging into "X" as root is more vulnerable to exploit than under console. If you want root as an option, fire up the login manager and "unhide" the root user. Then, root will be a choice for a graphical login.
 
Old 03-30-2004, 08:27 PM   #3
rhraz
Member
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 80

Original Poster
Rep: Reputation: 16
Well that makes sense. I'm looking for the login manager. I found something like it but I'm not sure it's what your talking about. It's located in the Mandrake Control Center and is called "Mandrake Linux Users Management Tool". I see how i can add users but nothing about unlocking root from being a selection at logon.
 
Old 03-30-2004, 08:50 PM   #4
xaxol
Member
 
Registered: Aug 2003
Location: Antelope, CA
Distribution: Ubuntu 9.04
Posts: 90

Rep: Reputation: 15
If you are using KDE,

Login as a regular rep.
Click on the Start Application Menu > Configuration > Configure your computer
Click on the + sign next to System
Click on Login Manager
Click on Administrator Mode on the bottom
Locate and select the Users Tab
Under the Hidding Users Field uncheck root and click apply
Close everything and logout.
root will be listed
 
Old 04-01-2004, 04:58 PM   #5
DocHoliday
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
Hi!

I have the same problem, I cannot login as root. I started login manager, but there is no Administrator Mode Button
 
Old 04-01-2004, 05:46 PM   #6
xaxol
Member
 
Registered: Aug 2003
Location: Antelope, CA
Distribution: Ubuntu 9.04
Posts: 90

Rep: Reputation: 15
DocHoliday,

Are you able to modify the setting?
Are the fields grayed out?
 
Old 04-07-2004, 07:23 AM   #7
chrisknight
Member
 
Registered: Jan 2003
Location: ohio
Distribution: CentOS5.5, SmoothWall 3.0
Posts: 139

Rep: Reputation: 15
I have the exact same problem... Finding the login manager as described above seems to be a different version of mandrake (or KDE) ...

I run x windows as root... I have for 3 years... I decided to try mandrake 10 from my redhat/fedora for something different...

Originally, I had no users defined... just root. But I couldnt got the system tray or the clock up in KDE as root... So I created a a user accound with admin rights... Now I cant login as root... the login prompt is as described above... my user to click on but no root.

Clicking 'configure your computer' --> 'system' does not give me the login manager... dont see it there...

I need to get back to loging in as root in x and have the clock and system tray...

any help would be great!

Thanks,
Chris
 
Old 04-07-2004, 07:55 AM   #8
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Here's the command you can use from the command-line:
Code:
kcmshell kdm
Be sure to do this as root:"su" and type your root password

Hit the "user" tab and check root off in the middle box so that it's not a hidden user anymore.
 
Old 04-07-2004, 08:36 AM   #9
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Here is a picture of it

Are you guys programmers? Do you constantly change and manipulate your system? Are you sysadmins? Just wondering why you need root access all the time. I use root all the time but I almost never start a root xsesseion. I'm just curious about this kind of stuff.

BTW, you may notice that I don't have root unchecked. I log in as root from the command prompt in a terminal and type startx. Comes up in KDE, since its my default.

Last edited by vectordrake; 12-19-2004 at 01:27 AM.
 
Old 04-08-2004, 04:19 PM   #10
Fatdaddy
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Quote:
Originally posted by vectordrake
I think they feel its more secure. Logging into "X" as root is more vulnerable to exploit than under console. If you want root as an option, fire up the login manager and "unhide" the root user. Then, root will be a choice for a graphical login.
i did this, then when i logged out of the user the root was still not there.

i tried it twice. still nothing
 
Old 04-08-2004, 05:30 PM   #11
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
Open kde control and goto system->login manager. Click on the users tab. To be able to change anything here you have to click on the button that gives it root priveleges. In KDE 3.2 it's an adiministrator mode button.
All you have to do is uncheck the root user from the list of hidden users.
 
Old 04-08-2004, 05:47 PM   #12
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Quote:
Originally posted by beejayzed
Open kde control and goto system->login manager. Click on the users tab. To be able to change anything here you have to click on the button that gives it root priveleges. In KDE 3.2 it's an adiministrator mode button.
All you have to do is uncheck the root user from the list of hidden users.
But you MUST do this as root or it won't work. Same thing can be achieved by firing it up from the CLI as root, as I mentioned above.
 
Old 04-08-2004, 06:08 PM   #13
Fatdaddy
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Quote:
Originally posted by beejayzed
Open kde control and goto system->login manager. Click on the users tab. To be able to change anything here you have to click on the button that gives it root priveleges. In KDE 3.2 it's an adiministrator mode button.
All you have to do is uncheck the root user from the list of hidden users.
i dont see an administrator mode button. could you possibily provide a pic so i can see where it is.
 
Old 04-20-2004, 09:38 PM   #14
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Posts: 3,366
Blog Entries: 33

Rep: Reputation: 216Reputation: 216Reputation: 216
Quote:
Originally posted by Fatdaddy
i dont see an administrator mode button. could you possibily provide a pic so i can see where it is.
I got it.
OK first, Im using Mandrake Linux 10.0 Community Download.

And this is what I found.

Start Button /System /Configuration /KDE /System /Login Manager

Configure login manager window opens.
Go to users page, and deselect root as hidden user.

You may also want to check in the next window that Auto login is disabled, Otherwise you wont get the option to login as root to KDE.

Da, Daaa!

Thanks for your assistance, It didnt give me the answer, but kept me looking for it.

Cheers. BTW, this post is from my new linux box install, through my win box firewall. Phew, Linux-Firewalls and networks in one intermingled lesson.

-----
Regards, Glenn
 
Old 04-20-2004, 09:41 PM   #15
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Posts: 3,366
Blog Entries: 33

Rep: Reputation: 216Reputation: 216Reputation: 216
[QUOTE]Originally posted by GlennsPref
[B]I got it.

From here:

http://www.atomicmpc.com/forums.asp?s=2&c=16&t=1949
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you log on to root in Mandrake 10.0 community edition? barratt Mandriva 13 06-26-2007 01:26 PM
Logging as Root (Mandrake 10.0) nazdrug Linux - Newbie 15 10-11-2004 08:52 AM
Logging in as root with mandrake 9.1 Getoutmarine Linux - Hardware 4 12-12-2003 12:42 PM
Logging in as root in Mandrake TheOneAndOnlySM Linux - Newbie 4 07-19-2003 12:29 AM
Logging in as root in Mandrake 9.1 arun79 Linux - Newbie 5 05-26-2003 01:51 PM


All times are GMT -5. The time now is 12:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration