LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-02-2003, 04:22 PM   #1
SpecialK5106
LQ Newbie
 
Registered: Oct 2003
Location: Gainesville, FL
Distribution: Slackware 9.1
Posts: 17

Rep: Reputation: 0
Linux will not boot (LILO doesn't start)


I recently put Slackware 9.0 on an old Dell Pentium 133 with a single 1.5 GB hard drive, and the installation went without error. I split the hard drive into three partitions. The first (/dev/hda1) contains the kernel and is set to be bootable. The second(/dev/hda2) is set aside for /home, and the final partition (/dev/hda3) is a 128 MB swap file. My lilo.conf file in /etc/ includes the following:

boot = /dev/hda
vga = normal

image = /boot/vmlinuz
root = /dev/hda1
label = Slackware
read-only

The system will not boot on its own. I don't think LILO even starts, because the first 'L' character isn't even printed. My screen shows some BIOS information, then a blinking cursor, and then nothing else happens. If I disable booting from a floppy in the BIOS, then I get the message "No boot signature in partition". Luckily, I made boot disks during installation, and they allow me to boot Linux.

LILO is installed, and I did run the lilo command, as root, without error. It seems to be that I just don't have any partition set to active, but fdisk does indicate that /dev/hda1 is bootable. So, what do you think it could be? How can I get Linux to boot on its own?

Thanks
 
Old 10-02-2003, 04:30 PM   #2
luxitan
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Gentoo
Posts: 78

Rep: Reputation: 15
did you especify that you wanted lilo in the MBR?
if not, run liloconfig and do it
 
Old 10-02-2003, 04:52 PM   #3
SpecialK5106
LQ Newbie
 
Registered: Oct 2003
Location: Gainesville, FL
Distribution: Slackware 9.1
Posts: 17

Original Poster
Rep: Reputation: 0
Well, I did do that, and still nothing. But I have a question related to that. Doesn't the line "boot = /dev/hda" in my lilo.conf indicate that I want it in the MBR? And then when I run lilo, shouldn't it then be installed in the MBR? Or does liloconfig do something additional?

Thanks
 
Old 10-02-2003, 05:52 PM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Maybe the BIOS is confused by having a bootloader in the MBR and a partition set as "active" - try taking away the "active" status of /dev/hda1 and let the BIOS find the bootloader in the MBR.
 
Old 10-02-2003, 06:20 PM   #5
SpecialK5106
LQ Newbie
 
Registered: Oct 2003
Location: Gainesville, FL
Distribution: Slackware 9.1
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks again, but that didn't work. I thought that the partition with the kernel had to be set to bootable?

I ran the command dd if=/dev/hda count=1 | strings | grep -i lilo .
A website that I was at indicated that the correct output should be

1+0 records in
1+0 records out
LILO

Instead, I get the following:
1+0 records in
1+0 records out
LILO
LILOu1^

What does that mean?
 
Old 10-02-2003, 06:25 PM   #6
luxitan
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Gentoo
Posts: 78

Rep: Reputation: 15
that doesnt mean nothing cause i get
1+0 records in
1+0 records out
LILO
üLILOu1^Í

and everythings ok with me

when you run liloconfig, and you do begin he will ask you if you want to use mbr, disk or superblock (not sure what this is). have you selected MBR, configurated and run LILO. it should work. it worked for me
 
Old 10-02-2003, 06:26 PM   #7
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
You could always try

gedit /etc/lilo.conf

change the

boot=/dev/hda

to

boot=/dev/hda1

then run the map installer

/sbin/lilo
 
Old 10-02-2003, 10:37 PM   #8
SpecialK5106
LQ Newbie
 
Registered: Oct 2003
Location: Gainesville, FL
Distribution: Slackware 9.1
Posts: 17

Original Poster
Rep: Reputation: 0
luxitan, I have tried liloconfig and it's just not working for me. But checking the MBR (with dd) shows that at least something related to LILO is being written there, even if it doesn't work.

Skyline, I tried what you recommended, and it doesn't work as well. Setting boot to hda1 would put it in the first partition (where the kernel is located), rather than the MBR, right? Then wouldn't I need some other bootloader in the MBR?

Something's seriously wrong here - it appears that LILO really is writing, and I have the correct configuration, right? Is there some other major step that I'm missing?
 
Old 10-02-2003, 10:43 PM   #9
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
have you tried installing lilo using
/sbin/lilo
instead of liloconfig? maybe there's something wrong with liloconfig.
 
Old 10-02-2003, 10:44 PM   #10
canon
Member
 
Registered: Feb 2003
Location: Seattle & N.Ireland
Distribution: Suse 9.current
Posts: 40

Rep: Reputation: 15
Has anything recently successfully booted off that hard drive, or could the first part of the disk be bad?
 
Old 10-02-2003, 10:46 PM   #11
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
actually, just noticed that you did try running lilo. Maybe you could post your whole lilo.conf? Someone might see something wrong.
 
Old 10-03-2003, 12:16 AM   #12
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Quote:
Setting boot to hda1 would put it in the first partition (where the kernel is located), rather than the MBR, right? Then wouldn't I need some other bootloader in the MBR?
No - the BIOS would simply load the partition table, then find the active partition and load the boot sector of that partition - if LILO was installed via boot=/dev/hda1 then it would be loaded from the boot sector of that partition - Conversly - if LILO was installed in the MBR it would simply ignore the active partition but unfortunately there's still appears to be problems with this also - As Canon mentioned, has anything recently been booted from the MBR of that drive?
 
Old 10-03-2003, 12:59 AM   #13
levian
LQ Newbie
 
Registered: Aug 2003
Location: kadin, jkt
Distribution: Dolphin,Shrike,98
Posts: 20

Rep: Reputation: 0
Hi all,

SpecialK, It seems that the problem has to do with your BIOS setting and your harddrive.
Old BIOSes sometimes hard to support or detect harddrive that is more than 1024 MB.
First, set your BIOS to its default setting, then boot your linux.
If that doesnt work, set your BIOS to detect your harddrive by auto mode and boot again.
If that doenst work as well, my last suggestion is to force LBA 32 during reinstallation

Hope this mean something......
 
Old 10-03-2003, 03:27 PM   #14
BlueWWWeb
LQ Newbie
 
Registered: Oct 2002
Location: Wonder Lake, IL
Distribution: Slackware
Posts: 7

Rep: Reputation: 0
I was having problems getting LILO to boot of my SCSI hd.. thats all i had was a seagate cheetah 9.1gb scsi and an IDE cd-rom... kept getting the L 99 99 (not even LI) ..after taking off the bootable of the partition that worked... why is that? using either mbr or superblock with the partition marked as bootable caused errors.
 
Old 10-04-2003, 03:33 AM   #15
SpecialK5106
LQ Newbie
 
Registered: Oct 2003
Location: Gainesville, FL
Distribution: Slackware 9.1
Posts: 17

Original Poster
Rep: Reputation: 0
I really appreciate all of the help, and I think that the problem has been resolved (sort of).

In the BIOS I have three settings for the boot sequence: Diskette First, CD-ROM First, and Hard Disk Only. When this whole thing started, if I selected "Diskette First", then I would get nothing but a blinking cursor after the BIOS loaded. If I selected "Hard Disk Only", then I would get the message "No boot signature in partition." I guess somewhere along the way, with some combination of settings, I managed to correctly load LILO in to the MBR. But it still wouldn't work, until I decided to switch the Boot Sequence back to "Hard Disk Only" (I had it on Diskette First).

So now, Linux loads, but only under "Hard Disk Only" booting. Does anyone have an idea why?

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO Boot config to start up Fedora besttech01 Fedora 13 03-31-2005 08:14 PM
Another Lilo dual boot (Linux+Linux) question tigerflag Slackware 11 05-22-2004 05:14 PM
dual boot - XP and Linux - Need to reinstall XP without effecting linux -LILO boot godofmind Linux - General 1 05-05-2004 09:13 AM
Lilo Grub will not start Linux does not boot Jano_64 Linux - Newbie 4 11-20-2003 03:15 PM
Start Linux from Bootmagic..No Lilo No Grub iamhigh Linux - Newbie 1 09-30-2003 04:54 AM


All times are GMT -5. The time now is 06:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration