LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-26-2004, 11:17 AM   #1
shadowsurfer
Member
 
Registered: Aug 2004
Location: philippines
Posts: 51

Rep: Reputation: 15
lilo boot loader


i have a pc with 2 HD on it ,primary HD consist of two partition (hda1 and hda2) hda1 is running win98os while hda2 running RH 7.2 . Primary slave consist of 2 partition also hdb1 (winme) and hdb2 none ... when i installed the RH7.2 the default set of the lilo boot loader is on hda1 and hda2. So when i boot my pc lilo prompt me to choose what os i will but when i choose windows it direct me to win98 (hda1). How can i set my lilo to set my windowsme as the second default o.s.? what is the command or file to be editted



thanks
 
Old 09-26-2004, 11:45 AM   #2
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
The file is lilo.conf. I think the location might be different for different distro's but for debian it's /etc/lilo.conf
 
Old 09-26-2004, 11:54 AM   #3
shadowsurfer
Member
 
Registered: Aug 2004
Location: philippines
Posts: 51

Original Poster
Rep: Reputation: 15
ive already modify it and change the setting from hda1 to hdb1 but it didnt work is there any file to configure
 
Old 09-26-2004, 12:58 PM   #4
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Yes, the file you need to edit/make changes is in lilo.conf. At the very bottom, do you see a "other" line? For example,
mine shows:

# other=/dev/hda4
# label=HURD
# read-only

Uncomment those lines.
1. Change other to point to your winme partition which would be: /dev/hdb1
2. Change label=WinME

After making the changes, you need to make it into affect so you will need to run 'lilo' afterwards. Now when you boot
up, you should see an option called WinME and upon clicking it, it would load WinME os for you. If that STILL doesn't
work, something else is messed up in your config file. Please paste it for us to see. Thanks and good luck.

-twantrd
 
Old 09-26-2004, 01:41 PM   #5
cincindie
Member
 
Registered: Jul 2004
Location: Zinzinnati, OH
Distribution: RH, FC 1-6, F 7-21, Debian, LinuxPPC, Knoppix, Ubuntu, Yellow Dog
Posts: 176

Rep: Reputation: 31
Also, after editing the lilo.conf file, you need to run /sbin/lilo -v for the changes to be written to your mbr.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO Boot Loader drumstick Linux - Software 1 05-20-2005 03:18 AM
Lilo Boot Loader problem Vindane Slackware 4 06-06-2004 11:13 PM
Installing Lilo Boot Loader qcoder Linux - General 1 01-09-2004 10:09 PM
How do I reconfigure Lilo boot loader? yzrider210 Linux - Newbie 10 12-12-2003 11:35 PM
Lilo to Grub Boot loader Maurice Arthur Linux - Software 3 07-23-2001 09:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration