LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-07-2010, 12:51 PM   #1
rgannon
LQ Newbie
 
Registered: Feb 2010
Location: PEI
Distribution: Ubuntu
Posts: 7

Rep: Reputation: 0
Question Lampp won't start Apache..."another web server daemon running". Ubuntu 9.10


I installed LAMPP a couple of weeks ago and was working fine. Today when I try to start lampp, it will only start MySql and ProFTPD. It says "XAMPP: Another web server daemon is already running." How can I find out where this other server is located and stop it?
 
Old 03-07-2010, 01:05 PM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
You could try :
stopapache

or
sudo /etc/init.d/apache2 stop

or
sudo /usr/sbin/apache2ctl stop

Have you installed another apache server ?

Run
sudo ps -u apache

or

sudo ps -u nobody

To see a list of processes owned by the usual apache owners.


If it's the xampp apache running then it doesn't matter, leave it running.

Or stop all the servers and then try starting them again.
 
Old 03-07-2010, 01:17 PM   #3
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
Check ps -e for this web server. Then try to figure out which one of the startup scripts starts it (use PID's to figure out boot sequence).
 
Old 02-18-2013, 05:15 AM   #4
ShivarajRH
LQ Newbie
 
Registered: Feb 2013
Posts: 1

Rep: Reputation: Disabled
Smile This worked for me...

good one...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CFLAGS vs EXTRA_CFLAGS, Ubuntu server 9.04 error while running "make install" Invisible-Man Linux - General 21 07-14-2009 07:31 AM
KPowersave's "The powersave daemon is not running" error MichaelMax SUSE / openSUSE 4 12-05-2005 12:58 PM
"mysqld ended" when trying to start mysql daemon guarriman Linux - General 1 01-19-2005 08:35 AM
Ubuntu: "There already appears to be an X server running on display :0." enderjm Debian 3 12-29-2004 08:46 AM
difference between "Web server local URL" and "IPv4 address"? kpachopoulos Linux - General 2 09-17-2004 02:30 PM


All times are GMT -5. The time now is 11:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration