LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-13-2007, 05:54 AM   #1
kantor_98
Member
 
Registered: Jan 2007
Posts: 68

Rep: Reputation: 15
keyboard issues


I want to have also a national keyboard, not only the english one. I am using fc6. I entered in
system/preferences/keyboard/keyboardlayout
and select also the national one.
But I don't know how to selet for use ! In win there ius a small icon down right. But in linux ?
 
Old 04-13-2007, 06:26 AM   #2
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: MX
Posts: 5,132

Rep: Reputation: Disabled
what is your first language?

2) are you using KDE window manager?

assuming yes its (i use Mandriva which should be similar)
go into kde control centre and then into the subfolders
Region and access.
keyboard layout

in layout TAB
click to enable it....and scroll down to your preferred language
change keyboard number to 105 or 104 etc

in switching options TAB
click to show indicator....(this is what win has)
click to show country

change to global...and most important

click on apply

then you can exit and it should be instant change


good luck
 
Old 04-13-2007, 06:55 AM   #3
kantor_98
Member
 
Registered: Jan 2007
Posts: 68

Original Poster
Rep: Reputation: 15
I am using gnome and I don't know where control center is... I have something else here...
 
Old 04-13-2007, 09:00 PM   #4
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: MX
Posts: 5,132

Rep: Reputation: Disabled
i do not use gnome but have a look at these pictures it looks like there is a tab for layouts so follow the instructing and then see if layouts has the answer?

http://www.debianadmin.com/special-c...in-ubuntu.html
 
Old 04-13-2007, 09:06 PM   #5
aus9
LQ Guru
 
Registered: Oct 2003
Distribution: MX
Posts: 5,132

Rep: Reputation: Disabled
if you are not a beginner....you may try this if above fails

source..... http://www.debian.org/doc/manuals/us...en.html#s-ctkm

13.6.2.1 Changing the Command Line Keyboard Mapping

1. Logged in as root user, type: dpkg-reconfigure console-data.

2. Answer the questions on the screen as they appear.

13.6.2.2 Changing the Desktop Keyboard Mapping

1. Check that the keyboard mapping that you want is installed in / usr/shre/keymaps/i386.

If it is not, then install the package before remapping.

2. Open /etc/X11/XF86Config-4 in a text editor.

3. Find the "Input Device" Section, then the Identifier "Generic Keyboard."

4. Edit the option "XkbLayout".

The default setting for "XkbLayout" is "us".

However, you can change this setting using any layout listed in / usr/share/keymap/i386. The setting must be enclosed in double quotation marks.

5. Restart your system, or restart the X Window System. The X Window System is now configured to use the new keyboard mapping
 
Old 04-19-2007, 02:32 AM   #6
kantor_98
Member
 
Registered: Jan 2007
Posts: 68

Original Poster
Rep: Reputation: 15
OK. I make it the hard way ! I installed also KDE, I follow the indications and... I succeed !
BUT !!!!
I hane the romanian keyboard installed, I can choose it, but when I work in openoffice, in Times New Roman, the diacritics (specific romanian signs) ARE NOT available, even if I am in the romanian keyboard !
Something is not OK !
How you solve the problem with your national specific signs ?
I must mention that on my computer I have also the win xp installed with the same openoffice 22 and there it is working perfectly with my national signs !
I also mention that I have installed the
"Microsoft's TrueType core fonts on rpm based systems"

Last edited by kantor_98; 04-19-2007 at 02:38 AM.
 
Old 04-19-2007, 03:38 AM   #7
kantor_98
Member
 
Registered: Jan 2007
Posts: 68

Original Poster
Rep: Reputation: 15
Solved ! I installed KDE, then I use:
KDE Control Center > Regional & Accessibility > Keyboard Layout > RO > Layout variant

and here I choose winkeys !!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard issues germansailor Linux - Hardware 1 12-19-2006 06:55 PM
serious keyboard issues germansailor Linux - Newbie 6 12-19-2006 05:44 PM
keyboard issues... c_olin3404 Slackware 16 07-23-2005 05:20 PM
Keyboard issues RockmanExe Slackware 5 12-07-2004 08:47 PM
Keyboard Issues TPupAZ Linux - Hardware 1 09-30-2004 02:40 PM


All times are GMT -5. The time now is 12:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration