LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2004, 02:20 AM   #1
citan
LQ Newbie
 
Registered: May 2004
Location: Romania
Distribution: Slackware 9.1
Posts: 4

Rep: Reputation: 0
Kernel 2.6.6 bootscreen resolution problem


Recently I've compiled kernel 2.6.6 and at boot I set vga=788 (800*600), but when it starts, it show in 460*400 mode. I use grub, Slackware 9.1, on a Pentium II 350Mhz, video onboard ATI Mach 64 - 4Mb platform.

Can someone help me?

PS: I have the patch-2.6.6-rc3, but I don't now how to patch my kernel. pls help on this one too.

Thanks
 
Old 05-22-2004, 09:11 AM   #2
jmorse
Member
 
Registered: Mar 2004
Location: United Kingdom
Distribution: LFS
Posts: 74

Rep: Reputation: 15
You may want to specify vga in hex, something like 'vga=0x113'.

Also check that you compiled in 'frame buffer' support.

Patching:
Copy the patch to the file below the source code eg:[/usr/src/kernel-patch.patch]
then cd into the source directory and run.

patch -Np1 -i ../kernel-patch.patch.

If you get errors about not finding files try using -Np0 instead.
 
Old 05-22-2004, 09:39 AM   #3
citan
LQ Newbie
 
Registered: May 2004
Location: Romania
Distribution: Slackware 9.1
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for patch apply method.

But about vga, it doesn't work with vga=0x113. I get this message from dmesg:

atyfb: 3D RAGE PRO (BGA, AGP) [0x4742 rev 0x7c] 4M SGRAM, 14.31818 MHz XTAL, 230 MHz PLL, 100 Mhz MCLK
fb0: ATY Mach64 frame buffer device on PCI
vesafb: abort, cannot reserve video memory at 0xfd000000
vesafb: framebuffer at 0xfd000000, mapped to 0xcd003000, size 4096k
vesafb: mode is 800x600x16, linelength=1600, pages=3
vesafb: protected mode interface info at c000:4ac6
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
fb1: VESA VGA frame buffer device
vga16fb: initializing
vga16fb: mapped to 0xcd404000
fb2: VGA16 VGA frame buffer device
VFS: Disk quotas dquot_6.5.1
.......
.......
Console: switching to colour frame buffer device 80x25

-------------------------I've tried "fbset -i":
mode "640x400-70"
# D: 25.172 MHz, H: 31.466 kHz, V: 69.923 Hz
geometry 640 400 640 6528 8
timings 39726 40 24 39 9 96 2
accel true
rgba 8/0,8/0,8/0,0/0
endmode

Frame buffer device information:
Name : ATY Mach64
Address : 0xfd000000
Size : 4190208
Type : PACKED PIXELS
Visual : PSEUDOCOLOR
XPanStep : 8
YPanStep : 1
YWrapStep : 0
LineLength : 640
MMIO Address: 0xfffffc00
MMIO Size : 2048
Accelerator : ATI Mach64GT

-------------------------...and fbset -i -fb /dev/fb1:

mode "800x600-75"
# D: 48.001 MHz, H: 46.876 kHz, V: 75.121 Hz
geometry 800 600 800 600 16
timings 20833 96 32 16 4 96 4
rgba 5/11,6/5,5/0,0/0
endmode

Frame buffer device information:
Name : VESA VGA
Address : 0xfd000000
Size : 4194304
Type : PACKED PIXELS
Visual : TRUECOLOR
XPanStep : 0
YPanStep : 0
YWrapStep : 0
LineLength : 1600
Accelerator : No

also I checked if Frame Buffer Support was included in the kernel, and it was.

It seems that /dev/fb0 can't show more than 460*400, if I load kernel2.6.4 on startup,everything works great (800*600, even 1024*724), but on 2.6.6 ....

I also notice a warning message and I don't know what it's wrong:
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.

Pls help!
 
Old 05-24-2004, 01:46 PM   #4
jmorse
Member
 
Registered: Mar 2004
Location: United Kingdom
Distribution: LFS
Posts: 74

Rep: Reputation: 15
Have you had the framebuffer working under 2.6 at all?
If a feature doesn't work, try the vanilla version of the kernel [without any patches]

Unable to explain, I resort to my setup, which works for me.

I have 'Support for frame buffer devices', compiled in, under
Device Drivers>Graphics Support

Also 'VGA 16-color graphics support' compiled in, not as a modules
and 'VESA VGA graphics support' in the same section.

Under 'Console Display Driver Support':
'Video mode selection support', 'Framebuffer Console support', 'Select compiled-in fonts', 'VGA 8x8 font' and 'VGA 8x16 font'.

Grub has 'vga=0x305' in the kernel section.

I get a 1024x768 console [without X] when I boot, and the penguin bootup logo [because I also compiled in everything under the 'boot logo' submenu.

Hope that helps...
 
Old 05-24-2004, 03:10 PM   #5
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Rep: Reputation: 30
Same here, and it works beautifully for me that way, make sure not to select your vid card but just vesa and vga support under there.
 
Old 05-24-2004, 03:14 PM   #6
rhash
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Rep: Reputation: 0
try setting in your grub vga=normal than go in and specifiy a resolution size in what ever you use to edit your resolution.

I know in SuSE i use sax2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Resolution problem w/ 2.6.9 Kernel + FC1 XsuX Fedora 1 11-16-2004 01:21 AM
bootscreen stops displayer with kernel-2.6.7 kudos Slackware 1 10-01-2004 04:06 PM
Console Resolution Problem After Kernel Update ShoCkwave Slackware 5 07-09-2004 10:53 AM
Mandrake Bootscreen wslyhbb Mandriva 0 12-12-2003 10:17 PM
Slack9 + Kernel Compile = Resolution Problem jim64 Slackware 13 07-19-2003 11:09 AM


All times are GMT -5. The time now is 03:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration