LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-08-2002, 02:14 PM   #1
John_Saunders
Member
 
Registered: Jun 2002
Location: Wilmington, NC
Distribution: Red Hat 7.2
Posts: 47

Rep: Reputation: 15
Just Upgraded to Apache 1.3.24 and It Won't Start!


I just upgraded my server running Red Hat 7.2 from Apache 1.3.20 to Apache 1.3.24 and for some reason it won't start. Here's what happens when I try to restart httpd:

[root@domain /]# /etc/rc.d/init.d/httpd start
Starting httpd: [Sat Jun 8 14:22:13 2002] [warn] NameVirtualHost MYIPADDRESS:80 has no VirtualHosts
[ OK ]
[root@domain /]

Does anybody know what I need to do to fix this? I compiled it into /usr/local/apache.

Before I upgrade Apache it was working fine so I'm hoping its just something simple.


Thanks,

John

Last edited by John_Saunders; 06-08-2002 at 02:26 PM.
 
Old 06-08-2002, 02:42 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
It's just a warning. Mine is doing the same, but it's starting.
 
Old 06-08-2002, 02:49 PM   #3
John_Saunders
Member
 
Registered: Jun 2002
Location: Wilmington, NC
Distribution: Red Hat 7.2
Posts: 47

Original Poster
Rep: Reputation: 15
Hi Mara......unfortunately, for me it doesn't seem to be working. My web pages aren't coming up and it keeps showing up in Webmin to 'Start Apache' instead of Restart.

I also tried changing the DocumentRoot to /var/www/html instead of /usr/local/apache in the httpd.conf file but that didn't help. Which setting is correct?


Best Regards,

John
 
Old 06-08-2002, 03:06 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Look it it's running using ps. If it is, but does not allow to connect, it's configuration problem (directory for apache). But if there's no httpd running, there's something more than it's writing. Look into /var/log/httpd for logs. Maybe there's something more.
BTW in my httpd.conf there's
NameVirtualHost 192.168.1
(This machine has local ip 192.168.1.1)

Last edited by Mara; 06-08-2002 at 03:08 PM.
 
Old 06-08-2002, 03:25 PM   #5
John_Saunders
Member
 
Registered: Jun 2002
Location: Wilmington, NC
Distribution: Red Hat 7.2
Posts: 47

Original Poster
Rep: Reputation: 15
Here's a copy of the last few lines in my error log:

[Sat Jun 8 13:58:46 2002] [error] (88)Socket operation on non-socket: accept: (client socket)
[Sat Jun 8 13:58:46 2002] [error] (88)Socket operation on non-socket: accept: (client socket)
[Sat Jun 8 13:58:46 2002] [error] (88)Socket operation on non-socket: accept: (client socket)
[Sat Jun 8 13:58:46 2002] [notice] caught SIGTERM, shutting down
[Sat Jun 8 14:01:04 2002] [warn] NameVirtualHost MYIPADDRESS:80 has no VirtualHosts
[Sat Jun 8 14:01:05 2002] [crit] (98)Address already in use: make_sock: could not bind to port 209
[Sat Jun 8 14:02:55 2002] [warn] NameVirtualHost MYIPADDRESS:80 has no VirtualHosts
[Sat Jun 8 14:02:55 2002] [crit] (98)Address already in use: make_sock: could not bind to port 209
[Sat Jun 8 14:14:29 2002] [warn] NameVirtualHost MYIPADDRESS:80 has no VirtualHosts
[Sat Jun 8 14:14:29 2002] [crit] (98)Address already in use: make_sock: could not bind to port 209
[Sat Jun 8 14:22:26 2002] [warn] NameVirtualHost MYIPADDRESS:80 has no VirtualHosts
[Sat Jun 8 14:22:26 2002] [crit] (98)Address already in use: make_sock: could not bind to port 209
[Sat Jun 8 14:38:43 2002] [warn] NameVirtualHost MYIPADDRESS:80 has no VirtualHosts
[Sat Jun 8 14:38:43 2002] [crit] (98)Address already in use: make_sock: could not bind to port 209


There's also at least a hundred lines of those (88)Socket operation errors as well.

Does this tell you anything as to why it isn't working?
 
Old 06-08-2002, 05:44 PM   #6
Noerr
Member
 
Registered: May 2002
Location: Dalec, HU
Distribution: Redhat 7.3
Posts: 696

Rep: Reputation: 30
what's up with your virutalhosts, do you have any at all?
 
Old 06-08-2002, 05:56 PM   #7
John_Saunders
Member
 
Registered: Jun 2002
Location: Wilmington, NC
Distribution: Red Hat 7.2
Posts: 47

Original Poster
Rep: Reputation: 15
I just figured out the problem. In one of my DNS configurations I had tried to point a domain name to an IP address that was assigned to another server. Apparantly, that was what was keeping it from starting. After I removed it, it started right up!

I just checked to see which version of Apache is running and it is saying 1.3.20 when I had just 1.3.24. I even tried restarting and it still didn't change.

Any ideas why it didn't update to the one I just compiled?


John
 
Old 06-09-2002, 01:46 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
The starting script you use is pointing to the old version. So edit the starting script to run the new version.
 
Old 06-09-2002, 03:36 PM   #9
John_Saunders
Member
 
Registered: Jun 2002
Location: Wilmington, NC
Distribution: Red Hat 7.2
Posts: 47

Original Poster
Rep: Reputation: 15
Do you know which file I need to edit to make this change?


John Saunders
 
Old 06-10-2002, 09:39 AM   #10
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
/etc/rc.d/init.d/httpd
It's a script. Usually quite long. So make a backup copy before editing. What you need is to replace /usr/sbin/httpd with the right path.
 
Old 06-10-2002, 10:23 AM   #11
John_Saunders
Member
 
Registered: Jun 2002
Location: Wilmington, NC
Distribution: Red Hat 7.2
Posts: 47

Original Poster
Rep: Reputation: 15
Mara,

I changed the path from /usr/sbin/httpd to /usr/local/apache/bin/httpd and after I restarted I went to the script I'm using, perldiver.pl, to show what the server is running. It came up with a 404 error and said 'Not Found
The requested URL /cgi-bin/perldiver.pl was not found on this server.


--------------------------------------------------------------------------------

Apache/1.3.24 Server at domain.com Port 80

So it's picking up the correct version, but when I tried to start Apache in Webmin it came up with this:

Failed to start apache :
Starting httpd: [ OK ]

I changed this section in the /etc/rc.d/init.d/httpd file and it appears to be why it won't start:

# Path to the httpd binary.
httpd=/usr/local/apache/bin/httpd
prog=httpd
RETVAL=0

When I changed it back to /usr/sbin/httpd, it started.

Just in case one of my settings in the Module Config section of Apache in Webmin may be causing the problem, I thought I'd list them:

Apache server root directory: /etc/httpd
Path to httpd executable /usr/local/apache/bin/httpd
Path to the apachectl command None
Command to start apache /etc/rc.d/init.d/httpd start
Command to stop apache /etc/rc.d/init.d/httpd stop
Display virtual servers as Icons
Order virtual servers by Server name
Maximum number of servers to display 100
Path to httpd.conf Automatic
Path to srm.conf Automatic
Path to access.conf Automatic
Path to mime.types /etc/mime.types
File to add virtual servers to httpd.conf
Test config file before applying changes? Yes


Do you have any other ideas?

Last edited by John_Saunders; 06-10-2002 at 10:27 AM.
 
Old 06-10-2002, 01:41 PM   #12
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Can you browse static pages?
If yes, there's one thing left - in /etc/httpd there is a directory "modules". It's a symlink. Mine is to /usr/lib/apache. You need to change this symlink to /usr/local/apache/lib (I'm not sure where is it in your case, but it'll be something similar).
 
Old 07-29-2002, 02:56 PM   #13
frankb
LQ Newbie
 
Registered: Jul 2002
Location: Philly
Distribution: RED HAT latest !!
Posts: 1

Rep: Reputation: 0
Wink [error] (88)Socket operation on non-socket: accept: (client socket) SOLUTION

for the issue of error logs generating: [error] (88)Socket operation on non-socket: accept: (client socket)

I have deleted any httpd.conf directives using LISTEN on <IP address> and the server started gracefully !!!
Please try that as you will probably see that the problem is Webmin is putting in that line for you under some circumstances that I don't know why ... maybe just in the .990 release !

Hope that helps, =Frank=
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
upgraded kde to 3.4, start menu blank? nextekcarl Mandriva 2 04-21-2005 09:42 AM
Upgraded Kernel - Now X Server Won't Start - No GUI Rexversusu Linux - Software 9 08-21-2004 07:42 AM
Upgraded from linux 2.4 to 2.6 now x won't start lynrees Debian 5 03-16-2004 05:43 PM
upgraded to sid, ignored cc mismatch and X wont start klod Debian 3 09-04-2003 04:57 AM
Apache and PHP upgraded jeremy LQ Suggestions & Feedback 0 02-27-2002 09:26 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration