LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 10-14-2004, 09:12 AM   #1
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
Java JRE


For my netbanking, I needed the java VM plugin. This was already installedd via Yast so I made the symlink to the plugin in my Firefox plugin map.
But then I couldn't start Firefox anymore. I checked the version: java2-jre1.4.2.

I downloaded the newest version of jre from Sun but when I want to upgrade the older version via Yast, the 2 packages have different names: 'java2-jre' for the old version and 'jre' for the new version. So I can't upgrade the old version. I wanted to delete the old version and install the new, but I'm not able to do, because of dependencies. (OpenOffice)

I just installed version 1.5, made the symlink in my Firefox plugins and a symlink in /usr/bin to the newer version of jre.

Firefox works but now both packages are installed. Isn't there a better way to solve this?

OS is Suse 9.1, Firefox is 1.0
 
Old 10-14-2004, 10:53 AM   #2
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
Yes, force remove the old version of JRE and re-install Ooffice if necessary. Although I dont think u need to reinstall office.
 
Old 10-15-2004, 06:00 AM   #3
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
So with the present state of my system, I remove the old version in Yast and when it complains about dependencies, I choose, "risk system inconsistency" ?

Last edited by merchtemeagle; 10-15-2004 at 10:00 AM.
 
Old 10-15-2004, 01:38 PM   #4
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
There must be some SuSe user who upgraded Java VM through Yast?
No one had this problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
issue with java JRE in SUSE Lasker Suse/Novell 5 06-26-2005 11:49 AM
Howto install/use java(jre)? eras Linux - Newbie 5 04-12-2005 05:05 PM
Sun Java jre 1.5.0.01 not working Rusty_L Linux - Software 7 03-04-2005 08:41 PM
Latest Java JRE doesn't seem to work kurt165749 Linux - Software 5 01-30-2004 01:37 PM
java jre luap Linux - Software 5 02-16-2003 11:41 PM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration