LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-02-2006, 07:53 PM   #1
rbautch
LQ Newbie
 
Registered: Jun 2006
Posts: 13

Rep: Reputation: 0
Isolinux ramdisk size


I'm booting a CD with ISOLINUX and loading my own initrd.img. When mounting the initrid.img, I initially got an error that there "wasn't enough space on the device", but when I adjusted the ramdisk_size parameter in the isolinux.cfg file, it worked fine. When the initrid.img is mounted, it uses 75% of the capacity on /dev/ram0. My problem is that when I use the cpio command to unpack an archive on an attached drive, the usage on /dev/ram0 jumps up to 100% and the command fails. How can I increase the size of /dev/ram0?
 
Old 07-02-2006, 08:51 PM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
ramdisk size is an option at kernel compile time...

for linux 2.4.x it's located at:

Block devices --> RAM disk support --> Default RAM disk size (NEW)

but yeah, if you wanna change the default size without recompiling, i *think* you just need to add a parameter like this (example) to your kernel's line in your isolinux.cfg:
Code:
ramdisk_size=8192

Last edited by win32sux; 07-02-2006 at 09:04 PM.
 
Old 07-03-2006, 11:03 AM   #3
rbautch
LQ Newbie
 
Registered: Jun 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by win32sux
ramdisk size is an option at kernel compile time...

for linux 2.4.x it's located at:

Block devices --> RAM disk support --> Default RAM disk size (NEW)

but yeah, if you wanna change the default size without recompiling, i *think* you just need to add a parameter like this (example) to your kernel's line in your isolinux.cfg:
Code:
ramdisk_size=8192
Thanks. Turns out the ramdisk_size parameter sets the maximum size of the ramdisk when the initrd.img gets mounted. What I needed to do was to intrease the size of the initrd.img itself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mkisofs: Error - boot image './isolinux/isolinux.bin' has not an allowable size. ogross74 Red Hat 2 05-15-2007 09:19 AM
Slow booting ramdisk (isolinux) Dark Carnival Linux - General 1 11-09-2004 04:07 PM
ramdisk size jonfa Linux - General 1 05-22-2004 01:22 PM
Set ramdisk size? TheOther1 Linux - General 6 02-22-2003 03:08 PM
ISOLINUX 1.75 2002-06-14 isolinux failed to get sector size tihe Linux - General 13 12-16-2002 04:55 AM


All times are GMT -5. The time now is 05:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration