LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-02-2006, 10:55 AM   #1
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Rep: Reputation: 15
Is it me or does Ubuntu apt-get suck?


i just got ubuntu and im trying to install any mp3 codec so i can play mp3s...but apt-get doesnt seem to have much...some forums suggested gstreamer0.8-plugins...but it doesnt accept it...it says the package has been moved or is obsolete etc...
and not much else works...help
 
Old 09-02-2006, 11:01 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
You may want to update your /apt/sources.list
http://paulstamatiou.com/2006/05/13/...-repositories/
 
Old 09-02-2006, 01:08 PM   #3
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Original Poster
Rep: Reputation: 15
ok...i followed the instructions on the site(thank you ) you gave and made slight changes...i had nost of the dapper ones....and i got gstreamer0.10-plugins-good from apt-get...but i still cant play mp3s....it still says that the codecs are missing...
 
Old 09-02-2006, 01:13 PM   #4
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Original Poster
Rep: Reputation: 15
and by the way...i have 'gb' for great britain infront of all the extra repositories...i guess it takes a shorter time...but is there a disadv to it?
 
Old 09-02-2006, 01:17 PM   #5
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Look at post #5 it may help;
http://www.linuxforums.org/forum/deb...wont-play.html
 
Old 09-02-2006, 01:53 PM   #6
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Original Poster
Rep: Reputation: 15
i added the sarge repository...but it still wont install libdvdcss and i still cant play mp3s...even after getting liblame0
 
Old 09-02-2006, 02:12 PM   #7
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Rep: Reputation: 30
Go to This Site and download the very small app. Follow the instructions to install and run it and in under 5 mins you will have mp3 and all sorts of other stuff up and running - no bother...


HTH

Mark
 
Old 09-02-2006, 02:26 PM   #8
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Original Poster
Rep: Reputation: 15
actually...i installed kaffeine...and it works fine on that...the problem is with totem player....but its al good...thanks for all your help..
and i do have easy ubuntu...thank you...
but i still dont get why i cant get a lot of the stuff from apt-get...o well..
 
Old 09-02-2006, 02:28 PM   #9
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Original Poster
Rep: Reputation: 15
aaaaaargh...its not working again...even in kaffeine player...no mp3s..this is just annoying...
 
Old 09-02-2006, 02:32 PM   #10
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 905
Blog Entries: 13

Rep: Reputation: 122Reputation: 122
Try following the steps described here : https://help.ubuntu.com/community/RestrictedFormats

P.S. what version of ubuntu are you using?
 
Old 09-02-2006, 03:41 PM   #11
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Original Poster
Rep: Reputation: 15
i have 6.06 ubuntu..
these are the errors when trying to install the multimedia stuff using easyubuntu...

W: GPG error: http://www.debian-multimedia.org sarge Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907

W: Duplicate sources.list entry http://gb.archive.ubuntu.com dapper/universe Packages (/var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_dapper_universe_binary-i386_Packages)
W: Duplicate sources.list entry http://packages.freecontrib.org dapper/free Packages (/var/lib/apt/lists/packages.freecontrib.org_plf_dists_dapper_free_binary-i386_Packages)
W: Duplicate sources.list entry http://packages.freecontrib.org dapper/non-free Packages (/var/lib/apt/lists/packages.freecontrib.org_plf_dists_dapper_non-free_binary-i386_Packages)
 
Old 09-03-2006, 05:37 AM   #12
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 905
Blog Entries: 13

Rep: Reputation: 122Reputation: 122
Try adding the sources using synaptic, or modify the sources.list file manually, then run sudo apt-get update or just click the reload button in synaptic.

Quote:
gstreamer0.10-plugins-good
It's normal Totem doesn't read MP3s with this, what you need is either totem-xine or the gstreamer ugly plugin set. For kaffeine and totem-xine, you'll need to install libxine extracodecs.

P.S. tried easyubuntu just now : messed things up pretty bad for me...
 
Old 09-04-2006, 12:16 PM   #13
flipwhy
Member
 
Registered: Jul 2006
Posts: 102

Original Poster
Rep: Reputation: 15
ok..thanks...makes a lotta sense...
got it to work...
need a dvd ripper too... tried installing the dvd::rip one...but when i test it (make test) it gives these errors which i cant find anything on after googling...

"make test
cd src && make
make[1]: Entering directory `/home/me/Downloads/dvdrip-0.98.1/src'
cc -o dvdrip-splitpipe dvdrip-splitpipe.c && mv dvdrip-splitpipe ../bin
/bin/sh: cc: command not found
make[1]: *** [../bin/dvdrip-splitpipe] Error 127
make[1]: Leaving directory `/home/me/Downloads/dvdrip-0.98.1/src'
make: *** [bin/dvdrip-progress] Error 2 "

any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu 5.10 apt-get error issey Ubuntu 7 01-25-2006 04:33 PM
Apt Get for Ubuntu carlosinfl Ubuntu 5 01-02-2006 01:11 PM
APT-GET In Ubuntu? carlosinfl Ubuntu 3 12-29-2005 09:02 AM
Ubuntu apt-get issues biojayc Linux - Software 2 08-22-2005 09:08 PM
Ubuntu (apt) repositories VertX Ubuntu 1 04-10-2005 07:39 AM


All times are GMT -5. The time now is 08:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration