LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2005, 01:15 PM   #16
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123

Try using a non-FC based livecd and see what kind of internet performance you get.
 
Old 08-01-2005, 01:16 PM   #17
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Matir
Try using a non-FC based livecd and see what kind of internet performance you get.
Good idea, Got Knoppix 3.9 ready to go.

BTW, in the Network settings, should I have a certain domain name for my PC, and what DNS servers should i have set? if that will help any
 
Old 08-01-2005, 01:21 PM   #18
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
DNS servers should either be your router or the DNS servers provided by your ISP. Some routers have very poor caching DNS servers so it can help to go upstream.
 
Old 08-01-2005, 01:55 PM   #19
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Original Poster
Rep: Reputation: 15
I have just tried with Knoppix, it automatically manages to connect to network properly (ie I can go to 192.168.1.1 Fine) but exactly the same as FC.
i can ping google.com and get results
i can ping msn.com and get no returns whatsoever

and visiting google.com gets me nowhere.

in Network settings, i got 192.168.1.1 set up as Primary DNS.
Also, in the router, it is set for Auto Discovery DNS Server, but in the next box for where you can manually specify them its got 139.175.55.224, Primary only.

i hope this information is useful

has anybody not ever had this problem before?

by the way, both PCs are using the Intel Pro 100+ PCI Network card
 
Old 08-01-2005, 02:00 PM   #20
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
My guess would be that you have a crappy router. Sorry. Now, we'll try to work around. Depending on your ISP, find out one of their nameservers, and replace the 192.168.1.1 in /etc/resolv.conf with the IP of that nameserver.
 
Old 08-01-2005, 02:12 PM   #21
comptiger5000
Member
 
Registered: May 2005
Distribution: Fedora Core Since version 3
Posts: 193

Rep: Reputation: 30
also, try plugging the pc into the internet directly, bypassing the router
 
Old 08-01-2005, 02:23 PM   #22
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Original Poster
Rep: Reputation: 15
The D-Link DSL-G604T Wireless ADSL Router . . . System Requirements: Computers with Windows, Mac or Linux Based Operation Systems with Installed Ethernet Adapter.

The router works fine, im using it to access the internet from a Windows XP computer, and resorting to windows on the linux box is the last thing I want to do.

Bypassing the router is not really an option, as I do not have a seperate ADSL modem, the ADSL Router is all I got.

I can access the router control panel fine from Linux (typing in 192.168.1.1 in firefox browser) and mess about there. Its just accessing websites that dont work. Is there a setting that I am overlooking?

Now to use the nameserver, I'll phone them up, well its out of hours now, I'll send an email.

I really do appreciate your help. I really do not want to give up on this and resort back to Windows. I want to be proud of a fully working linux system
 
Old 08-01-2005, 02:28 PM   #23
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
No problem. If you bear with us, we'll get you to a fully working system.
 
Old 08-01-2005, 03:06 PM   #24
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Matir
No problem. If you bear with us, we'll get you to a fully working system.
Im just glad your bearing with me and my seemingly uncurable problem

anyways, i tried doing replacing 192.168.1.1 in resolv.conf with 139.175.55.224 but no luck. infact, pinging that IP address from windows brings me no results, a dead IP address.

however, under Management IP tab in the Router Control Panel, there is:
IP address : 192.168.1.1
NetMask : 255.255.255.0
Default Gateway: 62.249.255.133
Hostname: mygateway
Domainname: ar7

I tried using 62.249.255.133 in resolv.conf also, but it dont work. The number is pingable however.
I only get the most results when the nameserver in resolv.conf is 192.168.1.1.
Thing is, pinging msn.com and others, they ping the proper IP address, and for msn.com i get the proper hostname, just no responses. with google.com i do get responses, I just can not seem to visit it with firefox.
 
Old 08-01-2005, 03:31 PM   #25
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
Try placing a different nameserver, such as one of the public DNS servers at granitecanyon.com in your resolv.conf. For your convenience, ns1.granitecanyon.com is 205.166.226.38.
 
Old 08-01-2005, 03:59 PM   #26
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Original Poster
Rep: Reputation: 15
Major Breakthrough!

It is somthing to do with IPv6
In firefox, you go to about:config and find network.http.disableIPv6 and set to True.

I can visit websites now! Including www.msn.com

But I musn't celebrate just yet.
Pinging msn.com still bears no fruit. Same with logging into IM programs.

I found this out by doing a search on my DSL-G604T router and linux and found this:
http://www.expansys.be/forumthread.a...551&thread=532

People there have had identical problems
Quote:
It's probably to do with DNS for ipv6. The router doesn't behave very well if your browser or app does a lookup for an ipv6 site.

Try the following to verify...
In firefox enter the following in the address box - about:config
the filter on dns and you should see the following line
network.dns.disableIPv6

Set this to true and restart.
If this speeds things up then you have the DNSv6 problem. Most linux distros provide some mechanisms to allow you to turn it off. You'll need to check how..

- RikD
So that leave me with disabling IPv6 in Fedore Core 4. If someone can point me in the right direction, that will be very much appreciated.

Matir, I will now go downstairs and try out your suggestion, see if that works.
 
Old 08-01-2005, 04:15 PM   #27
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
Type 'lsmod' and see if ipv6 is listed. If so, try 'rmmod ipv6' and see if that improves things any. Also try what I mentioned earlier.
 
Old 08-01-2005, 04:22 PM   #28
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Original Poster
Rep: Reputation: 15
I tried using your nameserver, but I get far better performance using 192.168.1.1
Infact, I could not even view linuxquestions.org using 205.166.226.38, maybe I need to re-enable IPv6 in Firefox for that?

IPv6 is listed when doing lsmod, however when using rmmod ipv6 i get the message "ERROR: Module ipv6 is in use"

I shall try from a fresh reboot.
 
Old 08-01-2005, 04:25 PM   #29
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
Yeah, make sure ipv6 is not in your /etc/modules.autoload.d or similar configuration.

Also, try maybe even deleting ipv6.ko (ipv6.o on 2.4) and then rebooting. (It would be somewhere in /lib/modules/`uname -r`/)
 
Old 08-01-2005, 04:51 PM   #30
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Matir
Yeah, make sure ipv6 is not in your /etc/modules.autoload.d or similar configuration.

Also, try maybe even deleting ipv6.ko (ipv6.o on 2.4) and then rebooting. (It would be somewhere in /lib/modules/`uname -r`/)
Im havin some difficulties locating modules.autoload.d in my /etc/ folder. Can not seem to find anything of a similar name. Im using Fedora Core 4.
Can not seem to find ipv6.ko in my lib/modules/[mykernel-FC4-etcetc]/ anywhere in here.

What I did manage to find is this:
/sys/module/ipv6/ with refcnt as file and sections as folder. Is it safe to delete this? Or renaming it?

I tried to use rmmod ipv6 -f, but it wont work, says Resource temporarily unavailable, but from what I have gathered, you must compile something in the kernel to allow this.

I am getting sooooo close to getting my internet on track.

Good news is, I can access this site on the same computer now No more running up and down the stairs
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet: Does not work darthcode Linux - Networking 26 04-20-2005 06:45 PM
I've got an IP but can't get internet to work! tentolga Linux - Networking 14 08-30-2004 06:04 PM
internet does not work MikeZila Linux - Networking 6 07-06-2004 02:11 AM
why won't the internet work? jimthing2001 Linux - Newbie 5 01-06-2004 06:40 PM
Internet won't work on RH 7.2 pilot1 Linux - Newbie 14 09-08-2002 08:32 AM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration