LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2007, 11:51 AM   #1
john83reuben
Member
 
Registered: Oct 2007
Location: Kuala Lumpur,Malaysia
Distribution: Debian Etch, OpenSuse
Posts: 132

Rep: Reputation: 17
Internet connection problem.Help


Hi guys. I have a problem here. I am using debian 4.0, and i installed a netinstall as a dual boot in my pc. My other OS is XP, After installing Debian, I cant have internet connection. If I use XP, there is no problem in connection,but the problem is in debian only. whle loading debian, i saw this line "not starting internet supersaver no service enabled", So I think the internet is not starting when i use debian.So Please help me to rectify the problem..Thank You
 
Old 10-12-2007, 12:12 PM   #2
gundumfx
Member
 
Registered: Jul 2007
Location: Linux( Fedora core 7 Admin)
Distribution: fedora core 7
Posts: 148

Rep: Reputation: 15
Quote:
Originally Posted by john83reuben View Post
Hi guys. I have a problem here. I am using debian 4.0, and i installed a netinstall as a dual boot in my pc. My other OS is XP, After installing Debian, I cant have internet connection. If I use XP, there is no problem in connection,but the problem is in debian only. whle loading debian, i saw this line "not starting internet supersaver no service enabled", So I think the internet is not starting when i use debian.So Please help me to rectify the problem..Thank You
well why don't you uninstall debian an install it back again an see what happens .
 
Old 10-12-2007, 09:29 PM   #3
john83reuben
Member
 
Registered: Oct 2007
Location: Kuala Lumpur,Malaysia
Distribution: Debian Etch, OpenSuse
Posts: 132

Original Poster
Rep: Reputation: 17
May I know what is this means "not starting internet supersaver no service enabled", Because I already tried installing full ubuntu installation.The network doesnt seem to work also..Pls Help
 
Old 10-13-2007, 07:00 AM   #4
john83reuben
Member
 
Registered: Oct 2007
Location: Kuala Lumpur,Malaysia
Distribution: Debian Etch, OpenSuse
Posts: 132

Original Poster
Rep: Reputation: 17
"not starting internet supersaver no service enabled"

May I know what is this means "not starting internet supersaver no service enabled", Because I already tried installing full ubuntu installation.The network doesnt seem to work also..Pls Help
 
Old 10-13-2007, 07:45 AM   #5
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Rep: Reputation: 30
When I first installed Debian, it took me ages to get the network working. Then I had a similar problem when I tried to get a local network up and running. I solved the problem by modifying /etc/network/interfaces to enable automatic network detection This I did by booting up Knoppix and copying it from there - it worked fine afterwards. I'll boot up Knoppix and post it later as I have subsequently changed this file to create a static IP address. Can't now, I've got kids to sort out!

Last edited by Tomermory; 10-13-2007 at 09:20 AM.
 
Old 10-13-2007, 09:16 AM   #6
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Rep: Reputation: 30
OK, I'm back. Now, I don't know how much you know about Linux, but I'll presume you know nothing, so please forgive me if you find me in any way patronising. Conversely, don't hesitate to ask for more precision if you don't know what the hell I'm on about. So, here goes.

1) First of all, we need to create a backup of your /etc/network/interfaces file, just in case something should go wrong. So, rename /etc/network/interfaces to /etc/network/interfaces.backup
2) Open a text editor (eg Kate or Kedit) and paste the following:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp
pre-up ifconfig eth0 up

allow-hotplug eth1
iface eth1 inet dhcp
pre-up ifconfig eth1 up

allow-hotplug eth2
iface eth2 inet dhcp
pre-up ifconfig eth2 up

3) Call this file interfaces and save it in /etc/network. Note, and this is very important, that there is no capital letter on interfaces. You mustn't make a spelling mistake either! If you ake a mistake, you'll get a black screen on boot up.

4) Now paste the following:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

5) Call this file interfaces- (note the hyphen) and save it in /etc/network. This file is probably unnecessary, but it won't hurt to put it in.

6) Now reboot. Cross your fingers. With any luck your network should be detected and you're away!

7) If you get a black screen, delete these two files and rename interfaces.backup to interfaces. Restart and you'll be back to normal.

Good luck!

James

Last edited by Tomermory; 10-13-2007 at 09:25 AM.
 
Old 10-13-2007, 11:22 AM   #7
gundumfx
Member
 
Registered: Jul 2007
Location: Linux( Fedora core 7 Admin)
Distribution: fedora core 7
Posts: 148

Rep: Reputation: 15
Quote:
Originally Posted by john83reuben View Post
May I know what is this means "not starting internet supersaver no service enabled", Because I already tried installing full ubuntu installation.The network doesnt seem to work also..Pls Help
yea you may know go to the following link to find help there

http://www.redtram.com/go/64157055/

an that is the only link i can find i tried googleing it
 
Old 10-14-2007, 12:20 AM   #8
john83reuben
Member
 
Registered: Oct 2007
Location: Kuala Lumpur,Malaysia
Distribution: Debian Etch, OpenSuse
Posts: 132

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Tomermory View Post
OK, I'm back. Now, I don't know how much you know about Linux, but I'll presume you know nothing, so please forgive me if you find me in any way patronising. Conversely, don't hesitate to ask for more precision if you don't know what the hell I'm on about. So, here goes.

1) First of all, we need to create a backup of your /etc/network/interfaces file, just in case something should go wrong. So, rename /etc/network/interfaces to /etc/network/interfaces.backup
2) Open a text editor (eg Kate or Kedit) and paste the following:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp
pre-up ifconfig eth0 up

allow-hotplug eth1
iface eth1 inet dhcp
pre-up ifconfig eth1 up

allow-hotplug eth2
iface eth2 inet dhcp
pre-up ifconfig eth2 up

3) Call this file interfaces and save it in /etc/network. Note, and this is very important, that there is no capital letter on interfaces. You mustn't make a spelling mistake either! If you ake a mistake, you'll get a black screen on boot up.

4) Now paste the following:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

5) Call this file interfaces- (note the hyphen) and save it in /etc/network. This file is probably unnecessary, but it won't hurt to put it in.

6) Now reboot. Cross your fingers. With any luck your network should be detected and you're away!

7) If you get a black screen, delete these two files and rename interfaces.backup to interfaces. Restart and you'll be back to normal.

Good luck!

James
Hi James...I have tried your way, but stil there is no internet connection. Actually, in my home, i have installed debian as dual boot, and this internet connection is not a problem..I can update and install stuff, but here in my college, i did the same way back at home, but there is no internet connection. Is that because of LAN. WMust I change any settings specifically because Im under LAN...Please help guys..
 
Old 10-14-2007, 06:20 AM   #9
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Rep: Reputation: 30
Ah yes, right, I see! OK, here I hope someone can verify what I'm saying (is there a Guru out there??) but I think the trouble is related to your IP address. I had a similar issue a few months ago: my Internet connection worked fine when the computer was isolated, but connected to another machine in an LAN network the Internet connection went down. I think that it's because at college you'll have a static IP address and that you'll need to specify this address in /etc/network/interfaces. You can do this in Debian in system-networking. You'll need to set the properties on one of the eths (on mine it's eth1) to become static and specify the college IP address in Gateway. Now, I'm not very certain about all of this myself so you'll need to check with someone who really knows. But you'll certainly need to find out what IP address your college network uses. Can someone please take over from here...?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
internet connection problem. bruse Linux - Networking 5 10-20-2005 05:09 PM
Internet connection problem ust Linux - General 7 06-08-2005 10:32 PM
Internet Connection Problem person Linux - Newbie 6 11-14-2003 12:49 PM
internet connection problem tumnus Linux - Networking 2 04-28-2002 10:21 PM
internet connection problem slobo Linux - Networking 4 09-10-2001 10:46 PM


All times are GMT -5. The time now is 06:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration