LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-27-2006, 04:23 PM   #1
LDJ
Member
 
Registered: Nov 2004
Posts: 80

Rep: Reputation: 15
Intel PRO Wireless 3945ABG: Help!


Ive just done my first real install of a Linux distro, installing Backtrack 2 on my laptop. Now thoug Im trying to get the wirless card working (a Intel Wireless 3945ABG) but dont really know where to start.

I downloaded a Linux driver off the Intel website which contained an INSTALL file, following this i got as far as the # ./load debug=0 command with a few minor errors mainly related to the tar commands ("Cannot change ownership to uid 100, gid 100: Operation not permitted" << I have no idea what this means or what caused it but it *seems* to extrac the files anyway?). However, when i type in the # ./load debug=0 command i just get the message "no such file or directory".

Can anyone explain what Im doing wrong and what I have to do to get my WLAN working in Linux?

Thanks (i really am just starting out so please be patient)





Code:
First, we build and install the ieee80211 subsystem.  You can obtain 
the latest ieee80211 subsystem from h**p://ieee80211.sf.net.  We 
recommend version 1.1.12 or newer:

	% tar xzvf ieee80211-1.1.12.tgz
	% cd ieee80211-1.1.12
	% make 
	# make install   <--- You may need to be root
	% cd ..

If you encounter problems with the above, you may need to install the 
ieee80211 sources into your kernel and then build it as part of your 
kernel image.  See the INSTALL and README.ieee80211 files provided in 
the ieee80211 subsystem package for more information.

Once the ieee80211 subsystem is installed, we build the ipw3945.ko module:

	% tar xzvf ipw3945-1.0.0.tgz
	% cd ipw3945-1.0.0
	% make

Now we install the firmware files (first finding where to install them):

	% wget http://bughost.org/ipw3945/ucode/ipw3945-ucode-1.13.tgz .
	% DIR=$(sed -ne "s:^FIRMWARE_DIR=\([^, ]*\).*:\1:p" \
		/etc/hotplug/firmware.agent)
	% tar xzvf ipw3945-ucode-1.13.tgz 
	% less ipw3945-ucode-1.13/LICENSE.ipw3945-ucode
	# cp ipw3945-ucode-1.13/ipw3945.ucode $DIR

NOTE:  'DIR' above typically works out to /lib/firmware.

Now we obtain the regulatory daemon:

	% wget http://bughost.org/ipw3945/daemon/ipw3945d-1.7.18.tgz.
	% tar xzvf ipw3945d-1.7.18.tgz
	% less ipw3945d-1.7.18/LICENSE.ipw3945d

Depending on your architecture perform one of the following	

For 32-bit systems:

	# cp ipw3945d-1.7.18/x86/ipw3945d /sbin

or for 64-bit systems:

	# cp ipw3945d-1.7.18/x86_64/ipw3945d /sbin

And now we can try to load the module, first clearing the kernel log:

	# ./load debug=0

Finally we can check to see if things worked:

	# iwconfig eth1

You should see something like:

eth1      unassociated  ESSID:off/any
          Mode:Managed  Channel=0  Access Point: 00:00:00:00:00:00
          Bit Rate=0 kb/s   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

And now you are ready to go.  Configure your AP using iwconfig:

	# iwconfig eth1 essid Whatever
	# iwconfig eth1 key DEADBEEF00
	# iwconfig eth1

eth1      IEEE 802.11g  ESSID:"Whatever"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:11:95:18:18:30
          Bit Rate=54 Mb/s   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:DEAD-BEEF-00   Security mode:open
          Power Management:off
          Link Quality=98/100  Signal level=-53 dBm  Noise level=-81 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

The specifics of how to bring up the interface is heavily dependent on 
the specific distribution you are using from here on out.
 
Old 12-27-2006, 04:38 PM   #2
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,593

Rep: Reputation: 162Reputation: 162
This looks like a pretty well designed instruction sheet. Load is a shell script:

./load

The ./ tells bash to forget about the PATH variable, and only look in the current working directory for the command. So, there is a file named load, somewhere, and you need to be in the same directory as load when you run ./load. Debug=0 is a parameter for the load script telling it to flush the kernel log, /var/log/syslog. Find load. If you cant find it, do this as root:

updatedb --prunepaths='/proc, /sys, /var/tmp, /tmp, /usr/tmp, /dev'

and wait until the prompt comes back. Then:

locate load | less

q to exit less.
 
Old 12-27-2006, 05:50 PM   #3
LDJ
Member
 
Registered: Nov 2004
Posts: 80

Original Poster
Rep: Reputation: 15
Excellent. thanks for your help.
I located the load script, but when i ran it i got:

Quote:
BT ipw3945-1.0.0 # ./load debug=0
Unloaded: ieee80211 ieee80211_crypt
insmod: can't read './ipw3945.ko': No such file or directory

Load failed.
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.18
2006-12-27
22:33:13: ERROR: opening /sys/bus/pci/drivers/ipw3945:
No such file or directory (2)
2006-12-27
22:33:13: ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection
any ideas what has gone wrong and how i rectify things?

thanks again...
 
Old 12-27-2006, 06:16 PM   #4
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,056

Rep: Reputation: 94
Code:
 BT ipw3945-1.0.0 # ./load debug=0
Unloaded: ieee80211 ieee80211_crypt
insmod: can't read './ipw3945.ko': No such file or directory

Load failed.
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.18
2006-12-27
22:33:13: ERROR: opening /sys/bus/pci/drivers/ipw3945:
No such file or directory (2)
2006-12-27
22:33:13: ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection
From the highlighted, it can't find the specified module. Try searching your system for that module. If you have it make a sym link or copy the module to the current directory. don't have a linux station in front of me so I can't find the modules directory. But I think they can be found under /lib/modules/`uname -r`/
 
Old 12-28-2006, 04:50 AM   #5
LDJ
Member
 
Registered: Nov 2004
Posts: 80

Original Poster
Rep: Reputation: 15
Thanks. That worked aswell! getting there slowly. LOL

Now I have loaded the module but I am hitting a problem at the stage :

Code:
And now you are ready to go.  Configure your AP using iwconfig:

	# iwconfig eth1 essid Whatever
	# iwconfig eth1 key DEADBEEF00
	# iwconfig eth1
When I enter my WPA encryption key for my WLAN I get the error:

Code:
Error for wireless request "Set Encode" (8B2A) : 
      invalid argument "<my wireless key>"
yet if I set it to DEADBEEF00 as in the example in the intel file, it sets fine.

Any ideas what that error means?

I wont have to go through this process every time I boot the machine will i?

Thanks again for the help - seems like im making a little progress at least!
 
Old 12-28-2006, 05:43 AM   #6
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,056

Rep: Reputation: 94
Not real familiar with BackTrack2 distro but you might want to build you a script with all the commands that you are typing and have it run on boot up.

as far as your error goes what is the full command that you are typing in. from the error stand point it means that you supplied the wrong argument.
 
Old 12-28-2006, 06:13 AM   #7
LDJ
Member
 
Registered: Nov 2004
Posts: 80

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jstephens84
Not real familiar with BackTrack2 distro but you might want to build you a script with all the commands that you are typing and have it run on boot up.
That's a good idea. How would I go about that then getting it to run automatically?

Quote:
Originally Posted by jstephens84
as far as your error goes what is the full command that you are typing in. from the error stand point it means that you supplied the wrong argument.
Im just typing in
Code:
iwconfig eth1 key j065467876
which is the key I use for the WLAN in windows. for some reason it doesn't seem to like it though?

Thanks again m8
 
Old 12-28-2006, 08:59 AM   #8
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,056

Rep: Reputation: 94
I think you have to tell it what key number it corresponds too like 1, 2, 3, 4.

to make the script just create a file and add in all the commands to the file. then chmod it to 755. then place it into what ever directory your distro looks into for startup scripts.
 
Old 12-28-2006, 09:04 AM   #9
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,056

Rep: Reputation: 94
http://tldp.org/HOWTO/Bash-Prog-Intro-HOWTO.html - tells you everything you need to know about scripting with bash for beginners.

http://www.linuxcommand.org/man_pages/iwconfig8.html - Iwconfig manual. shows you all the parameters you might need and how to use them.
 
Old 12-28-2006, 03:18 PM   #10
LDJ
Member
 
Registered: Nov 2004
Posts: 80

Original Poster
Rep: Reputation: 15
OK, making some progress here guys! (working hard for it mind!!! )

I now have The Wireless setup rinning - sort of. (Well, the WIFI light on the laptop is flashing lol!) Now though, I dont know how to configure the encryption. In KDE there is a wireless assistant which allows you to set your IP address, mask, gateway, DNS etc and also allows you to specify te WEP key. Thing is, my WLAN doesn't use WEP, but WPA-PSK (TKIP), but I dont know how to set and configure this?

Any hints welcomed again,

thanks
 
Old 12-28-2006, 03:54 PM   #11
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,056

Rep: Reputation: 94
Make sure your card supports this and also wireless assistant does not work that great when setting up wpa. That will have to be a manuall setting. What distro are you using again?
 
Old 12-28-2006, 04:02 PM   #12
LDJ
Member
 
Registered: Nov 2004
Posts: 80

Original Poster
Rep: Reputation: 15
Thanks again mate, Im using backtrack2 [http://www.remote-exploit.org/](not really sure this was the wisest choice for a starting distro, but in for a penny!)
 
Old 12-29-2006, 02:08 AM   #13
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,056

Rep: Reputation: 94
I would have to agree with you on that one. Before you get to involved with setting up your workstation with your current distro I would probably check out another distro. Either Ubuntu or Debian. If you don't mind to get your hands dirty then I really suggest Slackware. People say it's not for beginners but I have to disagree. Ubuntu also has pretty good driver support right out of the box. I am currently running it on my laptop but I am about to put slackware back onit.
 
Old 09-21-2007, 06:21 AM   #14
walter81
LQ Newbie
 
Registered: Sep 2007
Posts: 6
Blog Entries: 1

Rep: Reputation: 0
Smile succeded in installing the wireless card

Thanks alot guys for your help! your posts have been very useful, i would like to highlight some aspects:

1. You have to have the kernel source installed
2. after installing ieee80211 Reboot the PC

Then The MCC could recognise the wireless card (or ifconfig)

I run Mandriva 2007 Spring Free DVD on an HP nx6310 laptop

Walter
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Driver intel pro/wireless 3945ABG don't work lizburke29 Linux - Hardware 1 05-30-2008 05:44 PM
Very New to Linux. Need help with driver, etc Intel Pro/Wireless 3945ABG skizdigidy Linux - Wireless Networking 3 12-26-2006 04:45 PM
could not find intel pro/wireless 3945abg network connection verbose Linux - Hardware 22 10-03-2006 12:59 AM
Problem - Intel Intel(R) PRO/Wireless 3945ABG suresheva31 Fedora 2 09-18-2006 08:45 PM
Intel PRO/Wireless 3945ABG card not working in SuSE 10.1 iamjunko Suse/Novell 6 07-29-2006 01:10 PM


All times are GMT -5. The time now is 05:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration