LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-14-2010, 12:25 AM   #1
ufmale
Member
 
Registered: Feb 2007
Posts: 385

Rep: Reputation: 30
install older gcc using yum


Is there a way to install older version of gcc using yum?
I do a yum search, but it shows only the latest 4.5 version.
 
Old 05-14-2010, 01:59 AM   #2
alli_yas
Member
 
Registered: Apr 2010
Location: Johannesburg
Distribution: Fedora 14, RHEL 5.5, CentOS 5.5, Ubuntu 10.04
Posts: 559

Rep: Reputation: 92
Hi

Unfortunately by default yum will not allow you to install an older version of a package when a newer version is available.

However, there is a yum plugin that allows you to downgrade package versions - please see info here at the Fedora forum: http://forums.fedoraforum.org/showthread.php?t=200092

Note though that your yum repository needs to have older versions of the required package (in your case gcc) available - in order for the above to work.

Cheers
Yas
 
Old 05-14-2010, 02:17 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Post # 2 .... @ alli_yas
Quote:
Unfortunately by default yum will not allow you to install
an older version of a package when a newer version is available.
Sorry, not valid for gcc + the compat gcc packages. You can easily
have two to five compilers installed on Fedora 11 at the same time.
You will know that from the previous answer to @ufmale :
http://www.linuxquestions.org/questi...-gcc-804869/#2
..........................

And ufmale, have you still got Fedora 11 ?
yum install gcc-c++ compat-gcc-34-c++
.. will install versions 4.4.1 and 3.4.6 .
We are still waiting for you to answer,
if the gcc-3.4.6 worked for you. ? ? ? ?

For the other "compat", gcc-3.3.3 , gcc-4.1.3, etc. ,
you will have to download the packages from the links,
you already know.

'yum' can be used :
yum --nogpgcheck localinstall <package>

You may prefer 'rpm' chain install ..
rpm -Uvh <package> <package> <package> <package> <package>
..

Last edited by knudfl; 05-14-2010 at 02:44 AM.
 
Old 05-14-2010, 05:17 AM   #4
alli_yas
Member
 
Registered: Apr 2010
Location: Johannesburg
Distribution: Fedora 14, RHEL 5.5, CentOS 5.5, Ubuntu 10.04
Posts: 559

Rep: Reputation: 92
Wink

Quote:
Sorry, not valid for gcc + the compat gcc packages. You can easily
have two to five compilers installed on Fedora 11 at the same time.
Thanks - 100% - did not read the OP's post properly - you are 100% correct - I have done this myself with gcc and compat - where Oracle for example requires a particular version of these libs; and other applications require a different version

Thanks for the correction
 
Old 05-16-2010, 10:53 PM   #5
ufmale
Member
 
Registered: Feb 2007
Posts: 385

Original Poster
Rep: Reputation: 30
Thank you for your posts. I was trying to find an easy way since i am not really familiar much with linux installation. However, I will try that out.
 
Old 06-02-2010, 05:47 PM   #6
ufmale
Member
 
Registered: Feb 2007
Posts: 385

Original Poster
Rep: Reputation: 30
I finally got around to spend time installing gcc4.1 on my Fedora 11 machine.

However, I got problem with rpmlib dependency. Searching for internet for that module, but could not find the right one.
Downloaded couple of them, but couldn't install. Yum couldn't find it either.

I have no clue now. Can someone suggest any solution please?

Code:
[root@localhost Download]# rpm -Uvh gcc41-4.1.3_20080612-26.5.i586.rpm gcc41-c++-4.1.3_20080612-26.5.i586.rpm cpp41-4.1.3_20080612-26.5.i586.rpm libstdc++41-devel-4.1.3_20080612-26.5.i586.rpm libmudflap41-4.1.3_20080612-26.5.i586.rpm 
warning: gcc41-4.1.3_20080612-26.5.i586.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 3dbdc284
error: Failed dependencies:
	rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by gcc41-4.1.3_20080612-26.5.i586
	rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by gcc41-c++-4.1.3_20080612-26.5.i586
	rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by cpp41-4.1.3_20080612-26.5.i586
	rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by libstdc++41-devel-4.1.3_20080612-26.5.i586
	rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by libmudflap41-4.1.3_20080612-26.5.i586
[root@localhost Download]#
 
Old 06-03-2010, 07:56 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
rpm-4.7.0-1.fc11, 17-Apr-2009 : You may have this old version ?

# yum install rpm
.... will update rpm to version 4.7.1 with lzma included.
= rpm-4.7.1-1.fc11, 24-Jul-2009

....
 
Old 06-03-2010, 01:51 PM   #8
ufmale
Member
 
Registered: Feb 2007
Posts: 385

Original Poster
Rep: Reputation: 30
knudfl... you are very good.. Thanks. it works now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum install gcc doesn't set the lastest gcc ver 4.3.x kim,jw Linux - Newbie 3 12-23-2008 12:51 AM
Install Older Kernel with yum lebabyg Linux - General 5 06-27-2006 10:28 AM
Can't YUM update because LIBTOOL wants older GCC rvicker Linux - General 2 02-27-2006 07:58 PM
How can I install an older gcc thorney Fedora 1 11-25-2005 09:16 PM
Install older version of gcc s9902245 Linux - Newbie 1 09-16-2003 04:08 PM


All times are GMT -5. The time now is 01:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration