LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 12-04-2008, 10:35 AM   #16
Rsearcy
LQ Newbie
 
Registered: Nov 2008
Location: Indiana, USA
Distribution: openSUSE / SimplyMEPIS / Mandriva
Posts: 5

Rep: Reputation: 1

Here's one thing you might try:

First open a terminal.

Type: vi /etc/sysconfig/displaymanager

Move your cursor down until you see DISPLAYMANAGER_SHUTDOWN=

It should be followed by either "auto" or "all"
 
Old 12-04-2008, 10:48 AM   #17
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,043

Rep: Reputation: 83
Ok so lets try and see if you have the following. /etc/X11/gdm/gdm.conf If you do then lets edit it and see if you have the following key in there. SystemMenu = false if you see that change it to true. Then reboot or logout or both.
 
Old 12-04-2008, 11:29 AM   #18
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,069

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
This sounds interesting.

I use gnome on Ubuntu. Just out of interest, what comes up if you check your power management system. On mine there is an option to have the comp shut down when you press the power button. This is nice to have set in case you get a freeze for some reason.

Do you have the installation CD? Is it a Live CD? If you have and it is, try running from the CD and see if you have the reboot and shut down options there.
 
Old 12-04-2008, 03:04 PM   #19
ddclutch
Member
 
Registered: Dec 2008
Location: UK
Distribution: Suse Enterprise 10
Posts: 58

Original Poster
Rep: Reputation: Disabled
Ok,
First Widget:
I have done as you suggest. It now shuts down on the power button. It did before, but only if held off for 6 seconds, and then it simply powered off. Now it will shut down, doing so properly and progressively, after a simple press of the power button. So that is progress even if it isn't via the on-screen dialog. Thanks!
I don't have the installation CD and these Netbooks have no built in CD drive - I would need to get an external USB drive.

Guy
 
Old 12-04-2008, 03:15 PM   #20
ddclutch
Member
 
Registered: Dec 2008
Location: UK
Distribution: Suse Enterprise 10
Posts: 58

Original Poster
Rep: Reputation: Disabled
jstephens84:
I tried typing /etc/X11/gdm/gdm.conf but just get a :No such file or directory. The terminal opens with: linux:~ #
Should I be entering /etc/X... straight after this or do I need to change to a different directory first?

Rsearcy:
typing : vi/etc/sysconfig/displaymanager gets me the same response of No such File or Directory.

Maybe I am starting from the wrong directory in the Terminal window for this as well?

Sorry to be so dim; as I said, this is my first look at Linux.
But I do appreciate all your efforts to help!

Guy
 
Old 12-04-2008, 04:47 PM   #21
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,043

Rep: Reputation: 83
Oops forgot to tell you that you will need to place vi or vim before the /etc/X11/gdm/gdm.conf. This will open up the vi editor. Once you open that up you will press the down arrow and see if you find the specified input. If you find it press i so that it says insert and then change the false to true. Once finished just hit :wq to write quit. If you don't find it then just press :q! .
 
Old 12-04-2008, 07:49 PM   #22
ddclutch
Member
 
Registered: Dec 2008
Location: UK
Distribution: Suse Enterprise 10
Posts: 58

Original Poster
Rep: Reputation: Disabled
Nope! Still getting the same response.
My input line looks like this:
linux:~ # vi/etc/X11/gdm/gdm.conf

and it returns:
bash: vi/etc/X11/gdm/gdm.conf: No such file or directory
 
Old 12-04-2008, 09:27 PM   #23
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,043

Rep: Reputation: 83
Quote:
Originally Posted by ddclutch View Post
Nope! Still getting the same response.
My input line looks like this:
linux:~ # vi/etc/X11/gdm/gdm.conf

and it returns:
bash: vi/etc/X11/gdm/gdm.conf: No such file or directory
you need a space between vi and /etc/X11/gdm/gdm.conf
 
Old 12-05-2008, 05:18 AM   #24
ddclutch
Member
 
Registered: Dec 2008
Location: UK
Distribution: Suse Enterprise 10
Posts: 58

Original Poster
Rep: Reputation: Disabled
OK,
Getting something now. (it required a lower case x, as /x11/ not /X11/ which was how I read your message.)

Anyway, I now get a response E325: ATTENTION
found a swap file "/var/tmp/gdm.conf.swp"
followed by further details including "process ID 3336 (still running)"

If I ignore this and go to E (Edit anyway,
I then just get a page of tildes (~)
cursor keys don't take me down this page, which is full displayed anyway,

What now boss?
 
Old 12-05-2008, 08:11 AM   #25
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,043

Rep: Reputation: 83
ok lets step back and try this.
Code:
find / -name "gdm.conf"
this will search your entire hdd for gdm.conf which I really think is what you are using but I could be wrong. Post back what you get. gdm.conf.swap I believe is of no use to us. the above command is best ran as root.
 
Old 12-05-2008, 09:57 AM   #26
ddclutch
Member
 
Registered: Dec 2008
Location: UK
Distribution: Suse Enterprise 10
Posts: 58

Original Poster
Rep: Reputation: Disabled
Input line:
linux:~ # find / -name "gdm.conf"

Returns:
find: /proc/0: No such file or directory
find: WARNING: Hard link count is wrong for /: this may be a bug in your filesystem driver. Automatically turning on find's -noleaf option. Earlier results may have failed to include directories that should have been searched.
/etc/opt/gnome/gdm/gdm.conf
linux:~ #

I am logged in as root for all of this.

Guy
 
Old 12-05-2008, 10:24 AM   #27
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,043

Rep: Reputation: 83
Ok so it looks like it found the gdm.conf file under /etc/opt/gnome/gnome/gdm/ so lets edit the gdm.conf file under that location.
 
Old 12-05-2008, 11:15 AM   #28
ddclutch
Member
 
Registered: Dec 2008
Location: UK
Distribution: Suse Enterprise 10
Posts: 58

Original Poster
Rep: Reputation: Disabled
I ran that gdm.conf file and now get the idea what we are talking about!
I have looked carefully through it all and cannot find a SysteMenu=False key. Or anything similar. Most of the stuff there relates to log in and what settings result.

I did find:
Line 213.1 said "Whether you can shut down from GDM and Logout dialog"
AllowShutdown=true

So I assume I leave that as it is.
What's the protocol for exiting the gdm.conf without making changes?

Guy
 
Old 12-05-2008, 12:29 PM   #29
ddclutch
Member
 
Registered: Dec 2008
Location: UK
Distribution: Suse Enterprise 10
Posts: 58

Original Poster
Rep: Reputation: Disabled
Just had another look and found it!

It says:
SystemMenu=true
but it has a # so I assume this means it is a comment only. I can delete the # but how do I save this change and exit?

Guy
 
Old 12-06-2008, 03:46 AM   #30
ddclutch
Member
 
Registered: Dec 2008
Location: UK
Distribution: Suse Enterprise 10
Posts: 58

Original Poster
Rep: Reputation: Disabled
Thumbs up

SOLVED!
Did a bit of searching and found some info on how to use vi to edit the file and save changes.
activated "Allow Shutdown=true" by removing the #
activated "SystemMenu=true" by removing the #
enabled "Display last host login=true" by changing to true

Result!
From the normal desktop, if I go to shutdown it now brings up all 4 options: sleep; hibernate; reboot and shutdown. And they all work!

When I log out, it remembers my last login name for next time. I just enter my password

I can also shut down directly from the log-in screen if I wish.

So that is now all sorted! Thanks for the help, especially jstephens84

Now I need to fix my WiFi which appears not to exist, but I know it is in there somewhere! I will start a new thread.

Guy

Last edited by ddclutch; 12-06-2008 at 04:19 AM.
 
  


Reply

Tags
reboot, shut


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound doesn't work after sleep or hibernate, how to restart? lumix Linux - Hardware 1 12-16-2007 04:24 AM
Sleep and Hibernate on a New Dell D620 evillegas Linux - Laptop and Netbook 3 05-15-2007 01:38 PM
sleep/hibernate causes hardware failure St.Jimmy Linux - Hardware 0 02-11-2007 03:34 PM
Getting my laptop to Hibernate or Sleep Scott7 Debian 2 10-15-2005 05:33 AM
shut down and reboot options gone from gnome 2.10 acidjuice Slackware 9 04-06-2005 03:23 PM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration