LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-27-2006, 11:41 PM   #1
binary_0011
Member
 
Registered: Apr 2006
Location: Singapore
Distribution: RHEL4,FC4,FC5
Posts: 89

Rep: Reputation: 15
I cant ftp as root


it is very stange isn't it? I can ftp as other account ( andy, henson, peter..etc..) , I can ftp as anonymous. But I cant ftp as root.

is there anything i can check?

Thanks.
 
Old 07-27-2006, 11:50 PM   #2
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1; SUSE 13.2
Posts: 620
Blog Entries: 1

Rep: Reputation: 49
If I remember correctly, at least some linuxes will not allow ftp as root for security reasons.
 
Old 07-28-2006, 12:49 AM   #3
sambyte
Member
 
Registered: Feb 2006
Distribution: Redhat 9
Posts: 38

Rep: Reputation: 15
root cannot ftp by default

the security measures are such that root cannot ftp by default

to change the setting open the file vi /etc/vsftpd.ftpusers

and see that root is included in that list. this file only blocks access to ftp daemon . so in order to enable root to ftp simply remove root from that file and check ...
 
Old 07-28-2006, 01:31 AM   #4
binary_0011
Member
 
Registered: Apr 2006
Location: Singapore
Distribution: RHEL4,FC4,FC5
Posts: 89

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by sambyte
the security measures are such that root cannot ftp by default

to change the setting open the file vi /etc/vsftpd.ftpusers

and see that root is included in that list. this file only blocks access to ftp daemon . so in order to enable root to ftp simply remove root from that file and check ...
did that. i also did a service vsftpd restart , it still doesn't work.

i wasn't even prompt with a password and it said denied :

C:\Documents and Settings\myhost.somthing>ftp 198.123.218.127
Connected to 198.123.218.127.
220 (vsFTPd 2.0.1)
User (16.149.218.127none)): root
530 Permission denied.
Login failed.
 
Old 07-28-2006, 05:00 AM   #5
sambyte
Member
 
Registered: Feb 2006
Distribution: Redhat 9
Posts: 38

Rep: Reputation: 15
Hello,

ALso check the file /etc/shells ,your shell must be listed in /etc/shells.
But by the look of it seems that the option userlist_deny=YES is set in the /etc/vsftpd/vsftpd.conf file. remove that entry from that file and check

hope this helps
 
Old 07-28-2006, 05:10 AM   #6
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Why on earth would you want to ftp as root? Creating a new user for ftp'ing stuff, and perhaps a script for chmod'ing the needed files OR using a special group for accessing them does not take long, but adds to the security. Remember that ftp is not a secure protocol, and if you allow root ftp, then you actually allow anybody who gets to know the root password, to ftp-download your whole system. OR put some nifty rootkits on your machine, compromizing it completely without you even knowing it. Sounds nice? And I can tell you, stealing a root password is not even difficult, especially if your system's security is overall as low as in this case.

Root account should be used just and only for maintenance. sudo can be used, restricted, to grant the needed rights for needed users, and groups and file permissions can be used to achieve the needed freedom for stuff like ftp.

I really really hope you aren't really going to let root do ftp. Really.

Last edited by b0uncer; 07-28-2006 at 05:12 AM.
 
Old 07-30-2006, 09:42 PM   #7
binary_0011
Member
 
Registered: Apr 2006
Location: Singapore
Distribution: RHEL4,FC4,FC5
Posts: 89

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by b0uncer
Why on earth would you want to ftp as root?

dont worry, this is not a production server. I just wanted to test something on this server before moving it to production.
 
Old 07-30-2006, 10:38 PM   #8
binary_0011
Member
 
Registered: Apr 2006
Location: Singapore
Distribution: RHEL4,FC4,FC5
Posts: 89

Original Poster
Rep: Reputation: 15
i can ftp as root now. But i can only access my home drive and above. How do I access etc , var folder and etc?

Thanks.
 
Old 07-30-2006, 11:48 PM   #9
sambyte
Member
 
Registered: Feb 2006
Distribution: Redhat 9
Posts: 38

Rep: Reputation: 15
use the command lcd

hello,
use the command like lcd /home/, /var etc.....
it will take you to your other directories....

cd changes the directory in the server whereas lcd changes the directory in your local machine....

bye
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP with root v1nc3nt Linux - Newbie 1 05-23-2006 09:06 AM
root not able to do ftp tijo.thomas Linux - Software 1 03-03-2006 07:00 AM
ftp + root Morg666 Linux - Security 7 04-20-2004 05:19 PM
ftp to root rixride00 Linux - Newbie 7 04-02-2004 03:05 PM
ftp as root lenlutz Red Hat 3 02-18-2004 04:08 PM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration