LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2003, 03:35 PM   #1
tivoli pete
LQ Newbie
 
Registered: Oct 2003
Location: East Grinstead
Distribution: Fedora Core 1
Posts: 11

Rep: Reputation: 0
Thumbs up I can't get my Website to work on my local intranet.


I have set up a Linux server on my network, and I have Apache 2 installed, but when I try to access the default page using the localhost or its ip number, I just get page can't be found errors!

My distro' is RH 7.1 and initially, when I typed in the Linux server's hostname - I would get the info page, but not now. I have checked the httpd.conf, but can't see anything odd.

Can anyone help?

Thanks,

Tivoli Pete.


Last edited by tivoli pete; 10-13-2003 at 04:24 PM.
 
Old 10-12-2003, 03:38 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
If you replaced the default "Its working" page with your own, did you make sure its readable by all, etc? Can you get the page on the actual server itself by typing in your localhost IP? http://127.0.0.1

And you don't have any firewalls setup or anything on this server?
 
Old 10-12-2003, 05:05 PM   #3
tivoli pete
LQ Newbie
 
Registered: Oct 2003
Location: East Grinstead
Distribution: Fedora Core 1
Posts: 11

Original Poster
Rep: Reputation: 0
Thumbs down localhost does not work!

I have checked with http://127.0.0.0 and get a permission denied response. If I use localhost I get a message:

"The connection was refused when attempting to contact keyword.netscape.com"

Things all went pear shape after a power cut a few months back!

Tivoli Pete.

 
Old 10-12-2003, 05:45 PM   #4
coldy
Member
 
Registered: Nov 2002
Distribution: Debian GNU/Linux, Gentoo
Posts: 75

Rep: Reputation: 15
http://127.0.0.1 not http://127.0.0.0

this is your loopback address
 
Old 10-12-2003, 05:50 PM   #5
tivoli pete
LQ Newbie
 
Registered: Oct 2003
Location: East Grinstead
Distribution: Fedora Core 1
Posts: 11

Original Poster
Rep: Reputation: 0
Loopback address

Yes, sorry, that was a typo - whoops!

It gives the same response - "Connection refused"

Tivoli Pete
 
Old 10-12-2003, 06:09 PM   #6
coldy
Member
 
Registered: Nov 2002
Distribution: Debian GNU/Linux, Gentoo
Posts: 75

Rep: Reputation: 15
Ok, look what trickykid ask you, and look is the server already runing
 
Old 10-13-2003, 02:41 AM   #7
tivoli pete
LQ Newbie
 
Registered: Oct 2003
Location: East Grinstead
Distribution: Fedora Core 1
Posts: 11

Original Poster
Rep: Reputation: 0
Question This is where I look stupid!!

How do I stop and start the Web server? If I make a change to the httpd.conf file - do I then need to stop/start Apache to make the changes effective?

Tivoli Pete.

 
Old 10-13-2003, 09:06 AM   #8
coldy
Member
 
Registered: Nov 2002
Distribution: Debian GNU/Linux, Gentoo
Posts: 75

Rep: Reputation: 15
yes, you must restart apache to apply new settings. To restart it type
Code:
# service httpd restart
when you run
Code:
# service httpd
you'll see available options about this service
 
Old 10-13-2003, 10:44 AM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Also make sure you have read rights on the files your trying to access, say for instance, your index file??

chmod 644 index.html
 
Old 10-13-2003, 04:23 PM   #10
tivoli pete
LQ Newbie
 
Registered: Oct 2003
Location: East Grinstead
Distribution: Fedora Core 1
Posts: 11

Original Poster
Rep: Reputation: 0
Talking Success!

Restarting Apache has cured the problem. I possibly applied the fix, but never activated it - boy do I feel dumb!!

Thanks everyone for your help!

Tivoli Pete.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
restricting website access from local machine Stridier Linux - Networking 9 01-30-2006 05:26 AM
local users can't see website or get mail Michele Linux - Newbie 8 07-01-2004 02:00 PM
ping: unknown host in local intranet linuxjustin Linux - Networking 3 04-04-2004 03:03 PM
Unable to access local intranet computer by name thru squid MgF Linux - Networking 1 08-18-2003 09:31 PM
Using Konqueror to Browse Local Intranet sacants Linux - Newbie 1 02-21-2003 07:17 AM


All times are GMT -5. The time now is 11:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration