LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-09-2014, 04:15 AM   #16
xbg286
LQ Newbie
 
Registered: Jun 2014
Posts: 1

Rep: Reputation: Disabled
Problem solved


I would like report that I've had this issue on Lubuntu 14.04 and Firefox 29.0 I followed the instructions above and the black line is now gone.

Thank you very much because it was driving me crazy!
 
Old 06-09-2014, 01:24 PM   #17
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,195
Blog Entries: 10

Rep: Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986
Glad it worked out!
 
Old 06-11-2014, 01:09 AM   #18
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,475

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by Habitual View Post
Try:
Code:
    type about:config[Enter] 
    Promise to be careful 
    In the Search Bar type gfx.xrender.enabled 
    Right-click (F12) and Toggle to make it false 
    Exit Firefox. Open Firefox again.
Thanks Habitual. Your "promise to be careful" made me nervous. lol So I type "about:config" in the terminal? Then I am careful. Then in the search bar of Mozilla I type the gfx...thing. Then I right click (or hit F12) and Toggle to make it false. (What's "it"?)Then I exit Firefox and open it again and the black line is gone?

Oh great, this is working for everybody but me!

Last edited by Gregg Bell; 06-11-2014 at 01:12 AM. Reason: to have some fun
 
Old 06-11-2014, 03:31 AM   #19
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
So I type "about:config" in the terminal?
Nope, not in the terminal. That's your problem. You type about:config in the navigation bar of your browser. Then brace yourself for a rather hefty list.
jdk
 
1 members found this post helpful.
Old 06-11-2014, 09:42 AM   #20
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,195
Blog Entries: 10

Rep: Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986
Quote:
Originally Posted by Gregg Bell View Post
(What's "it"?)Then I exit Firefox and open it again and the black line is gone?
"it" specifically is the configuration element called "gfx.xrender.enabled"
Open a new tab in your browser and type "about:config" without the quotes.
Search for gfx.xrender.enabled
Right mouse click this value in your config editor and select Toggle.
This will turn the element's property value to false
Close the configuration editor tab.
Restart browser and you should be good to go.

a picture is worth a 1000 words
Here's what your may look like before changing this property's element value to false.

Last edited by Habitual; 06-26-2015 at 06:47 PM.
 
2 members found this post helpful.
Old 06-11-2014, 09:20 PM   #21
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,475

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by jdkaye View Post
Nope, not in the terminal. That's your problem. You type about:config in the navigation bar of your browser. Then brace yourself for a rather hefty list.
jdk
Thanks LZM jdk. You saved me, and Uncle Bob, from untold misery.
 
Old 06-11-2014, 09:24 PM   #22
Gregg Bell
Senior Member
 
Registered: Mar 2014
Location: Illinois
Distribution: Xubuntu
Posts: 1,475

Original Poster
Rep: Reputation: 85
Quote:
Originally Posted by Habitual View Post
"it" specifically is the configuration element called "gfx.xrender.enabled"
Open a new tab in your browser and type "about:config" without the quotes.
Search for gfx.xrender.enabled
Right mouse click this value in your config editor and select Toggle.
This will turn the element's property value to false
Close the configuration editor tab.
Restart browser and you should be good to go.

a picture is worth a 1000 words
Here's what your may look like before changing this property's element value to false.
Great stuff, Habitual! It worked perfectly. Before, I thought you were just telling me to be careful (in a general way) and so I got a little freaked. Now I can see what you were saying. Now I can start using Firefox (I'd been using Chrome because of the black line) again. Lots of people tried to solve this. You must be pretty good to be the one who did. Thanks tons!
 
Old 06-12-2014, 12:18 PM   #23
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,195
Blog Entries: 10

Rep: Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986
Quote:
Originally Posted by Gregg Bell View Post
Great stuff, Habitual! It worked perfectly. Before, I thought you were just telling me to be careful (in a general way) and so I got a little freaked. Now I can see what you were saying. Now I can start using Firefox (I'd been using Chrome because of the black line) again. Lots of people tried to solve this. You must be pretty good to be the one who did. Thanks tons!
Always glad to be of help.
 
1 members found this post helpful.
Old 10-21-2014, 05:35 PM   #24
zdanb
LQ Newbie
 
Registered: Oct 2014
Posts: 6

Rep: Reputation: Disabled
Worked

Quote:
Originally Posted by Habitual View Post
Try:
Code:
    type about:config[Enter] 
    Promise to be careful 
    In the Search Bar type gfx.xrender.enabled 
    Right-click (F12) and Toggle to make it false 
    Exit Firefox. Open Firefox again.
Thanks Habitual!
 
Old 12-14-2014, 06:20 AM   #25
freerk
LQ Newbie
 
Registered: May 2008
Posts: 9

Rep: Reputation: 0
Quote:
Originally Posted by Habitual View Post
"it" specifically is the configuration element called "gfx.xrender.enabled"
Open a new tab in your browser and type "about:config" without the quotes.
Search for gfx.xrender.enabled
Right mouse click this value in your config editor and select Toggle.
This will turn the element's property value to false
Close the configuration editor tab.
Restart browser and you should be good to go.

a picture is worth a 1000 words
Here's what your may look like before changing this property's element value to false.
Thanks! This finaly helped me solve this problem.
 
Old 05-03-2015, 08:26 PM   #26
dtrauma
LQ Newbie
 
Registered: May 2015
Posts: 2

Rep: Reputation: Disabled
Lightbulb Better way

Hey,

for my old intel gfx card I found a better way to work around this bug: switch from SNA to UXA acceleration. How to do this exactly differs in distributions, but usually you create an /etc/X11/xorg.conf with the content given here:

https://wiki.archlinux.org/index.php...ics#SNA_issues

This way you may fix graphics bugs elsewhere (for me, video playback works better with uxa, too) and still have hardware acceleration in firefox (much smoother scrolling, for example).
 
1 members found this post helpful.
Old 12-12-2015, 01:11 PM   #27
ghost123uk
LQ Newbie
 
Registered: Sep 2014
Location: Middle of the UK
Distribution: Lots !
Posts: 8

Rep: Reputation: Disabled
Quote:
Originally Posted by Habitual View Post
Try:
Code:
    type about:config[Enter] 
    Promise to be careful 
    In the Search Bar type gfx.xrender.enabled 
    Right-click (F12) and Toggle to make it false 
    Exit Firefox. Open Firefox again.
Just to thank Habitual, and let others know that this ^^^ worked for me.

It only happened after a routine update, so not sure what went wrong, but fine again now
 
Old 12-12-2015, 01:46 PM   #28
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,195
Blog Entries: 10

Rep: Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986
Glad it worked out for you also!
 
Old 12-15-2015, 12:50 PM   #29
zdanb
LQ Newbie
 
Registered: Oct 2014
Posts: 6

Rep: Reputation: Disabled
When Firefox 40 came out this quit working for me and all my other clients. All I got was a blank firefox window. I had to go in and create a new profile and go back in and set enable. Then I went into themes and added FXChrome theme. Now it works again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox 3 address bar hbar Linux - Software 1 06-16-2008 08:52 AM
Does firefox's address bar connect to google or something? dr_zayus69 General 1 04-29-2006 04:32 AM
Firefox Address bar problem iain.ross SUSE / openSUSE 2 03-23-2005 04:08 PM
Firefox - Autohighlight search and address bar notregistered Linux - General 2 03-01-2005 04:40 PM
firefox address bar marsques Linux - Software 3 07-23-2004 10:37 AM


All times are GMT -5. The time now is 08:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration