LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-25-2015, 08:11 PM   #1
Anil Kagi
Member
 
Registered: Aug 2014
Distribution: LinuxMint 17 Qiana Cinnamon
Posts: 149

Rep: Reputation: 0
How to write other language, [i.e. 'Kannada'] word documents in linux Mint 17


Hello everybody,

My system specifications: Samsung RV509, i3, 300GB HDD, 3GB Ram, Dual boot Windows7 & LM 17 cinnamon 32bit.

I have OpenOffice preinstalled on my system. I would like to create 'kannada' language word documents and be able to save them as windows .doc type file and/or .pdf file. [Kannada is the language of a state in south India.]

In case of windows; some 'kannada' language softwares called as 'Baraha' and 'Nudi' are available, that can be installed on a windows pc and 'kannada' language word documents can be created there.

These 'kannada' language softwares are not available for Linux.

However I want to be able to create 'kannada' language word documents on my Linux machine.

Is this possible? Could someone please kindly help me in this regard? I would be greatfull.

Thanks & Regards

Anil

Last edited by Anil Kagi; 01-25-2015 at 08:14 PM.
 
Old 01-25-2015, 10:32 PM   #2
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Hi,

as long as you have the fonts installed and the input method set up I think there should be no problem. See for example:
http://askubuntu.com/questions/26951...in-libreoffice

Evo2.
 
1 members found this post helpful.
Old 01-26-2015, 04:13 AM   #3
Anil Kagi
Member
 
Registered: Aug 2014
Distribution: LinuxMint 17 Qiana Cinnamon
Posts: 149

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by evo2 View Post
Hi,

as long as you have the fonts installed and the input method set up I think there should be no problem. See for example:
http://askubuntu.com/questions/26951...in-libreoffice

Evo2.
Thanks for coming Evo2,

And thanks for the link too.

Since I am new to Linux, I could not do part of what is suggested in the link. I did only part of what is said.

I did the following;

1] It was suggested in website, to remove all the mentioned scim pacakages, im-config. There were no scim pacakages installed on my system. But I removed the installed im-config.

2] It was suggested to to install the ibus. I did so successfully.

3] It was suggested to install the following pakages

ibus-m17n
ibus-table-extraphrase
ibus-gtk
ibus-gtk3
ibus-qt4
ibus-table
ibus-clutter

I did so successfuly.

But what I could not understand and could not do were the folllowing;

1] install the "Adjust methods for keyboard input"tools.

How?

I don't find anything of that kind in the 'Synaptic package manager'.

2] Choose the input method switch and make ibus as the choice.
A dialalogue box to restart X session appears choose ok.
Log out and login back to restart X session.

Where is the input method switch?

3] Go to ibus system tray icon choose preferences
click input method tab and kannada option which has kgp(nudi) ,inscript(nudi),itrans(baraha format)
choose them to the add to list .---done---

I don't find the ibus system tray icon.

I opened the LibreOffice word document and tried to type in kannada. It didn't.

I am confused. Please kindly help me.

Thank you

Regards

Anil

Last edited by Anil Kagi; 01-26-2015 at 04:14 AM.
 
Old 01-26-2015, 11:42 AM   #4
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,162

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
LibreOffice needs to be configured. Click on Tools - Options. Then select Language settings - Languages in the box that pops up. Then you mark the box "Enable complex text layout" and select Kannada in the drop-down menu labeled CTL.
 
Old 01-26-2015, 06:54 PM   #5
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Hi,

the exact dialogs change between versions. For example in newer versions of ibus-setup in the "General" tab, you can configure "Keyboad Shortcuts" including "Next input method" which will allow you to switch between direct input and the other input method(s) (Ie Kannada) that you have selected. Have you tried something like this?

Evo2.
 
1 members found this post helpful.
Old 01-27-2015, 09:40 PM   #6
Anil Kagi
Member
 
Registered: Aug 2014
Distribution: LinuxMint 17 Qiana Cinnamon
Posts: 149

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by evo2 View Post
Hi,

the exact dialogs change between versions. For example in newer versions of ibus-setup in the "General" tab, you can configure "Keyboad Shortcuts" including "Next input method" which will allow you to switch between direct input and the other input method(s) (Ie Kannada) that you have selected. Have you tried something like this?

Evo2.
Thanks Evo2, that solved the problem.

I typed 'ibus' in the menu search box and the GUI for the keyboard input appeared, then the rest was easy, the only key being, you need to restart, for things to come into effect.

That's nice of you Evo2.

Thanks for your compassion. Love you.

Ragards

Anil
 
Old 01-27-2015, 09:45 PM   #7
Anil Kagi
Member
 
Registered: Aug 2014
Distribution: LinuxMint 17 Qiana Cinnamon
Posts: 149

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by DavidMcCann View Post
LibreOffice needs to be configured. Click on Tools - Options. Then select Language settings - Languages in the box that pops up. Then you mark the box "Enable complex text layout" and select Kannada in the drop-down menu labeled CTL.
Thank you for coming, DavidMcCann.

I had done that as suggested in the link. But had trouble in finding the GUI for the keyboard inputs. Earlier I had typed 'keyboard inputs' and got a GUI. But that was different, not relating to ibus. Then I typed 'ibus', and that did the job.

Thanks for the helping hand.

Regards

Anil
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How do I program in shell script for write a word if it finds another word bal_nair1 Linux - Newbie 9 04-23-2012 07:28 AM
[SOLVED] How do I program in shell script for write a word if it finds another word bal_nair1 Programming 2 04-23-2012 02:41 AM
Need English Phonetic Key Board for Kannada Language gundya Linux - Newbie 1 01-24-2010 11:47 AM
Documents saved as MS Word documents Raggety Linux - Software 2 01-14-2009 03:16 PM


All times are GMT -5. The time now is 04:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration