LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-17-2010, 05:29 AM   #1
IlIl7
LQ Newbie
 
Registered: Oct 2010
Location: Europe mainly.. :D
Distribution: BackTrack 5
Posts: 14

Rep: Reputation: 0
How to turn Turtle-speed browsing into penguin-speed browsing?? :D


Hi everybody

I've just installed Slackware 13.1 in two different laptops for first time. I have some strange internet browsing behaviour in one of the laptops.

I've installed 2 internet browsers(firefox,opera) using the directions from Slackbuilds.org and there is also konqueror pre-installed. Moreover I installed Wicd network manager.

The problem:

I can browse some pages e.g. youtube with firefox very slowly but NEVER facebook.
I can browse almost any page, even facebook, with OPERA but very very slowly.
The same goes with konqueror...
Wicd shows that i am always connected with my WPA wireless network

Laptop details:
Quote:
Toshiba sattellite a100-209
//-----------------------------------------------
Processor Intel Celeron M 370 / 1.5 GHz
Databus-Speed 400 MHz
//-----------------------------------------------
Installed RAM 512 MB
Technology DDR2 SDRAM - 533 MHz
//-----------------------------------------------
Hard disk 80 GB - 5400 rpm
//-----------------------------------------------
Optical Drive DVD±RW (±R DL) / DVD-RAM
//-----------------------------------------------
Display-Type 15.4" TFT
Max. resolution 1280 x 800 ( WXGA )
//-----------------------------------------------
Graphic Card ATI Radeon Xpress 200M
Shared Memory 128 MB
//-----------------------------------------------
Soundcard Realtek ALC861
After having looked some other posts i think the folowing should matter.. :
Quote:
1) resolv.conf:
domain siemens
nameserver 192.168.1.1
2) nsswitch.conf-sis:
....
hosts: files nisplus nis dns
....
(that is the only line that DNS appears)
3) In firefox using about:config i already changed the following:
Set “browser.sessionhistory.max_total_viewers” to “0“
Set “network.http.pipelining” to “true”
Set “network.http.proxy.pipelining” to “true”
Set “network.http.pipelining.maxrequests” to some number like 10.
Set “network.dns.disableIPv6” to “true”
4) In Wicd
checked is only the "use encryption" box and it appears to be connected with SIEMENS-43D40C at 50%(192.168.1.2)
5) named.conf
Quote:
options {
directory "/var/named";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." IN {
type hint;
file "caching-example/named.root";
};

zone "localhost" IN {
type master;
file "caching-example/localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "caching-example/named.local";
allow-update { none; };
};
6) when i do dig www.facebook.com in terminal i get:
Quote:
; <<>> DiG 9.4.3-P4 <<>> facebook.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62224
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;facebook.com. IN A

;; ANSWER SECTION:
facebook.com. 3600 IN A 69.63.181.12
facebook.com. 3600 IN A 69.63.189.16
facebook.com. 3600 IN A 69.63.189.11

;; Query time: 27 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sun Oct 17 12:16:13 2010
;; MSG SIZE rcvd: 78
Hopefully sbdy shows me how to become a in browsing as well. Thanks in advance
 
Old 10-17-2010, 08:57 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,850

Rep: Reputation: Disabled
I notice that you are using your ISP's nameserver (192.168.1.1 indicates this). You could try changing this to a public DNS server. You can find a couple of them here. That may speed things up (or it may not).
ciao,
jdk
 
Old 10-17-2010, 01:30 PM   #3
IlIl7
LQ Newbie
 
Registered: Oct 2010
Location: Europe mainly.. :D
Distribution: BackTrack 5
Posts: 14

Original Poster
Rep: Reputation: 0
@jdkaye

Should i make these changes of dns in resolve.conf??? or somewhere else?

P.S. Please do not forget i m new in linux :d
 
Old 10-17-2010, 01:51 PM   #4
Kyle Lionheart
LQ Newbie
 
Registered: Nov 2006
Location: Italy
Distribution: Ubuntu, Debian
Posts: 21

Rep: Reputation: 2
In resolve.conf, yes.
Or, as 192.168.1.1 is probably your router's IP, you may want to change the DNS there to use the same ones everywhere in your network, and keep the router as nameserver on the PCs.

Also, if simply changing DNS doesn't work...are there other wireless networks in your area? You might want to try changing the wi-fi channel you are using in that case(on your router)
 
Old 10-17-2010, 04:10 PM   #5
IlIl7
LQ Newbie
 
Registered: Oct 2010
Location: Europe mainly.. :D
Distribution: BackTrack 5
Posts: 14

Original Poster
Rep: Reputation: 0
so i changed resolv.conf from:
Quote:
domain siemens
nameserver 192.168.1.1
to:
Quote:
nameserver 69.111.95.100
nameserver 63.251.62.33
using the page http://www.dnsserverlist.org/ as suggested above by @jdkaye.
However I still have very slow internet browsing and no facebook with any of the 3 browsers..
@Kyle Lionheart
I cannot change the WIFI channel because the router belongs to the house owner who lives above and doenst want to change anything....

The laptop belongs to my girlfriend and she looses her patient....
so please help to keep
 
Old 10-18-2010, 12:49 AM   #6
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,850

Rep: Reputation: Disabled
You can go to a website and test the speed of your connection and see if that is the problem. Here is one you can try. There are many others.
ciao,
jdk
 
Old 10-18-2010, 01:20 AM   #7
mesiol
Member
 
Registered: Nov 2008
Location: Lower Saxony, Germany
Distribution: CentOS, RHEL, Solaris 10, AIX, HP-UX
Posts: 731

Rep: Reputation: 137Reputation: 137
Hi,

first you should change the nsswitch.conf. The line
Code:
 hosts: files nisplus nis dns
should in you setup only contain
Code:
hosts: files dns
if there is no nisplus/nis service available.

Than change your dns as mentioned by IlIl7 to an official dns and not to your routers ip. My experience with some routers is, that they require up to 10 times longer for a dns result that a direct query to an official dns.
 
Old 10-18-2010, 06:21 AM   #8
IlIl7
LQ Newbie
 
Registered: Oct 2010
Location: Europe mainly.. :D
Distribution: BackTrack 5
Posts: 14

Original Poster
Rep: Reputation: 0
hi all again
tried everything u suggested but unfortunatelly nothing worked

my girlfriend lost her patience....
so this laptops just goes back to windows..

thanks everybody anyway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Boost your Browsing speed LXer Syndicated Linux News 0 10-27-2007 07:00 AM
Browsing Speed ajkannan83 Linux - Software 2 09-08-2006 12:16 AM
How to speed up Browsing? LeanPudLou Suse/Novell 6 02-17-2005 02:21 PM
How to speed up browsing? Gerd Linux - Networking 2 03-10-2004 06:54 AM
need tips to speed up browsing Brain Drop Linux - Software 2 04-23-2003 03:40 AM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration