LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2009, 08:50 AM   #1
medimus
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Rep: Reputation: 0
How to mount my ReadyNAS (without the expert vocabulary)


I have an Aspire one with Linpus lite and a ReadyNAS duo, and have spent hours trying to mount the NAS, but all the help files are in a Linux knowhow language that I don't understand. I would need a very basic and exact help how to do this.

I have enabled NFS on the NAS, which is on my (otherwise Windows) network at addres 192.168.2.4. The command nmblookup finds the NAS:
[user@localhost ~]$ sudo nmblookup - r NAS
querying NAS on 192.168.2.255
192.168.2.4 NAS<00>
So somehow I'm connected!

Then I have tried different commands to mount the NAS but with no luck. I have made the directory /media/netnas/ to mount it to, and tried to modify the file /etc/fstab (not mtab), since I get messages that the device is not listed there, but I don't understand how to (what is the device supposed to be called, "dev0" "dev1" etc is NOT common knowledge to a newbie).

I have a share on the NAS called ASPIRE, but the best would be if I could mount the root and go from there to ASPIRE (I also have shares named MEDIA and BACKUP).

So - can someone nice explain if/how I need to modify fstab/mtab and how I shall tell Linpus lite (Fedora 8 based) to mount my NAS, if possible automatically when I'm on my home network, or else how I can do it manually? I really have tried, spent months to try to learn how to do this, but now I'm giving up. I have a pretty good understanding of DOS commands, but I don't understand Linux!

If I have omitted some information about my system, please let me know!
 
Old 12-07-2009, 09:30 AM   #2
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
you'll want something like this in your fstab

192.168.2.4:/media /mount/point nfs defaults 0 0


the /media will vary depending on what you are exporting, I believe that is the default one that the readynas exports
 
Old 12-07-2009, 10:12 AM   #3
medimus
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
OK, and then... Why the "/media" and the "/mount/point", is that the exact command or am I supposed to modify it for my own use?
Do I need anything in mtab? How do I mount the NAS, having change the fstab? Shall i mount "NAS" or "192.168.2.4" or ?
 
Old 12-07-2009, 05:27 PM   #4
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,388

Rep: Reputation: 2199Reputation: 2199Reputation: 2199Reputation: 2199Reputation: 2199Reputation: 2199Reputation: 2199Reputation: 2199Reputation: 2199Reputation: 2199Reputation: 2199
Opps. Just confusing.
 
0 members found this post helpful.
Old 12-07-2009, 05:28 PM   #5
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
The line I gave was what you'd put in your fstab, you need to change /mount/point to wherever you want to mount the nas, like say /export/nas

/media comes from the nas, if you go into the nas admin webpages you can look at shares it has setup, I believe the default one is media.

You don't need to do anything in mtab, mtab is a file that gets modified by the mount command

if you want to mount from the command line it'd be something like mount -t nfs -o rw 192.168.2.4:/media /export/nas
 
Old 12-07-2009, 05:31 PM   #6
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
What I gave was the fstab entry though you need to change /mount/point to where you want to mount it (like /export/nas) make sure that directory exists
you don't need to do anything to mtab, it gets modified by mount

if you want to mount via command line it would be something like: mount -t nfs 192.168.2.4:/media /export/nas


the /media comes from the nas itself, you can go into the admin web pages and look at what shares it is making available, I believe media is the default one.
 
Old 12-08-2009, 06:54 AM   #7
medimus
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
OK, I have changed fstab according to your instructions and rebooted. No automatic mount (was is supposed to be automatic?) So I tried command line (and realized that folder names are case sensitive, I first tried "netnas" - response "no such folder"). This is the result:

[user@localhost ~]$ sudo mount -t nfs 192.168.2.4:/aspire /media/Netnas
mount: wrong fs type, bad option, bad superblock on 192.168.2.4:/aspire,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

There is a share on the Nas named aspire, with NFS enabled (read/write). Should I give up? I have no idea where to find or how to interpret syslog, nor what dmesg | tail means.

By the way - thanks a lot estabroo for trying to help me!!
 
Old 12-08-2009, 02:05 PM   #8
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
dmesg | tail -- this gives you the last few lines of the syslog file, it'll give you more information if an error occured that was reported there but not in the terminal you ran your mount command in

Do you have the nfs service turned on (under the Services -> Standard File Protocols)
 
Old 12-09-2009, 07:31 AM   #9
medimus
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
You don't understand - I am a newbie and can't interpret your advice:

I searched (from the root) for syslog and found 35 files with the name in it, none changed after Nov 1 2009. I tested the command from terminal and got this message:

[user@localhost ~]$ sudo dmesg | tail
FAT: Filesystem panic (dev mmcblk0p1)
fat_get_cluster: invalid cluster chain (i_pos 0) (+four identical rows after)

that makes no sense to me (the ReadyNAS is using a Linux based system, and I don't use FAT except FAT32 on my 4Gb expansion card (so I can read it from Windows) and some USB stick). The NAS has no problems with NTFS.

I have the NFS file system turned on in the NAS. If you mean in my Aspire one there is no folder Services, and if there is, how do I modify the standard file protocols if I have to?

Thanks for your patience!

Last edited by medimus; 12-09-2009 at 07:39 AM.
 
Old 12-09-2009, 05:13 PM   #10
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
The aspire shouldn't need anything special turned on. Are you sure the nas is at 192.168.2.4?

The Services -> Standard File Protocols is from the nas admin webpages, Services is a clickable item in the list on the lefthand side, it opens kind of a submenu that has a few items one of which is Standard File Protocols, selecting that opens up a page on the right that has a list of various services and allows you to turn them on and off, make sure NFS is turned on here, you also need to make sure its turned on for the aspire share.
 
Old 12-09-2009, 06:28 PM   #11
medimus
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
I have a pretty good idea about the NAS admin menues, and NFS has been turned on for the Share "aspire" all the time. I also have CIFS turned on to access it from my Win XP and Vista computers. And I'm positive the NAS is at 192.168.2.4, I even made a static ip for it. As I said first, I have a pretty good idea about DOS and Windows, its the Linux commands I don't know. And I'm about to give them up!
 
Old 12-10-2009, 09:59 AM   #12
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
Well if you've given up on nfs you can always mount the cifs instead. You'll need to have smbfs installed on your linux box then you can mount it with something like

mount -t cifs -o user=blah,pass=blah //192.168.2.4/aspire /media/Netnas

you might not need the user,pass

fstab entry would be similar

//192.168.2.4/aspire /media/Netnas cifs defaults,user=blah,pass=blah 0 0
 
Old 12-10-2009, 10:11 AM   #13
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
If you have an entry in /etc/fstab, post your fstab file here. You can try mounting it after booting, and the look for messages in /var/log/messages. "sudo mount /media/Netnas" (assuming /media/Netnas is your mount point). The other information such as filesystem and the IP are already in your fstab entry. Do you see any errors printed after entering the command? If so, also check near the end of your /var/log/messages file. It may provide more detailed information.

Also remember that Linux files and directories are case sensitive. You noted that you created a /media/netnas directory, but used "/media/Netnas" in your command.

Check if your distro has an nfs-client package. Do you have the file "/sbin/mount.nfs". If not, this could be the reason for the error message you received. I would expect /sbin/mount.nfs to be installed by default, and wouldn't fault anyone for expecting it as well. It is called by the mount command and if not found, the mount command may return the same "wrong fs type" error message you saw.

If you can mount it manually but it doesn't mount when you boot up, try adding the _netdev option in your fstab line. This will defer mounting your share until the network is ready. If there is a "noauto" option as well, this will prevent mounting automatically during bootup, but will also prevent bootup failures if there is a problem. This option is what you would add if a non-system partition went bad. Use it for removable drives or for a portable laptop that may not be connected to the network.

Last edited by jschiwal; 12-10-2009 at 10:32 AM.
 
Old 12-11-2009, 12:14 PM   #14
medimus
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Hi estabroo and jschiwal - I love you guys - despite the header of this whole conversation (...without the expert vocabulary) you don't realize your expertize. In Sweden we call this being "Home blind".

estabroo: "You'll need to have smbfs installed on your linux box..." and what is smbfs and how do I know if I have it, and how do I get it if i don't?? I have installed gparted, and it says the file system (I think that may be what you are talking about) is ext2. I tested your commands with cifs (i don't think the NAS is picky about user and pass) and they didn't work either. I also have installed Samba and Unison file synchronizer earlier in my efforts to connect, but I can't make any of them work.

jschiwal: the file var/log/messages is empty, and I posted the error message above (dec 9). I did understand that Linux is case sensitive (the folder I made is Netnas with N).

I can't find sbin/mount.nfs (is this the final clue??), there is mount.aufs, mount.cifs, mount.fuse, mount.ntfs, mount.ntfs-3g and mount.ntfs-fuse. I can read an USB-disk with ntfs, but not write to it. How can i find and install mount.nfs (in detail please)?? The ReadyNAS has a Linux based operative system as you probably know.

"try adding the _netdev option in your fstab line..." Seems like a good advice but how and where exactly do I add this (if i eventually manage to get in touch with my NAS)? Right now I would be so happy just to mount manually.

There is a lot of bad talk about Windows but as far as I'm concerned - it works.
 
Old 12-11-2009, 12:29 PM   #15
medimus
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Hey - some progress. I opened the Aspire Package manager and found some programs related to nfs, that i installed. Now i have the mount.nfs there! And the response to $ sudo mount -t nfs 192.168.2.4/aspire /media/Netnas is different:
"mount.nfs: directory to mount not in host:dir format"

At least it's not "panic" any more. But what's missing? I feel a little closer to a solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with English? Questions? Vocabulary, grammar... Post here :) frenchn00b General 1219 06-29-2015 01:15 PM
Soundcore Readynas DUO on Infrant/IT3107 CPU djfuzz Linux - General 0 08-01-2009 11:49 AM
backup question - NFS share in Ubuntu 9.04 backup to READYNAS NV+ newellrp1 Linux - Newbie 3 05-19-2009 04:57 PM
LXer: Using KVocTrain to Build Your Foreign Language Vocabulary LXer Syndicated Linux News 0 09-16-2007 04:21 AM
Expert Please eckomark Linux - Newbie 6 11-11-2001 01:06 AM


All times are GMT -5. The time now is 10:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration