LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2009, 02:54 PM   #1
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
how to make the user not to download using fire fox


Hi,

My friend has a cyber cafe.

He asked me to config firefox so that the users only can browse ,but cant download anything...

Is this possible...
 
Old 02-26-2009, 02:59 PM   #2
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
you might want to look into this firefox addon (rkiosk) https://addons.mozilla.org/en-US/fir...cation=firefox
 
Old 02-26-2009, 03:04 PM   #3
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
In about:config have a play with the settings that start browser.download or alternatively, set the download folder location to be /dev/null
 
Old 02-26-2009, 03:06 PM   #4
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
hmm.. but woudnt the second option still allow right click, save as to work?
 
Old 02-26-2009, 03:13 PM   #5
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Original Poster
Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by frieza View Post
hmm.. But woudnt the second option still allow right click, save as to work?
hello frieza ,am in trouble i just tried that,help me to return to original,am not getting any option....
 
Old 02-26-2009, 03:21 PM   #6
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
hmm
did you try edit.. preferences.. and change the 'save files to' back to Desktop ?
 
Old 02-26-2009, 03:31 PM   #7
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Original Poster
Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by frieza View Post
hmm
did you try edit.. Preferences.. And change the 'save files to' back to desktop ?
now my mozilla is in fullscreen mode,no url,no option,no menu ,no edit ,nothig here present...help me to restore....plzzzzzzzz............
 
Old 02-26-2009, 03:39 PM   #8
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
if you installed the kiosk addon maybe you need to remove it manually, which would be troublesome but not impossible
maybe this will help a bit
http://www.firefoxfacts.com/2008/12/...irefox-add-on/

you may have to removeit by hand

worst case scenereo, remove firefox, reinstall firefox
in the mean time i found some documentation on how to use rkiosk
http://davidstoker.org/blog/2008/05/...irefox-part-1/

Last edited by frieza; 02-26-2009 at 03:44 PM.
 
Old 02-26-2009, 04:02 PM   #9
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Original Poster
Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by frieza View Post
if you installed the kiosk addon maybe you need to remove it manually, which would be troublesome but not impossible
maybe this will help a bit
http://www.firefoxfacts.com/2008/12/...irefox-add-on/

you may have to removeit by hand

worst case scenereo, remove firefox, reinstall firefox
in the mean time i found some documentation on how to use rkiosk
http://davidstoker.org/blog/2008/05/...irefox-part-1/
i am totally messed up,samething happens after uninstall and reinstall...
 
Old 02-26-2009, 04:35 PM   #10
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
hmm, try uninstalling firefox
then look in your home directory under .mozilla/firefox, removing all the files there
then as root look in /usr/lib (or lib64 if it's a 64 bit linux) for firefox directories, remove the contents of those
then reinstall firefox
 
Old 02-26-2009, 04:41 PM   #11
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
now my mozilla is in fullscreen mode,no url,no option,no menu ,no edit ,nothig here present...help me to restore....plzzzzzzzz............
press F11 ?
 
Old 02-26-2009, 05:08 PM   #12
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
if he installed rkiosk, F11 may be disabled
 
Old 02-26-2009, 11:34 PM   #13
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Original Poster
Rep: Reputation: 135Reputation: 135
oh my god,finally I removed the contents of .mozilla in the home directory and install again..done..

but all my bookmarks gone ....
 
Old 02-26-2009, 11:43 PM   #14
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Original Poster
Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by XavierP View Post
In about:config have a play with the settings that start browser.download or alternatively, set the download folder location to be /dev/null
I just did that and my firefox crashes and restarted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fire fox 3.01 als2we Linux - Newbie 2 09-13-2008 01:28 PM
How to replace fire fox 1.5.0.9 with fire fox2 in mepis 6.0 inspiron_Droid LinuxAnswers Discussion 0 02-21-2007 02:19 PM
Fire fox and me tkienzle Linux - Software 7 02-03-2005 09:14 PM
Fire fox paul62 Linux - Software 9 08-07-2004 10:10 PM
Fox fire me .... AndreL Linux - Newbie 9 03-15-2004 11:39 AM


All times are GMT -5. The time now is 02:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration