LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-14-2006, 04:01 PM   #1
Harpo
Member
 
Registered: Mar 2006
Location: Canada
Distribution: Suse 10.0 Retail, 10.1, 10.2, 11.1, Edubuntu 7.04, Mandriva 2010
Posts: 89

Rep: Reputation: 15
How To Make Permissions For New Hard Drive?


Hello

I have installed a new SATA hard drive to my computer. I have partitioned it, formatted the partitions (1 reiserfs, and 1 VFAT). I have automatically mounted it so that it mounts at boot. My problem is that I can't seem to use the hard drive because only root can make changes to the drive. How do I change the permissions so that I can use the drive without being root? Any help would be greatly appreciated.

Thanks
 
Old 04-14-2006, 04:53 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
once you've mounted it then you can forget that it is a seperate device when the mounted partition is unix compliant. just use chown / chmod to change the permissions and ownership of whatever you want. if it's for the vfat then you would set the umask or uid / gid directly in the /etc/fstab file as vfat can't handle per file permissions and ownership.
 
Old 04-14-2006, 07:52 PM   #3
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Edit the part of your fstab that mounts the fat drive to say users,defaults,umask=000 in the options section this will give users read/write. Mount folder must be ownd by group users. Read more on permissions for greater customization.

regards,
...drkstr
 
Old 04-14-2006, 10:06 PM   #4
Harpo
Member
 
Registered: Mar 2006
Location: Canada
Distribution: Suse 10.0 Retail, 10.1, 10.2, 11.1, Edubuntu 7.04, Mandriva 2010
Posts: 89

Original Poster
Rep: Reputation: 15
Thanks for the help. I now have the access required for the reiserfs partition, but no luck on the VFAT partition. I can't seem to change the ownership of the drive. I have modified the fstab to say, as suggested, users,default,umask=000, to no avail. I have also tried chown to change ownership as with reiserfs, but get told that operation not permitted. Any further advice on this one?
 
Old 04-15-2006, 12:56 AM   #5
Harpo
Member
 
Registered: Mar 2006
Location: Canada
Distribution: Suse 10.0 Retail, 10.1, 10.2, 11.1, Edubuntu 7.04, Mandriva 2010
Posts: 89

Original Poster
Rep: Reputation: 15
A quick addendum to my last post. It seems as though I need to change the group to users. How exactly do I do that? The drive is root root currently. Root users would work just fine. So, my question is how do I change the group to users?
 
Old 04-15-2006, 02:24 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
like you have the umask value there you can also use uid=xxx and/or gid=xxx but if you are using a umask of 000 then that will allow full access irrespective of groups.
 
Old 04-15-2006, 01:33 PM   #7
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
did you change the ownership of the folder you are mounting it under? I'm assuming it is still owned by root. do a 'chgrp users /mnt/fat' to give r/w access to that folder for the group users, or 'chown user /mnt/fat' for a particular user. This should work with the options users,defaults,umask=000 0 0 in the fstab. The last two 0's just means that it will not force a filesystem check. It can be kind of buggy for fat drives.

regards,
...drkstr
 
Old 04-16-2006, 12:18 PM   #8
Harpo
Member
 
Registered: Mar 2006
Location: Canada
Distribution: Suse 10.0 Retail, 10.1, 10.2, 11.1, Edubuntu 7.04, Mandriva 2010
Posts: 89

Original Poster
Rep: Reputation: 15
Thanks to everyone for the help. I found that I had to unmount the drive before I could make the changes to it, then remount it and all was just the way I wanted it. I really appreciate the responses I received. I only hope that someday I'll be knowledgeable enough about Linux to be able to help others as well.
 
Old 04-16-2006, 05:52 PM   #9
Harpo
Member
 
Registered: Mar 2006
Location: Canada
Distribution: Suse 10.0 Retail, 10.1, 10.2, 11.1, Edubuntu 7.04, Mandriva 2010
Posts: 89

Original Poster
Rep: Reputation: 15
I spoke too soon. Upon rebooting my machine, drive changed back to root root. Any further assistance on this matter will once again be much appreciated.
 
Old 04-16-2006, 08:44 PM   #10
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
please list the entry in your fstab that mounts your fat drive. I'll be able to tell you what to fix. Also, make sure your drive is not mounted when you change the ownership of the folder you are mounting it to. I'm not sure if it matters or not but I think it does.

...drkstr
 
Old 04-18-2006, 10:57 PM   #11
Harpo
Member
 
Registered: Mar 2006
Location: Canada
Distribution: Suse 10.0 Retail, 10.1, 10.2, 11.1, Edubuntu 7.04, Mandriva 2010
Posts: 89

Original Poster
Rep: Reputation: 15
Thanks once again. I managed to get it solved. I'm not even sure what it was that I did. But, all is fine now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Drive Permissions djljjm Linux - Newbie 2 04-22-2005 03:00 PM
Hard Drive Permissions djljjm Linux - Newbie 3 04-18-2005 04:35 PM
Hard Drive Permissions djljjm Linux - Newbie 1 04-18-2005 12:29 PM
Hard drive permissions R¬dical_úD SUSE / openSUSE 3 01-10-2005 08:20 AM
hard-drive permissions Airburned Linux - General 4 07-13-2003 01:10 PM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration